Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Не поддерживается Realtek PCI-Express card reader на базе rts5229  (Прочитано 2600 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexusnet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Здравствуйте дорогие линуксиды ))). Прикупил я себе новый ноутбук hp Pavilion g7  и сразу же залил туда новую ОС Ubuntu 12.04.  Радости не было предела, все красиво, чинно и без тормозов. Да вот не задача, не определился у меня одно устройство. Им оказался карт-ридер rts5229 компании Realtek Semiconductor Corp.
на сайте производителя я скачал исходники, да вот только при компиляции он ошибку выдает:

sudo make
[sudo] password for alexusnet:
cp -f ./define.release ./define.h
make -C /lib/modules/3.2.0-29-generic/build/ SUBDIRS= modules
make[1]: Вход в каталог `/usr/src/linux-headers-3.2.0-29-generic'
make[2]: *** Нет правила для сборки цели `arch/x86/tools/relocs.c', требуемой для `arch/x86/tools/relocs'.  Останов.
make[1]: *** [archscripts] Ошибка 2
make[1]: Выход из каталога `/usr/src/linux-headers-3.2.0-29-generic'
make: *** [default] Ошибка 2

Подскажите, пожалуйста, на что компилятор ругается? )))))
Кстати у меня 64-разрядная машина на процессоре AMD A10
вот еще...
вывод lspci:
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5229 (rev 01)
   Subsystem: Hewlett-Packard Company Device 184c
   Flags: bus master, fast devsel, latency 0, IRQ 3
   Memory at f0100000 (32-bit, non-prefetchable) [size=4K]
   Capabilities: <access denied>
вывод uname -a:
Linux alexusnet-PC 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
« Последнее редактирование: 27 Август 2012, 22:11:33 от alexusnet »

Оффлайн alexusnet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Решил проблему установкой недостающих пакетов:
sudo apt-get install scons pkg-config g++ libgtk2.0-dev libglib2.0-dev libglade2-dev libpthread-stubs0-dev zlib1g-dev libbz2-dev libssl-dev

Просто не хватало какого-то из этих пакетов...  )))

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
lspci -knn | grep "Eth\|Net" -A2
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
блин, у меня тоже проблема 12.04
root@maxoft-ZBOX-ID84:/usr/src/linux-headers-3.2.0-49-generic-pae# make oldconfig && make prepare && make scripts
scripts/kconfig/conf --oldconfig Kconfig
#
# configuration written to .config
#
scripts/kconfig/conf --silentoldconfig Kconfig
make[1]: *** Нет правила для сборки цели `arch/x86/tools/relocs.c', требуемой для `arch/x86/tools/relocs'.  Останов.
make: *** [archscripts] Ошибка 2
root@maxoft-ZBOX-ID84:/usr/src/linux-headers-3.2.0-49-generic-pae#
ХЕЛП!

Пользователь решил продолжить мысль 01 Август 2013, 23:07:14:
опять плюнул, всё ок
cd /usr/src
apt-get source linux-headers-`uname -r`
cd linux-3.2.0
« Последнее редактирование: 01 Август 2013, 23:07:14 от victor00000 »
Нельзя друзья, дулу - AnrDaemon видите?
~.o

 

Страница сгенерирована за 0.181 секунд. Запросов: 25.