Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Проблемма с GD lib  (Прочитано 1323 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Programmer

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Проблемма с GD lib
« : 02 Февраль 2008, 14:01:38 »
Доброго времени суток!
Вот решил я себе поставить Ubuntu на сервер, все настроил все хорошо.. Но недавно понадобилась GD библиотека для PHP... Через apt-get установил php5-gd и тут началось... Посыпались ошибки вот такого содержания PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so' - /usr/lib/php5/20060613+lfs/gd.so: undefined symbol: gdImageCreateFromPng in Unknown on line 0Несколько дней гугления и прочих плясок с бубном ни к чему не привели... Может быть кто-нибудь знает в чем проблемма?

Оффлайн Programmer

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Проблемма с GD lib
« Ответ #1 : 04 Февраль 2008, 15:51:41 »
Ну неужто никто не занает в чем проблемма? Или хоябы в каую сторону рыть?

Оффлайн xmig

  • Любитель
  • *
  • Сообщений: 98
    • Просмотр профиля
Re: Проблемма с GD lib
« Ответ #2 : 04 Февраль 2008, 21:21:10 »
На первый взгляд не хватает какой-то библиотеки или компоненты. У меня были похожие симптомы, правда с другой программой. Попробуй набрать
sudo apt-get install -fэто проверит зависимости и восстановит отсутствующие пакеты.

Оффлайн kipelovets

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Проблемма с GD lib
« Ответ #3 : 09 Август 2009, 17:36:33 »
у меня такая же проблема. кто-нибудь нашел решение?

 

Страница сгенерирована за 0.053 секунд. Запросов: 22.