Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Инструкции по установке драйвера nvidia-96 в Ubuntu 11.04 и старше (Закрыто)  (Прочитано 1644 раз)

0 Пользователей и 1 Гость просматривают эту тему.

vizuxe

  • Автор темы
  • Гость
Тема закрыта. Теперь обсуждение инструкций ведется здесь
« Последнее редактирование: 05 Июль 2013, 14:43:10 от vizuxe »

Оффлайн йцуаы

  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
на сколько понимаю ключивым моментом здесь являетса  уменшение версии икс орг так вот по ссылке пусто
http://packages.ubuntu.com/maverick/x11/
зы пытаюсь провернуть ваш рецепт на xubuntu 12.10 nvidia fx 5200

vizuxe

  • Автор темы
  • Гость
Да, действительно ссылка перестала работать (Только что тоже обнаружил ;D. Хотя ссылка http://packages.ubuntu.com/maverick/x11/ работала на момент написания статьи). Дело в том, что Ubuntu 10.10 уже перестали поддерживать и все ее репозитории перенесли на http://old-releases.ubuntu.com что несколько усложняет задачу т.к там все пакеты разбросаны и перемешаны  :-\. Попробую найти эти же пакеты и надо бы их еще упаковать в архив.
Пока попробуйте скачать эти же пакеты здесь http://packages.ubuntu.com/lucid/x11/ , это репозиторий Ubuntu 10.04.

Оффлайн йцуаы

  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
в общем попробовал поставить ручным способом предварительно понизив версию xorg до 1.11 ( инсталлятор просил 1.11,1.12  ставил с репризатория 12.4 )ругает ядро мол не то
поднял тему тут как то глухо с рецептами
з.ы. попробую собрать пакеты из вашей ссылки
з.з.ы. с ядром как понимаю тоже довнграуд ?
« Последнее редактирование: 10 Декабрь 2012, 21:22:47 от йцуаы »

vizuxe

  • Автор темы
  • Гость
Вы какую версию драйвера хотите поставить?
Если драйвер не работает на этой версии ядра, то вам нужно поставить ту которую он требует. Попробуйте поставить ядро 2.6.35 или 2.6.32. О том как это сделать вы можете посмотреть здесь.

Оффлайн йцуаы

  • Любитель
  • *
  • Сообщений: 73
    • Просмотр профиля
спасибо за помощь к сожалению сгорел блок питания (неизвестностно что ещо утянул за собой)
так что проблемы с драйверами для того компьютера откладываются на не определённый период

з.ы. сгорел по причине криворукости некоторых %user%
     уточняю дабы читающие сее не усомнились
« Последнее редактирование: 14 Декабрь 2012, 19:23:41 от йцуаы »

vizuxe

  • Автор темы
  • Гость
Инструкции восстановлены!

Но все равно желательно исспользовать свободные драйвера, так как в большинстве случаев они работают стабильнее:

Цитата из http://vasilisc.com/nouveau-support-3d :

Открытый драйвер для nvidia видеокарт Nouveau получил поддержку 3D в последней, на сегодняшний день, ветке ядра линукс. Вместе с текущей версией libdrm, Nouveau в Mesa 3D 9.0 позволяет линукс приложениям использовать 3D акселерацию на любой топовой видеокарте GeForce.
Поддерживаются все возможности акселерации для всех чипов. Однако, раньше для некоторых видеокарт из среднего и топового сегмента некоторые возможности включались после ручного вмешательства пользователя. Это было связанно с тем, что проприетарная прошивка не могла быть доступна открытому драйверу из пакета или быть скаченной из Интернета. Нужно было установить проприетарные драйвера NVIDIA и аккуратно извлечь оригинальную прошивку при инициализации оборудования.
Незадолго до Нового Года, Линус Торвальдс интегрировал наработки разработчика Red Hat Бена Скеггса (Ben Skeggs), которые позволяют драйверу Nouveau автоматически применять нужную прошивку. Это и позволяет Nouveau включать 3D для всех NVIDIA карт на чипе GeForce.
Так как свободные драйвера AMD и Intel так же поддерживают 3D для своих видеокарт, то можно смело сказать, что открытые драйвера дистрибутивов линукс поддерживают "искаропки" 3D функции для большинства видеокарт на рынке ПК.
« Последнее редактирование: 04 Июль 2013, 23:19:35 от vizuxe »

Оффлайн Romek

  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Для устаревших видеокарт подходят драйвера серии 96.xx.xx:

Поскольку из wiki статью с инструкциями неожиданно убрали, а всё что там было, запомнить не удалось, позволю спросить: правильно ли я понял, что драйвер серии 96.хх.хх (на сайте Nvidia - 96.43.23) требует особую версию xorg, а тот, в свою очередь, - особой версии ядра?

Если так - то как установить этот самый xorg 1.11 / 1.12 на 12.04? На packages.ubuntu.com версия 1:7.6+12ubuntu1  ???

Ядро, как я понимаю можно взять с kernel.ubuntu.com.

Спасибо.

vizuxe

  • Автор темы
  • Гость
Вам нужен xorg версии 1.12. В Ubuntu 12.04 он вроде уже стоит, а по поводу версии ядра, то попробуйте сначала установить драйвер с сайта nvidia (версии 96.43.23) без каких либо глобальных изменений в системе. Если не получится, то вам придется откатывать версию xorg до 1.9 и ядро до 2.6. Xorg берите из репозиториев Ubuntu 10.10.

Пользователь решил продолжить мысль 05 Июль 2013, 12:58:01:
Тема закрыта. Теперь обсуждение инструкций ведется здесь
« Последнее редактирование: 05 Июль 2013, 14:43:23 от vizuxe »

 

Страница сгенерирована за 0.074 секунд. Запросов: 24.