Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: lenovo z570 и grub  (Прочитано 5333 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Constantine2210

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
lenovo z570 и grub
« : 03 Декабря 2012, 10:31:36 »
Здравствуйте.
купил я себе вышеозначенный ноут, и решил поставить на нем паралельно 2 системы: Win и какой нибудь линукс,
сначала поставил suse и все у меня работал,но потом, зачем то решил переставить сьюз заново,и теперь у меня не работает граб.никак. уже ставил ubuntu 12.10,12.04.1 kubuntu 12.10 opensuse 12.2,
граб не запускается
(похоже даже на диске,если запускать через F12 то не грузится ни флэшка ни диск, только если в боисе поставить приоритет загрузки на диск(флэшку) то тогда выдает ошибку, и потом загружается черно-белое откошко с предложением старта установки или пробной системы)
как починить,желательно при этом оставив линукс и винду

под эфи выделен отдельный раздел
мне кажется надо что то в настройках биоса изменить, или какой то косяк в загрузочной области
биос - phoenix securecore tiano
bios version 45cn38ww
в нем практически ничего не настраивается,т.е. можно установить дату,вермя, очередь загрузки устройств, разрешь работу сети и юсб. и все.

сейчас загрузался с загрузочной флэшки

при загрузке диска alternate  пишет prefix is not set  или что то в этом духе,
« Последнее редактирование: 03 Декабря 2012, 10:58:27 от Constantine2210 »

Pilot6

  • Гость
Re: lenovo z570 и grub
« Ответ #1 : 03 Декабря 2012, 12:21:30 »
grub через терминал установите, и все будет ништяк.

Оффлайн Constantine2210

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: lenovo z570 и grub
« Ответ #2 : 03 Декабря 2012, 12:25:51 »
а как..?
sudo grub-install
требует смонтировать диск(вот сейчас разбираюсь как это сделать)

при этом меня глужет сильные сомнения что получится - груб не запускается даже с lifeCD. то почему ему заработать сейчас

Пользователь решил продолжить мысль 03 Декабря 2012, 12:32:44:
ubuntu@ubuntu:~$ sudo grub-install /dev/sda6 --uefi-secure-boot
Path `/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting.
ubuntu@ubuntu:~$
« Последнее редактирование: 03 Декабря 2012, 12:32:44 от Constantine2210 »

Pilot6

  • Гость
Re: lenovo z570 и grub
« Ответ #3 : 03 Декабря 2012, 12:34:21 »
Constantine2210,
Ну так смонтируйте. Надо загрузиться с LiveCD, смонтировать куда-нибудь корень линукса с HDD, например в /mnt
sudo mount /dev/sda2 /mnt

А потом поставить grub
sudo grub-install --root-directory=/mnt /dev/sda

sda2 - корень линукса
sda - диск, куда загрузчик будет ставиться (диск, а не раздел).


Оффлайн Constantine2210

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: lenovo z570 и grub
« Ответ #4 : 03 Декабря 2012, 12:41:40 »
поставил,щас попробую

Пользователь решил продолжить мысль 03 Декабря 2012, 12:49:34:
неполучилось

Пользователь решил продолжить мысль 03 Декабря 2012, 12:51:41:
он вообше загрузчика не видит
в биосе стоит загруска сначала с жесткого,потом СД и где-то в конце загрузка с сети,
он тупит коакое-то время а потом пытается грузиться из сети
« Последнее редактирование: 03 Декабря 2012, 12:51:41 от Constantine2210 »

Pilot6

  • Гость
Re: lenovo z570 и grub
« Ответ #5 : 03 Декабря 2012, 12:52:18 »
Constantine2210,
А у меня получилось ))). Так что смотрите, что не так делаете.

Оффлайн Constantine2210

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: lenovo z570 и grub
« Ответ #6 : 03 Декабря 2012, 12:59:59 »
ОСи становились переустанавливались не однократно,включая дефолтные настройки, при которых опять же не работало ничего,так что дело не в "криворукости",при стандартных настройках что то бы да заработало.

Пользователь решил продолжить мысль 03 Декабря 2012, 13:26:28:
и еще у меня сильное подозрение что у меня uefi

Пользователь решил продолжить мысль 03 Декабря 2012, 17:06:27:
При загрузке флэшки с Ubuntu 12.10 пишет: secure boot not enabled
затем появляется:
                         gnu grub version 2.00 7ubuntu11
Try Ubuntu without installing
Install Ubuntu
OEM install(for manufactures)
Check disk for defects


при этом на компьютере уже стоит Ubuntu 12,10

Пользователь решил продолжить мысль 03 Декабря 2012, 17:07:57:
аналогично с alternate 12.04.1

Пользователь решил продолжить мысль 03 Декабря 2012, 17:14:49:
при установка граба из флэшки пишет:

ubuntu@ubuntu:~$ sudo mount /dev/sda3 /mnt
ubuntu@ubuntu:~$ sudo grub-install --root-directory=/mnt /dev/sda
Installation finished. No error reported.
ubuntu@ubuntu:~$


но всеравно ничего не грузит

Пользователь решил продолжить мысль 03 Декабря 2012, 17:42:25:
и еще вопрос - можно ли почистить загрузочную область? а то у меня там мусора...
и заставить грузиться диск с uefi и без нее?
« Последнее редактирование: 03 Декабря 2012, 17:42:25 от Constantine2210 »

Pilot6

  • Гость
Re: lenovo z570 и grub
« Ответ #7 : 03 Декабря 2012, 19:42:41 »
Если uefi, то надо читать тему про это.

Оффлайн Constantine2210

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: lenovo z570 и grub
« Ответ #8 : 03 Декабря 2012, 19:59:39 »
вот именно, что непонятно то ли есть то ли нет,
вроди на форумах написано что ноут поддерживает и эфи и обычную загрузку,
но вот сам этого нигде не увидел

по идее это должно быть в биосе, но там ничего подобного нет,
у меня вообще биос какой-то урезанный,в разделе загрузки можно вабрать только порядок загрузки..даже удалить, что-либо из этого списка нельзя..

Ubuntu(установочник пытается загрузиться с эфи,не может)
но при этоим во время установки упорно пытается поставить именно граб эфи,

сьюз тоже во время установки пытается поставить граб эфи,ну по крайней мере требует создать раздел /boot/efi/
при этом еще ругатся на отсутсвие какой-то метки...в конце настройки установки в съюзе можно редактировать выбранные параметры
в том числе и загрузчик.пытался ставить:
lilo - вообще не поставился
elilo - так же выдает ошибки еще на этапе установки
grub 2 efi - ставится но не грузится
grub 2 - ставится но не грузится
grub - ставится и грузится, но невидит убунты и вообще не хочу съюз,до второго не обновляется

при этом есть еще вариант с форматированием винчестера, но меня он не устраивает.


кстати встречал посты владельца lenovo z570 - у него та же проблема,решения не нашел,
sudo grub-install - не работает

Пользователь решил продолжить мысль 03 Декабря 2012, 20:03:05:
ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xcca50800

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048      411647      204800    7  HPFS/NTFS/exFAT
/dev/sda2          411648   874825710   437207031+   7  HPFS/NTFS/exFAT
/dev/sda3       874825728   945829887    35502080   83  Linux
/dev/sda4       945829888   976773167    15471640   12  Compaq diagnostics

Disk /dev/sdb: 4022 MB, 4022337536 bytes
124 heads, 62 sectors/track, 1021 cylinders, total 7856128 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x20ac7dda

This doesn't look like a partition table
Probably you selected the wrong device.

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   ?  3224498923  3657370039   216435558+   7  HPFS/NTFS/exFAT
/dev/sdb2   ?  3272020941  5225480974   976730017   16  Hidden FAT16
/dev/sdb3   ?           0           0           0   6f  Unknown
/dev/sdb4        50200576   974536369   462167897    0  Empty

Partition table entries are not in disk order

Disk /dev/sdc: 4007 MB, 4007657472 bytes
61 heads, 21 sectors/track, 6110 cylinders, total 7827456 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6da034c0

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *        2048     7827455     3912704    c  W95 FAT32 (LBA)


если нужно

Пользователь решил продолжить мысль 03 Декабря 2012, 20:08:36:
загрузочная флэшка Ubuntu 10.04 - вообще не загружается
пишет приграшение:
boot>

Пользователь решил продолжить мысль 03 Декабря 2012, 21:35:25:
УРА!!!
Поставил как хотел! правда через ж**у
Короче если я правильно понял то на ноутах этой модели последние линуксы(Ubuntu 12.04. 12.10; съюз 12.2) с упорством достойного лучшего применения стараются загрузиться с эфи, и даже умудряются что то прописывать в загрузочной области, как установить эфи и возможно ли это - не знаю,
но можно поставить старый граб,без эфи,путем установки старого линукса(например Ubuntu 10) и потом его обновления до текущей версии.

если установка не запускается, а вылезает приглашение:
boot>
надо юзнуть
boot> help
и тогда каким-то непонятным образом загрузчик сработает
« Последнее редактирование: 03 Декабря 2012, 21:35:25 от Constantine2210 »

Оффлайн Uximo

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: lenovo z570 и grub
« Ответ #9 : 14 Февраля 2013, 20:05:26 »
сегодня столкнулся с той же бедой!
этот способ не сработал, но я нашел другой по проще и решил добавить сюда если вдруг кому понадобится
нужно загрузиться с live CD
и обновить grub так как описано здесь:
https://help.ubuntu.ru/wiki/%D0%B2%D0%BE%D1%81%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_grub
удачи! :)

 

Страница сгенерирована за 0.034 секунд. Запросов: 25.