Форум русскоязычного сообщества Ubuntu


Автор Тема: [РЕШЕНО]Китайский в gedit  (Прочитано 817 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн NgeMtu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
[РЕШЕНО]Китайский в gedit
« : 07 Январь 2013, 17:12:55 »
Доброго времени суток. Случилось невероятное и не знаю как с этим бороться.

gedit при открытии любого текстового документа в котором есть русский язык почемуто буквы отображает китайскими иероглифами и именно иероглифами и тут дело не в кодировке!
Вот к примеру:
Создал документ написал привет Ubuntu
а он выдал
袩褉懈胁械褌 褍斜褍薪褌褍

И даже те доки что были сохранены на других системах хоть в utf-8 хоть в кирилице то все равно такое чудит.
Вот скрин этого слова

А вот док с большим набором текста
gedit

kate

Рылся в гугле но решения не нашол. Пробовал конфиги сносить с профиля юзера но видать не все.
Кто-нибудь сталкивался? :-\
*******************************


Решение найдено благодарю arcfi
Восстановить

['UTF-8', 'CURRENT', 'ISO-8859-15', 'UTF-16']
Ман тут
 
« Последнее редактирование: 17 Январь 2013, 21:56:19 от yorik1984 »

Оффлайн zotkindm

  • Старожил
  • *
  • Сообщений: 2452
  • (K)Ub 14.04
    • Просмотр профиля
Re: Китайский в gedit
« Ответ #1 : 07 Январь 2013, 17:28:00 »
Кодировка слетела.

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Китайский в gedit
« Ответ #2 : 07 Январь 2013, 18:22:31 »
Сравнивайте:
$ locale
LANG=ru_RU.utf8
LC_CTYPE="ru_RU.utf8"
LC_NUMERIC="ru_RU.utf8"
LC_TIME="ru_RU.utf8"
LC_COLLATE="ru_RU.utf8"
LC_MONETARY="ru_RU.utf8"
LC_MESSAGES="ru_RU.utf8"
LC_PAPER="ru_RU.utf8"
LC_NAME="ru_RU.utf8"
LC_ADDRESS="ru_RU.utf8"
LC_TELEPHONE="ru_RU.utf8"
LC_MEASUREMENT="ru_RU.utf8"
LC_IDENTIFICATION="ru_RU.utf8"
LC_ALL=

$ gsettings list-recursively | grep org.gnome.gedit.*enco
org.gnome.gedit.preferences.encodings auto-detected ['UTF-8', 'CURRENT', 'ISO-8859-15', 'UTF-16']
org.gnome.gedit.preferences.encodings shown-in-menu ['CP866', 'ISO-8859-15', 'WINDOWS-1251']

Оффлайн NgeMtu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: Китайский в gedit
« Ответ #3 : 07 Январь 2013, 19:48:39 »
Сравнил
Цитировать
$ locale
LANG=ru_RU.UTF-8
LANGUAGE=ru_RU:en
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY=ru_RU.UTF-8
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER=ru_RU.UTF-8
LC_NAME=ru_RU.UTF-8
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION=ru_RU.UTF-8
LC_ALL=

$ gsettings list-recursively | grep org.gnome.gedit.*enco
org.gnome.gedit.preferences.encodings auto-detected ['GB18030', 'UTF-8', 'CURRENT', 'ISO-8859-15', 'UTF-16']
org.gnome.gedit.preferences.encodings shown-in-menu ['WINDOWS-1251']



Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Китайский в gedit
« Ответ #4 : 07 Январь 2013, 20:21:08 »
org.gnome.gedit.preferences.encodings auto-detected ['GB18030', 'UTF-8', 'CURRENT', 'ISO-8859-15', 'UTF-16']
А если это убрать?

Оффлайн NgeMtu

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: Китайский в gedit
« Ответ #5 : 07 Январь 2013, 20:50:12 »
arcfi,Благодарю помогло  ;D
Тем кто не знает как изменить то тут ман

 

Страница сгенерирована за 0.082 секунд. Запросов: 24.