Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Раздача Интернета в локальную сеть и его потеря после перезагрузки!  (Прочитано 737 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Anz

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
  • Anz end anzers
    • Просмотр профиля
Пытался расшарить интернет по рецепту: https://forum.ubuntu.ru/index.php?topic=107492.0 на второй комп с Виндовс 7 максимальная.
сеть установилась но доступа к ней не было.
Затем стал переделывать из рецепта на Вики
http://help.ubuntu.ru/wiki/sharing_internet#%D1%80%D0%B0%D0%B7%D0%B4%D0%B0%D1%87%D0%B0_%D0%B8%D0%BD%D1%82%D0%B5%D1%80%D0%BD%D0%B5%D1%82%D0%B0_%D0%B2_%D0%BB%D0%BE%D0%BA%D0%B0%D0%BB%D1%8C%D0%BD%D1%83%D1%8E_%D1%81%D0%B5%D1%82%D1%8C_icsinternet_connection_sharing
в какой то момент на последних стадиях сеть вроде заработала но Винда ее обзывала неизвестной
после перезагрузки на Ubuntu 12.04 стало недоступно само включение сети и при загрузке машина долго ее пытается конфигурировать но без толку.
Возможно есть способ все исправить хотя бы "как было". Скриншоты не могу вывесить так как подключился с другой машины из винды. на команду ifconfig -a выводит оба eth без ip адресов а lo выводит 127.0.0.1
Xubuntu 14.04, DELL INSPIRON 9400; CanonLBP2900; Epson TX200).

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Способ описанный в местной wiki работоспосоен, но действительно только до перезагрузки.
В прикреплённой теме, по которой Вы изначально пытались настроить, описан как раз Ваш случай, но Вы, судя по всему, не смогли осилить всё сообщение до конца.
Читайте и творите. Если не получится, то ... то там описано что делать, если результат всех действий отрицательный.
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Anz

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
  • Anz end anzers
    • Просмотр профиля
Пока что сделал следующее: убрал из файла /etc/network/interfaces строчки которые я вносил по первому рецепту (возможно я внес с ошибкой)
осталось:
auto lo
iface lo inet loopback

Что это значит я не знаю, но НетворкМенеджер заработал. Теперь попытаюсь присоеденить сетевой кабель.
Сеть заработала! Теперь попытаюсь еще раз настроить по "первому рецепту"
(https://forum.ubuntu.ru/index.php?topic=107492.msg802575#msg802575)


Пользователь решил продолжить мысль 23 Январь 2013, 19:32:24:


во весь размер:
http://storage2.static.itmages.ru/i/13/0123/h_1358954793_9239230_914687e58e.png

Все равно день потерян, буду двигаться более вдумчиво...
« Последнее редактирование: 23 Январь 2013, 19:32:24 от Anz »
Xubuntu 14.04, DELL INSPIRON 9400; CanonLBP2900; Epson TX200).

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
А вот может Вам всё-таки проще будет раздать интернет средствами NM?
http://ru.d-ws.biz/articles/icsLinuxAndWindows.shtml
Вариант намбер 2
Удачи
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Anz

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
  • Anz end anzers
    • Просмотр профиля
Ввел все по рецепту и сеть установилась! :D Вводил ручные настройки на клиентской машине.
После перезагрузки...?

Пользователь решил продолжить мысль 23 Январь 2013, 20:55:20:
:( После загрузки опять то же самое НетворкМенеджер частично вырубается.
Ввел в терминале:
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
iptables-save > /etc/iptables.up.rules
echo "pre-up iptables-restore < /etc/iptables.up.rules" >> /etc/network/interfaces
интернет восстановился
Но это что кадый раз так?
и главное НЕПОНЯТНО как это все устроено.
 

Пользователь решил продолжить мысль 23 Январь 2013, 21:03:45:
sudo /etc/init.d/NetworkManager restartsudo /etc/init.d/NetworkManager restart
не находит команду
« Последнее редактирование: 23 Январь 2013, 21:03:45 от Anz »
Xubuntu 14.04, DELL INSPIRON 9400; CanonLBP2900; Epson TX200).

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
:( После загрузки опять то же самое НетворкМенеджер частично вырубается.
Уважаемый, Вы хоть одно слово про Network Manager в тексте видели?
Мало того, NM просто перестаёт работать, если замечает, что в interfaces есть описание более чем интерфейса Loopback.

Но это что кадый раз так?
Ну если Вам так нравиться каждый раз ходить из угла в угол, то пожалуйста

и главное НЕПОНЯТНО как это все устроено.
Кто Вам мешает изучить указанные в том сообщении статьи?
 
sudo /etc/init.d/NetworkManager restart
не находит команду
Оно и понятно. Ведь такого файла нет, а значит и команды.

Пользователь решил продолжить мысль 23 Январь 2013, 21:34:58:
Если не можете настроить конфиг-файлами и рука привыкла к мыши - я Вам дал ссылку на гайд по расшариванию интернета с помощью мыши (там чуть-чуть по клаве постучать всё равно придётся).
« Последнее редактирование: 23 Январь 2013, 21:34:58 от fisher74 »
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Anz

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
  • Anz end anzers
    • Просмотр профиля
Я весьма благодарен за поддержку и изучать статьи буду вмеру сил и времени. Особых одолжений не требуется, спасибо.
Xubuntu 14.04, DELL INSPIRON 9400; CanonLBP2900; Epson TX200).

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Просто пройдите по всем пунктам первого сообщения в прикреплённой теме (первая ссылка в Вашем первом сообщении) и всё.
Не пытайтесь после настройки восстановить работу Network Manager-а - они несовместимы: чтобы работала раздача обсуждаемым способом нужно править interfaces, что для NM фатально. И, соответсвенно, наоборот.
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн Sly_tom_cat

  • Don't worry, be happy!
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 12075
  • Xubuntu 20.04 (64bit)
    • Просмотр профиля
Главная ошибка, как правильно заметил fisher74, это попытка совместить несовместимое - любая настройка в /etc/network/interfaces отключает NM - он просто перестает работать, если там прописано что-то кроме конфигурации lo интерфейса.

Вам нужно определиться - с помошью чего раздавать - через NM (это возможно в некоторых случаях) или через настройки в конфиг-файлах. И дальше двигаться по выбранному пути.
Индикатор для Yandex-Disk: https://forum.ubuntu.ru/index.php?topic=241992
UEFI-Boot - грузимся без загрузчика: http://help.ubuntu.ru/wiki/uefiboot

Оффлайн Anz

  • Автор темы
  • Любитель
  • *
  • Сообщений: 60
  • Anz end anzers
    • Просмотр профиля
Спасибо всем, за подсказки. Я хотел бы научится работать в терминале. Мышью я и в Винде нащелкался. Минус в том ,что изучение очень для меня времяемкое занятие, а иногда хочется пройти "быстро и легко"... И  в этом ловушка, так как, не имея понятия о том "что и для чего" делается, если что то не работает то оказываешься в полной беспомощности.
Кстати ссылка из "рецепта": Руководство interfaces
http://translated.by/you/man-interfaces-5-network-interface-configuration-for-ifup-and-ifdown/into-ru/trans/
кажется битая.
« Последнее редактирование: 24 Январь 2013, 17:59:48 от Anz »
Xubuntu 14.04, DELL INSPIRON 9400; CanonLBP2900; Epson TX200).

 

Страница сгенерирована за 0.091 секунд. Запросов: 24.