Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: [решено] 1 Нет звука в браузерах и 2 Как удалить ненужное звуковое оборудование?  (Прочитано 4160 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Razielvamp

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
Приветствую, коллеги.

Обрисовываю ситуацию. Стоит ALSA Driver и основня звуковая карта Creative Soundlaster. Значица во всех плеерах и прочих вещах звук есть, НО во всех браузерах звука нет (пробовал на трех).

пишется вот такая бодяга:
(firefox-bin:7076): Gdk-WARNING **: XID collision, trouble ahead
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
перерыл уже весь инет, переустановил алсу на самую новую 1.0.25, снес пульс, чтобы ничего лишнего было, в итоге все равно ничего не смог решить...

если ввести aplay -l, то получаем:
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Live [SB Live! Value [CT4830]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
  Subdevices: 32/32
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
  Subdevice #8: subdevice #8
  Subdevice #9: subdevice #9
  Subdevice #10: subdevice #10
  Subdevice #11: subdevice #11
  Subdevice #12: subdevice #12
  Subdevice #13: subdevice #13
  Subdevice #14: subdevice #14
  Subdevice #15: subdevice #15
  Subdevice #16: subdevice #16
  Subdevice #17: subdevice #17
  Subdevice #18: subdevice #18
  Subdevice #19: subdevice #19
  Subdevice #20: subdevice #20
  Subdevice #21: subdevice #21
  Subdevice #22: subdevice #22
  Subdevice #23: subdevice #23
  Subdevice #24: subdevice #24
  Subdevice #25: subdevice #25
  Subdevice #26: subdevice #26
  Subdevice #27: subdevice #27
  Subdevice #28: subdevice #28
  Subdevice #29: subdevice #29
  Subdevice #30: subdevice #30
  Subdevice #31: subdevice #31
card 1: Live [SB Live! Value [CT4830]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 1: Live [SB Live! Value [CT4830]], device 3: emu10k1 [Multichannel Playback]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
и вот тут меня смутило, что первым устройством идет HDMI звук с видеокарты в ATI Radeon, в настройках системы, я везде, где можно выбрал саундбластер, но может браузеры используют первое устройство из списка?

Вобщем отсюда два вопроса:
1. Как удалить вобще подчистую это HDMI устройство из всех списков (ибо вообще не нужно)?
2. В чем еще может быть причина такого поведения в браузерах, в какую сторону еще посмотреть?
Но 2й вопрос не будет иметь смысла, если проблему поможет решить ответ на 1й, так что, на данный момент он приоритетнее.
« Последнее редактирование: 25 Январь 2013, 12:56:28 от Razielvamp »

Pilot6

  • Гость
Razielvamp,
Вы слишком много всего наделали. Не надо было сносить пульс, а всего-то надо было в настройках системы выбрать правильное устройстов по умолчанию.

Оффлайн Razielvamp

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
Pilot6, очень прошу поделиться, где именно эту галку поставить, везде где нашел - ставил

ЗЫ пульс снес, потому что с ним скайп не работал. Это какбе другой вопрос :)

Pilot6

  • Гость
Razielvamp,
Работает скайп с пульсом. Только хрипит иногда. Но это тоже исправить можно.

В параметрах звука какие устройства показывает? Дайте скриншот что ли?

Оффлайн Razielvamp

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
В параметрах звука какие устройства показывает? Дайте скриншот что ли?

не совсем понимаю о каких именно параметрах идет речь, их там много %) Выложил сткрины, которые отображает alsamixer из терминала.
Если просто ткнуть на значёк звука в GUI то там, HDA ATI HDMI (Alsa mixer), SBlive! Value [CT4830] (Alsa Mixer), ATI R6xx HDMI (OSS Mixer). Расположеныы соответственно сверху вниз в контекстном меню, где они выбираются. Ползунки с грмкостью есть только у бластера, у хдми все неактивно

Вложение выкладываю архивом, ибо не разобрался, как вставить картинки, хотел засунуть с ЗАПРЕЩЁННЫЙ РЕСУРС, оказалось, что это запрещенный ресурс
« Последнее редактирование: 24 Январь 2013, 16:33:28 от Razielvamp »

Pilot6

  • Гость
Razielvamp,
В alsamixer все в порядке. Дайте скрин "Параметры системы -> Звук".

https://forum.ubuntu.ru/index.php?topic=49898.0

Оффлайн Razielvamp

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
скрин.

если ткнуть мышкой в название аудиокарты, то вылезет список с устройствами, которые я написал в предыдущем сообщении. (С развернутым списком скриншот не делается, линукс - такой линукс :o)

http://itmages.ru/image/view/862247/9ea07867


Pilot6

  • Гость

Оффлайн Razielvamp

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
уже есть :) прямо сюда не вставился, вернее вставился, но почему-то не отображался

Pilot6

  • Гость
Razielvamp,
Это KDE что ли? Я не знаю как там в графическом режиме настраивать. В гноме все намного проще.

Оффлайн Razielvamp

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
Да вобщемто гном. только дистриб не Ubuntu а дебиан. Но по сути те же яички, тока в профиль

и настроек там собсно никаких нет. Только эти ползуны и все. Ну и еще галки, типа подключения всяких цифровых выходов (естесно они убраны).
« Последнее редактирование: 24 Январь 2013, 17:04:35 от Razielvamp »

Pilot6

  • Гость
Razielvamp,
По дебиану не на этот форум.

Оффлайн Razielvamp

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
ну я конечно понимаю, что не та все песочница, туда сюда. Но вопрос-то не в дистрибе.

Я готов с удовольствием выслушать, как удалить HDMI устройство из всех списков именно на Ubunt'е ;)

Pilot6

  • Гость
Razielvamp,
Если хотите именно удалить (я не считаю это правильным способом решения проблемы), то надо посмотреть в lspci -k модуль ядра, который управляет этим устройством и заблеклистить его.

Оффлайн Razielvamp

  • Автор темы
  • Любитель
  • *
  • Сообщений: 56
    • Просмотр профиля
Да, я тоже не считаю это решение правильным, но пока что других просто не вижу, да и для конкретно моих целей оно на 100% подходит.

Собсно lspci пишет вот такую штуку:
05:00.0 VGA compatible controller: ATI Technologies Inc RV610 [Radeon HD 2400 XT]
Kernel driver in use: fglrx_pci
05:00.1 Audio device: ATI Technologies Inc RV610 audio device [Radeon HD 2400 PRO]
Kernel driver in use: snd_hda_intel

Можно как-нибудь поподробнее узнать, как добавлять в блеклист?
« Последнее редактирование: 25 Январь 2013, 00:26:05 от Razielvamp »

 

Страница сгенерирована за 0.113 секунд. Запросов: 25.