Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Помогите разобраться в хитросплетениях драйверов AMD  (Прочитано 722 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Jaksn

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
    • Просмотр профиля
Я всё никак не могу установить подходящий драйвер.
Сначала я установил проприетарный драйвер, предоставленный самой ОС, но этот драйвер оказался сильно устаревшим. Поэтому я скачал более новую версию драйвера с сайта AMD (ver. 13.1), установил, но предыдущий драйвер забыл деактивировать, в результате в некоторых играх стали появляться графические глюки  тормоза. Я удалил все драйвера и установил драйвер 13.1 по новой, в результате все 3D игры перестали работать и steam не запускался. Потом я прочел в одной из инструкций, что нужно ставить драйвера из x-swat репозитория (для 12.04). Я всё сделал по инструкции и установил драйвер. Всё вновь заработало, но графические артефакты всё равно остались. Я вновь всё удали и заново поставил драйвера версии 13.1 и опять steam и игры перестали запускаться. Потом я прочел, что моя видеокарта - Radeon HD5650 не поддерживается драйверами, начиная с версии 12.6 и что нужно устанавливать версию 12.4, полностью удалив перед этим предыдущий драйвер. Предыдущий драйвер я удалить не смог.
В общем всё закончилось тем, что мне пришлось переустанавливать Ubuntu  :(
Пожалуйста, кто-нибудь, объясните как правильно установить последнюю версию драйвера для моей видеокарты.

Pilot6

  • Гость
Jaksn,
Вопрос правильный. Действительно эта видеокарта не поддерживается последними драйверами, но можно поставить fglrx-legacy. Только нужно сделать deb пакеты, чтобы при обновлении ядра не приходилось переустанавливать.

Пользователь решил продолжить мысль 25 Январь 2013, 21:20:34:
Pilot6,
Приведите полное название карты. А то у AMD путаница с этим
Mobility поддерживается.

Пользователь решил продолжить мысль 25 Январь 2013, 21:21:43:
Сейчас посмотрел 5600 серия поддерживается самыми последними драйверами.

Пользователь решил продолжить мысль 25 Январь 2013, 21:23:10:
А вообще не факт, что существует версия, на которой стим будет без артефактов.
« Последнее редактирование: 25 Январь 2013, 21:23:10 от Pilot6 »

Оффлайн Jaksn

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
    • Просмотр профиля
Pilot6,
AMD Mobility Radeon HD5650
На Windows новая версия драйвера установилась. На Linux что-то не хочет
Кстати по началу артефактов не наблюдалось. Значит дело всё в Steam'е?
« Последнее редактирование: 25 Январь 2013, 21:32:50 от Jaksn »

Pilot6

  • Гость
Jaksn,
Дело не в стиме, а в пока не очень доработанных драйверах AMD для линукса. Вот скоро 12.04 обновится до 12.04.2. Там будет новая графическая подсистема, и по умолчанию предлагаться новый драйверы, которые как раз должны со стимом работать хорошо. Подождите до середины февраля.

Оффлайн san-alex

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 7727
  • Ex-CNC programmer
    • Просмотр профиля
У меня точно такая же карта. В 12,04 прекрасно работает драйвер, предложенный системой. В 10.04 ставил проприетарный. Из репозитория плохо работал. А что за артефакты? Можно скриншотик? Может, ты просто, вертикальную синхронизацию не включил?
« Последнее редактирование: 25 Январь 2013, 22:03:28 от san-alex »

Pilot6

  • Гость
Jaksn,
Кстати да. А чем-таким предложенный драйвер показался "сильно устаревшим", что пришлось его менять?
Новые драйверы от AMD - всегда проблемно.

Оффлайн Jaksn

  • Автор темы
  • Участник
  • *
  • Сообщений: 108
    • Просмотр профиля
Pilot6,
Попытался запустить Sеrious Sam 3, а тот не запустился, сославшись на устаревший драйвер OpenGL.
san-alex,
объекты постоянно мигают. И если повернуться к глючному объекту, игра начинает жутко тормозить. Вертикальную синхронизацию включал.
« Последнее редактирование: 25 Январь 2013, 22:38:58 от Jaksn »

 

Страница сгенерирована за 0.11 секунд. Запросов: 24.