Форум русскоязычного сообщества Ubuntu


Автор Тема: Не могу установить программы в ubuntu 11.04  (Прочитано 2406 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн p1wpaw

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
стоит у меня графическая оболочка mate, похожа на гном 2, такая же на Linux Mint есть
Хотел поставить 7-zip из репов выходили следующие ошибки:

сначала были неудовлетворяющие зависимости:
sudo apt-get install p7zip-rar p7zip-full
Пакеты, имеющие неудовлетворённые зависимости:
peazip : Зависит: libcurl3 (>= 7.16.2-1) но он не будет установлен
         Зависит: libgmp3c2 но он не будет установлен
устранил их:
sudo apt-get check затем sudo apt-get -f  install
Будут установлены следующие дополнительные пакеты:
 libcurl3 libgmp3c2
НОВЫЕ пакеты, которые будут установлены:
 libcurl3 libgmp3c2
все устранилось, пакеты установились, ставлю прогу
sudo apt-get install p7zip-rar p7zip-full
Настраивается пакет opera (12.02.1578-1linuxmint) ...
Traceback (most recent call last):
 File "/usr/sbin/update-software-center", line 38, in <module>
   from softwarecenter.db.update import rebuild_database
 File "/usr/share/software-center/softwarecenter/db/update.py", line 57, in <module>
   from softwarecenter.db.database import parse_axi_values_file
 File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
   from softwarecenter.db.application import Application
 File "/usr/share/software-center/softwarecenter/db/application.py", line 25, in <module>
   from softwarecenter.backend.channel import is_channel_available
 File "/usr/share/software-center/softwarecenter/backend/channel.py", line 25, in <module>
   from softwarecenter.distro import get_distro
 File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 165, in <module>
   distro_instance=_get_distro()
 File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 148, in _get_distro
   module =  __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
dpkg: не удалось обработать параметр opera (--configure):
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Обрабатываются триггеры для menu ...
При обработке следующих пакетов произошли ошибки:
opera
попробовал поставить geany тоже такая же ошибка, что делать?


Пользователь решил продолжить мысль 27 Января 2013, 15:01:32:
особенно интересно что означает это:
ImportError: No module named LinuxMint
dpkg: не удалось обработать параметр opera (--configure):
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Обрабатываются триггеры для menu ...
При обработке следующих пакетов произошли ошибки:
opera

Пользователь решил продолжить мысль 27 Января 2013, 15:03:11:
удалял оперу тоже вышла эта же ошибка
« Последнее редактирование: 27 Января 2013, 15:03:11 от p1wpaw »

Оффлайн www777

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 2777
    • Просмотр профиля
Re: Не могу установить программы в ubuntu 11.04
« Ответ #1 : 27 Января 2013, 19:37:42 »
найди скрытые папки в /home/user относящиеся к opera, и удали их (можешь сделать бекап)

Оффлайн p1wpaw

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Не могу установить программы в ubuntu 11.04
« Ответ #2 : 28 Января 2013, 08:17:32 »
удалил из домашней папки папку .opera не помогло
E: opera: подпроцесс установлен сценарий post-removal возвратил код ошибки 1
это в синаптике выдало при попытке удалить оттуда папку opera

До этого стaвил peazip тоже ошибка выходила но сейча ся его в меню нашел и он запускается, в принципе оказывется проблемы нет, но ошибки пакетами опера так и не устранены

Оффлайн funny-pinguin

  • Участник
  • *
  • Сообщений: 109
    • Просмотр профиля
Re: Не могу установить программы в ubuntu 11.04
« Ответ #3 : 29 Января 2013, 06:26:23 »
Похожая проблема, и её решение описано -- http://askubuntu.com/questions/81263/how-to-i-fix-software-center-after-installing-the-linux-mint-mate-desktop

Суть в том, что Минтовский Mate меняет код дистрибутива на свой, и вот как восстановить.

В терминале вводим

gksu gedit /etc/*release
и заменяем содержимое вот на это

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=Natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"

В терминале вводим

gksu gedit /etc/*issue
и замеяем содержимое вот на это

Ubuntu 11.04 \n \l
PS: 11.04 более не поддерживаеться, так что, имейте в виду...
« Последнее редактирование: 29 Января 2013, 21:21:06 от funny-pinguin »

Оффлайн p1wpaw

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Не могу установить программы в ubuntu 11.04
« Ответ #4 : 06 Марта 2013, 16:06:10 »
Спасибо! Заработало все и пакет сам удалился  :) ;)

Оффлайн zoxibu

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
    • Программу Microsoft Office 2007 у нас можно скачать бесплатно с ключом и прочими потрохами
Re: Не могу установить программы в ubuntu 11.04
« Ответ #5 : 09 Марта 2013, 01:33:19 »
Товарищи, а зачем минт меняет название дистрибутива, официальная версия есть?
Минюст отказался регистрировать Пиратскую Партию России. Даже там знают, что всё пиратское регистрировать не требуется...

Оффлайн КНВ

  • Активист
  • *
  • Сообщений: 705
    • Просмотр профиля
Re: Не могу установить программы в ubuntu 11.04
« Ответ #6 : 09 Марта 2013, 01:49:51 »
А зачем ты меняешь гном 2 на мате?

Оффлайн p1wpaw

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Не могу установить программы в ubuntu 11.04
« Ответ #7 : 18 Марта 2013, 15:58:12 »
У меня гном 3 и юнити были хотелось вернутьстарый гном

Оффлайн КНВ

  • Активист
  • *
  • Сообщений: 705
    • Просмотр профиля
Re: Не могу установить программы в ubuntu 11.04
« Ответ #8 : 19 Марта 2013, 18:08:09 »
В 11.04 гном2 есть искаропки. Называется "классическая Ubuntu" или "классическая Ubuntu без эффектов" (без компиза)

 

Страница сгенерирована за 0.041 секунд. Запросов: 25.