Форум русскоязычного сообщества Ubuntu


Автор Тема: Пароли перестали приниматься ... руткит какойто поймал?  (Прочитано 605 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AltCtrlDel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Неожиданно перестало принимать пароли на системные действия, и на sudo, и на разблокировку компутера - ничё нельзя было выполнить. Сделал флешку с http://www.sysresccd.org/, загрузился. Смонтировал винт, chroot почему то не прошёл (забыл записать как ругалось) отредактировал shadow - стёр пароли рута и юзера (то что между двоеточиями). Загрузил Ubuntu - паролей нет, сделал passwd и для рута и для пользователя. sudo всё равно пароль не требует. Прочитал что ещё надо sudoers смотреть, глянул, а там в конце строчка
ALL ALL=(ALL) NOPASSWD: ALL
- четыре раза прописана. Причём дата файла времён установки системы. Ставил не я и щас уже не спросишь кто ставил. Может так и было? Но почему тогда раньше пароли спрашивало?
заменил эти строчки на
altctrldel ALL=(ALL) ALL
- вроде, всё работает

содержимое sudoers теперь такое (без комментариев)
Defaults      env_reset
root    ALL=(ALL) ALL
%sudo ALL=(ALL) ALL
%admin ALL=(ALL) ALL
altctrldel ALL=(ALL) ALL

Доступа к компу физически ни у кого кроме меня не было 100%. Интернет есть, конечно. С этой убунты и пишу. Чтото пролезло?
Во время установки системы мне "мину" подсунули?

Объясните чайнику что это было и как дальше лечИться.
« Последнее редактирование: 20 Февраль 2013, 13:25:03 от AltCtrlDel »

Pilot6

  • Гость
AltCtrlDel,
Ничего не пролезло. Сами сломали.

chemtech

  • Гость
AltCtrlDel,
Что-то не похоже на чайника.

Оффлайн AltCtrlDel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Что-то не похоже на чайника.

Чайника, чайника. Простой программер под винду. линуксы даже не ставил ни разу. Это всё гугл в помощь. Но его помощь не бесконечна.

Как сам сломал не знаю. В файлы эти не лазал.

Оффлайн easy2002

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2786
  • Мурманск
    • Просмотр профиля
Как сам сломал не знаю. В файлы эти не лазал.
Модем устанавливал?
Tempora mutantur et nos mutantur in illis

Оффлайн AltCtrlDel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Модем устанавливал?

хм. Действительно. Пробовал установить 4G от меги, модель E3276, не встало. Прочитал что и у других не ставится, воткнул модем в комп с виндой. Только это несколько перезагрузок до того было пока всё слетело.

Оффлайн easy2002

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2786
  • Мурманск
    • Просмотр профиля
не встало
..четыре раза. Ну так это он тебе в sudoers напачкал
Tempora mutantur et nos mutantur in illis

Оффлайн AltCtrlDel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
не встало
..четыре раза. Ну так это он тебе в sudoers напачкал


Спасибо! Наверно всё от этого модема, а не враг пробрался.

 

Страница сгенерирована за 0.089 секунд. Запросов: 25.