Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Не загружается Unity, работает только терминал.  (Прочитано 13540 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Zlat

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
У меня Ubuntu 12.04, внезапно перестала загружаться графическая оболочка, работает только терминал.

Раньше мне предлагалось выбрать пользователя, и после ввода пароля загружался Unity. Теперь же я вижу только приглашение ввести логин и пароль в терминале.

Пожалуйста подскажите как решить мою проблему, такие вещи как sudo apt-get remove unity и unity --replace не помогли.
« Последнее редактирование: 20 Февраль 2013, 22:48:10 от Zlat »

denkin

  • Гость
что устанавливалось перед появлением проблемы? железо?
...unity --replace не помогли.

и не могло помочь, юнити то не запущено. а судя по предидущей команде даже удалено.

Пользователь решил продолжить мысль 20 Февраль 2013, 23:21:48:
пробуем сперва:
sudo apt-get install unity - установит юнити обратно
sudo dpkg-reconfigure lightdm - настроит окно логина, если тоже удалено, то sudo apt-get install lightdm
« Последнее редактирование: 20 Февраль 2013, 23:21:48 от denkin »

Оффлайн Zlat

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
что устанавливалось перед появлением проблемы? железо?

Устанавливал Eclipse через терминал, вот этой командой.
sudo apt-get install eclipse-cdt
так же устанавливал новую версию драйверов для видеокарты, но около 2 дней до начала проблем.

denkin

  • Гость
обновления?

что насчет возвращения юнити на место, как я писал выше?

совет - не применяйте бездумно команд особенно по "левым" мануалам. синтаксис apt-get в общем случае очень прост:
sudo - запуск с правами администратора
apt-get - собственно консольная программа для управления пакетами
install <имя пакета> - установить пакет (программу)
или
remove <имя пакета> - удалить пакет

более полно:man apt-get - консольная справка по программе

Пользователь решил продолжить мысль 21 Февраль 2013, 00:39:09:
хороший ресурс по командам *nix
« Последнее редактирование: 21 Февраль 2013, 00:39:09 от denkin »

Оффлайн Zlat

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
denkin, жаль, но ваши инструкции не помогли.

denkin

  • Гость
обновлений не было перед поломкой?

Пользователь решил продолжить мысль 22 Февраль 2013, 14:30:12:
по какому методу устанавливался драйвер на видео?

Оффлайн Zlat

  • Автор темы
  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Через стандартное приложение:  Драйверы устройств.

denkin

  • Гость
после загрузки в консоль startx что получается?

Оффлайн Leonardo

  • Новичок
  • *
  • Сообщений: 32
    • Просмотр профиля
У меня похожая была проблема. Дело в драйвере на видео было. Может, у вас драйвер встал криво? Попробуйте переустановить, если это так.

Оффлайн snakybro

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
У меня похожая проблема. Появилась она после того, как выбрал в настройках проприетарный драйвер. Теперь при загрузке выдает сообщение «The system is running in low-graphics mode». Ничего выбрать не могу, рабочий стол не работает. Могу запустить только командную строку. Как можно исправить ситуацию?

Оффлайн Leonardo

  • Новичок
  • *
  • Сообщений: 32
    • Просмотр профиля
Re: Не загружается Unity, работает только терминал.
« Ответ #10 : 27 Февраль 2013, 20:49:24 »
snakybro,
ну как мне советовали в такой ситуации:
1) удалите установленный драйвер
2) переустановите проприетарный драйвер
Какая видеокарта?
Если AMD (ATI), то
1) sudo apt-get purge fglrx2) а) sudo apt-get install fglrx2) б) http://help.ubuntu.ru//wiki/%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80_%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE%D0%BA%D0%B0%D1%80%D1%82_amd?redirect=1
« Последнее редактирование: 27 Февраль 2013, 20:51:54 от Leonardo »

Оффлайн snakybro

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Leonardo,
спасибо большое. Статья из вики помогла. Но теперь другое вылезло. Сейчас после загрузки все правильно отображает, появляется экран выбора пользователя, НО я не могу зайти в систему, т.к. при вводе правильного пароля от своей учетной записи, меня снова выбрасывает на экран входа. Пароль правильный. На гостевую захожу без проблем.
P.S.: возможно связано как-то - у меня в терминале неправильно отображается кириллица. То непонятные закарлюки, то вовсе какие-то квадратики вместо символов.

Оффлайн Leonardo

  • Новичок
  • *
  • Сообщений: 32
    • Просмотр профиля
snakybro,
на гостевую все же заходит? И все нормально отображается в гостевой? вот что выбрасывает из своей учетной записи на начальный экран, так это все же из-за драйвера скорее всего. А на счет закорючек и проблем с кириллицей... Точно драйвер установился хорошо?
попробуйте это команду и напишите ее вывод:
lspci -k | grep VGA -A2

Оффлайн Sergey_Aka

  • Участник
  • *
  • Сообщений: 125
    • Просмотр профиля
У меня похожая проблема. Появилась она после того, как выбрал в настройках проприетарный драйвер. Теперь при загрузке выдает сообщение «The system is running in low-graphics mode». Ничего выбрать не могу, рабочий стол не работает. Могу запустить только командную строку. Как можно исправить ситуацию?
Когда после установки проприетарного драйвера ATI у меня периодически не загружалась оболочка Unity для входа в настройки системы делал так: ПКМ, выбрать пункт Настройка рабочего стола (или близкое по смыслу, к сожалению не помню). Открывается окно настройки внешнего вида рабочего стола, от туда уже можно зайти в настройки Источники приложениий => Дополнительные драйвера и переключиться на открытый драйвер.
AsRock P5B-DE, Intel Core2Duo E7500 (3519 MHz), RAM 4047 Mb, Radeon HD 5750 (512 Mb), HDD: Seagate 256 Gb (ST3250620AS), WD 500 Gb (WD5000AAKS-0).

Оффлайн snakybro

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Leonardo, да, в гостевую заходит и там все прекрасно. Но в основную никак. После определенных манипуляций, вход должен быть в основную запись без пароля. Но когда пытаюсь это сделать, то опять таки выкидывает на экран приветствия. Попробовал обновить систему через sudo apt-get upgrade - не помогло.
А вот вывод команды:
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI BeaverCreek [Radeon HD 6520G]
   Subsystem: Hewlett-Packard Company Device 3569
   Kernel driver in use: radeon
--
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Caicos [Radeon HD 6400M/7400M Series]
   Subsystem: Hewlett-Packard Company Device 3569
   Kernel driver in use: radeon

Впечатление, что проблема с файлами в учетках. Хотя, пробовал команду pwck, но она не помогла. Хотя выдала целый список с примечаниями в конце строк: "не существует".

 

Страница сгенерирована за 0.074 секунд. Запросов: 24.