Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Выбор версии Qt  (Прочитано 872 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн chindyasov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Выбор версии Qt
« : 16 Марта 2013, 16:16:48 »
Недавно вышла пятая версия Qt. Какую использовать для проекта: старую четвёртую или новую? Сильно ли они различаются?

Qt использую впервые, поэтому одним из критериев является документация. До этого программировал под Windows, используя WinAPI.

Оффлайн Progger

  • Любитель
  • *
  • Сообщений: 95
    • Просмотр профиля
Re: Выбор версии Qt
« Ответ #1 : 16 Марта 2013, 17:41:51 »
Если делать простое приложение на QtWidgets, то разницы между Qt4 и Qt5 нет. Если на QtQuick, то лучше сразу на Qt5. Единственная проблема, что Qt5 нет в репозитории 12.10, поэтому придёться либо ставить 13.04, либо из исходников собирать, либо ставить из ppa, но там 5.0.0

Оффлайн Чистый

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3473
  • nix - вот оно счастье...
    • Просмотр профиля
Re: Выбор версии Qt
« Ответ #2 : 16 Марта 2013, 18:47:27 »
не лезьте пока на Qt5 пока она не станет 5.2 так как ошибок там много, если проект новый и только планируете его начать потерпите, меньше будет головной боли, если проект для себя то можно и 4 юзать, ничего не потеряете
Тестовый репозиторий kdeNeur ppa:devcode/kdeneur
各々が死ぬことをどのように決定する

Оффлайн chindyasov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Выбор версии Qt
« Ответ #3 : 16 Марта 2013, 22:42:50 »
Спасибо за ответы. Пока Qt буду изучать на примере четвёртой версии.

 

Страница сгенерирована за 0.051 секунд. Запросов: 25.