Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Сканер Mustek BearPaw 1200 неправильно определяется  (Прочитано 2909 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн keha

  • Автор темы
  • Активист
  • *
  • Сообщений: 616
  • Вот такой вот...
    • Просмотр профиля
Доброго времени суток...
Пытаюсь завести сей сканер под kubuntu 7,04/7.10 -  но возникает любопытная проблема. Сканер определяется как
# scanimage -L
device `plustek:libusb:001:005' is a Mustek BearPaw 2400 flatbed scanner
Но я бы с этим смирился, если бы он сканировал, но он просто загоняет каретку до упору в конец и все. потом ее оттуда с трудом выгнать..
что делать?
PS это просто 1200, без букв.
на перегонки со временем

Оффлайн FirstAlex

  • Новичок
  • *
  • Сообщений: 36
    • Просмотр профиля

Оффлайн keha

  • Автор темы
  • Активист
  • *
  • Сообщений: 616
  • Вот такой вот...
    • Просмотр профиля
Re: Сканер Mustek BearPaw 1200 неправильно определяется
« Ответ #2 : 20 Февраль 2008, 07:49:28 »
ссылка не помогла. но я сам разобрался. оказалась что у 1200 и 2400 один чип. и надо было всего подредактировать два файла /etc/sane.d/plustek.conf и /usr/local/etc/sane.d/plustek.conf. в обоих файлах я заменил в строке 'option mov 0' нолик на единичку. кто просмотрит файл, поймет зачем.

PS но проблемы не заканчиваются. сканер нормально сканирует только в серых цветах, цветные сканы - просто слегка цветная засвеченность. плюс каретка при сканировании не возвращается назад. только при начале нового скана каретка возвращается назад и потом сканирует...что делать?
PS плюс xsane видит сканер только под root
« Последнее редактирование: 20 Февраль 2008, 08:00:53 от keha »
на перегонки со временем

Glad

  • Гость
Re: Сканер Mustek BearPaw 1200 неправильно определяется
« Ответ #3 : 24 Февраль 2008, 15:38:37 »
В firmware с установочного диска файл перекинул?

Оффлайн keha

  • Автор темы
  • Активист
  • *
  • Сообщений: 616
  • Вот такой вот...
    • Просмотр профиля
Re: Сканер Mustek BearPaw 1200 неправильно определяется
« Ответ #4 : 25 Февраль 2008, 11:36:47 »
я не использовал firmware, потому что я использую драйве plustek, а не GT68xx.
на перегонки со временем

Оффлайн FirstAlex

  • Новичок
  • *
  • Сообщений: 36
    • Просмотр профиля
Re: Сканер Mustek BearPaw 1200 неправильно определяется
« Ответ #5 : 25 Февраль 2008, 16:56:00 »
я не использовал firmware, потому что я использую драйве plustek, а не GT68xx.
А что мешает использовать GT68xx? С ним проблем нет.

Оффлайн keha

  • Автор темы
  • Активист
  • *
  • Сообщений: 616
  • Вот такой вот...
    • Просмотр профиля
Re: Сканер Mustek BearPaw 1200 неправильно определяется
« Ответ #6 : 26 Февраль 2008, 05:09:26 »
GT68xx не поддерживает чип LM9832
на перегонки со временем

Оффлайн ZPLen

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Сканер Mustek 1200 ub PLus установился, работал недели две, после чего юзер перестал его видеть, видит только камеру:
[user@user ~]$ scanimage -L
device `v4l:/dev/video0' is a Noname Logitech QuickCam Communicate S virtual device
xsane работает только с вебкамерой
 :'(
Под рутом xsane работает нормально:
root@user ~]# scanimage -L
device `v4l:/dev/video0' is a Noname Logitech QuickCam Communicate S virtual device
device `gt68xx:libusb:002:003' is a Trust Compact Scan USB 19200 flatbed scanner
Что нужно, чтобы юзер увидел device `gt68xx:libusb:002:003' ?
При этом GIMP под юзером предлагает другое у-во для сканера - gt68xx:libusb:002:004 (которое ес-но не определяется)
Юзер в группу scanner включен
прошивка PS1fw.usb в /usr/share/sane/gt86xx/ со всеми правами
файл gt68xx.conf в /etc/sane.d/ отредактирован вроде как надо

Оффлайн keha

  • Автор темы
  • Активист
  • *
  • Сообщений: 616
  • Вот такой вот...
    • Просмотр профиля
надо открыть доступ юзеру к папке gt86xx, где лежит прошивка
на перегонки со временем

Оффлайн keha

  • Автор темы
  • Активист
  • *
  • Сообщений: 616
  • Вот такой вот...
    • Просмотр профиля
Re: Сканер Mustek BearPaw 1200 неправильно определяется
« Ответ #9 : 16 Февраль 2009, 07:43:46 »
Добрались тут мои руки опять до этого сканера. В этот раз я его пытался завел в kubuntu 8.04
В kubuntu 8.04 все проблемы ранее упомянутые решились. Просто редактируем файл /etc/sane.d/plustek.conf как выше мною описано и все!
на перегонки со временем

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.