Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Ошибки при обновлении пакетов  (Прочитано 10751 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pirate_P

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Ошибки при обновлении пакетов
« : 07 Апреля 2013, 11:44:30 »
Доброго времени суток. Установил Ubuntu 12.10 и начал устанавливать пакеты требуемые для решения моих целей. В итоге столкнулся с проблемой обновления пакетов.
При попытке выполнить команду:
apt-get upgradeВыводит следующее сообщение:
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 ubuntu-minimal : Depends: libc6-i686
E: Unmet dependencies. Try using -f.
При попытке выполнить:
apt-get -f installВыдает следующую ошибку:
Correcting dependencies... failed.
The following packages have unmet dependencies:
 ubuntu-minimal : Depends: libc6-i686
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
Все команды выполненные выше, нужны лишь для того что бы скачать java, но при попытке установки:
openjdk-6-jre-headlessИмеем:
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 openjdk-6-jre-headless : Depends: openjdk-6-jre-lib (>= 6b27-1.12.3-0ubuntu1~12.04.1) but it is not going to be installed
                          Depends: ca-certificates-java but it is not going to be installed
                          Depends: tzdata-java but it is not going to be installed
                          Depends: java-common (>= 0.28) but it is not going to be installed
                          Depends: libjpeg8 but it is not going to be installed
                          PreDepends: multiarch-support but it is not going to be installed
                          Recommends: icedtea-6-jre-cacao (= 6b27-1.12.3-0ubuntu1~12.04.1) but it is not going to be installed
                          Recommends: icedtea-6-jre-jamvm (= 6b27-1.12.3-0ubuntu1~12.04.1) but it is not going to be installed
 ubuntu-minimal : Depends: libc6-i686
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

За раннее благодарен.

Оффлайн san-alex

  • Забанен
  • Старожил
  • *
  • Сообщений: 7726
  • Ex-CNC programmer
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #1 : 07 Апреля 2013, 13:57:00 »
Джава устанавливается вот так.
А ты понадобавлял репозиториев, и начались конфликты версий пакетов. Лучше всего отключить левые репозитории, обновиться и установить, как в ссылке, которую я дал. Я сам устанавливал именно так и прекрасно работает.

Оффлайн Pirate_P

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #2 : 07 Апреля 2013, 14:48:02 »
В том то и дело, что в любом случае выскакивает:
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u15-2.3.7-0ubuntu1~12.04.1) but it is not going to be installed
                 Depends: libasound2 (>= 1.0.23)
                 Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
                 Depends: libjpeg8 (>= 8c) but it is not going to be installed
                 Depends: libpulse0 (>= 1:0.99.1) but 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14 is to be installed
                 Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not going to be installed
                 Recommends: ttf-dejavu-extra but it is not going to be installed
 ubuntu-minimal : Depends: libc6-i686
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Оффлайн san-alex

  • Забанен
  • Старожил
  • *
  • Сообщений: 7726
  • Ex-CNC programmer
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #3 : 07 Апреля 2013, 14:54:22 »
Репозитории поотключал?

Оффлайн Pirate_P

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #4 : 07 Апреля 2013, 15:02:30 »
если ты про sources.list, то да, из него удалил те две строчечки

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #5 : 07 Апреля 2013, 16:25:25 »
Pirate_P,
sudo apt-get purge openjdk-7-jreвыхлоп под спойлер
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн san-alex

  • Забанен
  • Старожил
  • *
  • Сообщений: 7726
  • Ex-CNC programmer
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #6 : 07 Апреля 2013, 16:27:53 »
...и вывод этих двух команд тоже:
ls /etc/apt/sources.list.d
cat /etc/apt/sources.list

Оффлайн Pirate_P

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #7 : 07 Апреля 2013, 17:12:25 »
apt-get purge openjdk-7-jre
(Нажмите, чтобы показать/скрыть)

cat /etc/apt/sources.list
(Нажмите, чтобы показать/скрыть)

На ls /etc/apt/sources.list.d не реагирует.

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #8 : 07 Апреля 2013, 17:17:55 »
Pirate_P,
а команда
sudo apt-get install -fвыдает тоже самое что и
В том то и дело, что в любом случае выскакивает:
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u15-2.3.7-0ubuntu1~12.04.1) but it is not going to be installed
                 Depends: libasound2 (>= 1.0.23)
                 Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
                 Depends: libjpeg8 (>= 8c) but it is not going to be installed
                 Depends: libpulse0 (>= 1:0.99.1) but 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14 is to be installed
                 Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not going to be installed
                 Recommends: ttf-dejavu-extra but it is not going to be installed
 ubuntu-minimal : Depends: libc6-i686
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

?
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн san-alex

  • Забанен
  • Старожил
  • *
  • Сообщений: 7726
  • Ex-CNC programmer
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #9 : 07 Апреля 2013, 17:22:20 »
Попробуй почистить систему и поставить пакет вручную:
sudo apt-get autoremove
sudo apt-get clean
sudo apt-get update
sudo apt-get install libc6-i686

Оффлайн Pirate_P

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #10 : 07 Апреля 2013, 17:37:27 »
Попробуй почистить систему и поставить пакет вручную:
sudo apt-get autoremove
sudo apt-get clean
sudo apt-get update
sudo apt-get install libc6-i686
На все команды пишет ошибку
Try 'apt-get -f install' with no packages (or specify a solution).

Оффлайн san-alex

  • Забанен
  • Старожил
  • *
  • Сообщений: 7726
  • Ex-CNC programmer
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #11 : 07 Апреля 2013, 17:42:04 »
ХЗ, попробуй этот пакет вручную поставить: http://pkgs.org/debian-sid/debian-main-i386/libc6-i686_2.11.3-4_i386.deb.html

Оффлайн Pirate_P

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #12 : 07 Апреля 2013, 19:08:53 »
Не получается, после попытки манипуляции с обновлением пакетов одна и та же ошибка

Оффлайн chaevara

  • Активист
  • *
  • Сообщений: 702
    • Просмотр профиля
Re: Ошибки при обновлении пакетов
« Ответ #13 : 10 Апреля 2013, 16:14:22 »
по первому посту apt-get ругается на зависимости
ubuntu-minimal : зависит от : libc6-i686
т.е. он не может поставить ubuntu-minimal, так как нет libc6-i686, если я правильно понимаю. и поэтому установка отложена (held)
, значит нужно насильно поставить с ключом -f:
sudo apt-get install -f ubuntu-minimal
а потом доустановить libc6-i686.deb (скачанный)
не?

посмотрел у себя в синаптике: ubuntu-minimal установлен, а libc6-i686 отсутствует вообще
« Последнее редактирование: 10 Апреля 2013, 16:35:03 от chaevara »
$ sudo apt-get dist-upgrade. Никогда еще Штирлиц не был так близок к провалу...

 

Страница сгенерирована за 0.034 секунд. Запросов: 25.