Форум русскоязычного сообщества Ubuntu


Автор Тема: При создании пустого проекта - Qt Creator просто закрывается. Что делать?  (Прочитано 2864 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн romankoval

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
При создании пустого проект Qt Creator просто закрывается. Подскажите, что сделать

Qt Creator установил с репозитория. Версия 2.7.0 не установилась - выдало: "Зависимости пакета не могут быть разрешены". Установил второй вариант - 2.5.2.
И вот при попытке создать пустой проект - Qt Creator просто закрывается. Что тут можно сделать?

N.B. Попробовал сделать ""Файл" >> "Новый файл или проект" >> "GUI приложение Qt">> приложение "Hello World!" на кнопке PushButton - то в этом случае нормально работает.
     А вот если делаю: "Файл" >> "Новый файл или проект" >> "Другой проект" >> "Пустой проект Qt" >> Qt Creator просто закрывается и всё. Почему, подскажите, пожалуйста?

Оффлайн quiet_readonly

  • Участник
  • *
  • Сообщений: 133
    • Просмотр профиля
Кажется, QtCreator падает. Я так понимаю, используется Ubuntu 12.04?

Оффлайн romankoval

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Да, у меня Ubuntu 12.04. Как же можно решить эту проблему?

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5121
  • Все по палатам!
    • Просмотр профиля
12.04 - из репозитариев qtcreator 2.4.1 (qt4.8.0) - все работает.
Извините, я все еще учусь

Оффлайн romankoval

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Qt Creator установил с "Центра приложений Ubuntu" (по-другому не умею). Версия 2.7.0 не установилась - выдало: "Зависимости пакета не могут быть разрешены". Установил второй вариант - 2.5.2. Других вариантов там нет.
У меня qt 4.8.1.

Если у Вас, SergeyIT, 2.4.1 и qt4.8.0 нормально работают, то может и мне их установить? Вот только как удалить qt 4.8.1? И откуда потом установить Qt Creator 2.4.1 и qt4.8.0?

Или может проблема в другом? Я вот, например, просто установил Qt Creator, без всяких настроек. Может его как-то надо настраивать? Или доустанавливать какие-то дополнительные пакеты (этого я тоже не умею)?

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5121
  • Все по палатам!
    • Просмотр профиля
В центре в источниках у вас наверно стоит пре-релиз апдейт.
То есть надо снести qtcreator, оставить только рекомендованные апдейты и установить снова.
Извините, я все еще учусь

Оффлайн romankoval

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
В центре в источниках у вас наверно стоит пре-релиз апдейт.

Там для версии 2.5.2 было написано precise-backports - это и означает "пре-релиз апдейт"?

То есть надо снести qtcreator, оставить только рекомендованные апдейты и установить снова.
Удалить значит qtcreator. А что значит - оставить только рекомендованные апдейты?

Дракон

  • Гость
Почему бы не установить новейшую Qt прямо с сайта http://qt-project.org/downloads

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5121
  • Все по палатам!
    • Просмотр профиля
А что значит - оставить только рекомендованные апдейты?
Примерно здесь
http://help.ubuntu.ru/wiki/%D1%80%D0%B5%D0%BF%D0%BE%D0%B7%D0%B8%D1%82%D0%BE%D1%80%D0%B8%D0%B9
Но в 12.04 уже изменено кое-что
Извините, я все еще учусь

Оффлайн romankoval

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Почему бы не установить новейшую Qt прямо с сайта http://qt-project.org/downloads
Всё дело в том, что я не знаю - как её оттуда установить. И если устанавливать qt5, то как удалить qt4.8.1?

Оффлайн _XDD_

  • Участник
  • *
  • Сообщений: 108
    • Просмотр профиля
sudo apt-add-repository ppa:alexey-ivanov/qtcreator
sudo apt-get update
sudo apt-get upgrade

2.7 для 4.8

Оффлайн romankoval

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
А что делает команда:
sudo apt-add-repository ppa:alexey-ivanov/qtcreator
?

Она устанавливает Qr Creator или дополняет его?

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
romankoval,
Цитировать
Всё дело в том, что я не знаю - как её оттуда установить.
Кто ищет тот всегда найдет.
1)заходишь на сайт http://qt-project.org/downloads
2)скачиваешь файл в зависимости от твоей системы (Linux-32 бит или Linux-64 бит)
3)Как файл скачался нажимаешь правой кнопкой мыши и ставишь галочку напротив "разрешить исполнение как программы"
4)Теперь, либо нажимаешь двойным щелчком мыши и устанавливаешь файл либо открываешь терминал, файл кидаешь в терминал и нажимаешь enter и устанавливаешь через графический установщик.
5)Устанавливаешь зависимости для Qt sudo apt-get install "^libxcb.*" libx11-xcb-dev libglu1-mesa-dev libxrender-dev
6)Profit!
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн romankoval

  • Автор темы
  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля


5)Устанавливаешь зависимости для Qt sudo apt-get install "^libxcb.*" libx11-xcb-dev libglu1-mesa-dev libxrender-dev

Установил и оно выдало: "Аварийное завершение"
Вот подробности:
(Нажмите, чтобы показать/скрыть)

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
romankoval,
просто еще раз введи команду, такое бывает.
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

 

Страница сгенерирована за 0.124 секунд. Запросов: 25.