Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Ubuntu 13.04 с шифрованным диском - проблема загрузки...  (Прочитано 1313 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Darkwolf

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
  • Волчище серый хвостище!
    • Просмотр профиля
    • Пока тут мой блог :)
Доброго времени, форумчане!
Недвно появился повод обновить систему, что называется "с нуля", причиной послужила замена жёсткого диска.
Во время работы мастера установки, решил использовать шифрование разделов (почему именно так тут объяснять не буду, ибо оффтоп, да и потом, если это предусмотрено, то почему бы и не воспользоваться :)).
Вобщем, после установки, при включениях и перезагрузке компа запуск системы останавливался с ошибкой: "cryptsetup: evms_activate is not avaliable" (см. скриншот), поле для ввода ключа при этом не появляется.

Если подождать продолжительное время, выпадает консоль с BusyBox'ом (см. скриншот).

После одного или нескольких перезапусков (системы в этом пока не заметил, иногда всё нормально грузится и при первом включении компа) загрузка проходит нормально: пояляется поле для ввода пароля, после ввода пароля система грузится без каких-либо проблем.
В чём может быть проблема? На 12.04 я с таким не сталкивался.
Отказываться от шифрования не хочу, но и мыслей никаких нет. Гугление тоже ничего внятного не даёт.

Оффлайн rayanAyar

  • Старожил
  • *
  • Сообщений: 1027
  • Да пребудет с вами совпавшая контрольная сумма
    • Просмотр профиля
Гугль вываливает тучу ссылок на эту проблему. Это пробовали?
update-initramfs -u -k all
Покажите пожалста содержимое /etc/crypttab и /etc/fstab

Оффлайн Darkwolf

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
  • Волчище серый хвостище!
    • Просмотр профиля
    • Пока тут мой блог :)
Гугль вываливает тучу ссылок на эту проблему. Это пробовали?

На то он и гугл, чтобы вываливать тучу ссылок ;D Только так чтобы конкретно по моей проблеме не нашёл ничего похожего, у всех причины возникновения проблемы разные. Вообще, если признаться честно, не особо люблю перечитывать форумы на вражеском языке, по многим пробежал просто глазами :) Сейчас пересмотрел кое-какие ссылки более подробно. Заметил на лаунчпаде схожую проблему (если закрыть глаза, опять же, на то, что у человека RAID 0) https://bugs.launchpad.net/ubuntu/+source/cryptsetup/+bug/957602. Если в 2х словах, как я понял, проблема в том, что evms не нравится образ initramfs, о чём cryptsetup нам и сообщает, то ли он не подходит для конкретной версии ядра, то ли ещё что-то. А командой:

update-initramfs -u -k all
мне как раз предлагается подогнать initramfs под все ядра которые у меня в системе имеются? Если так, то тогда не совсем понятен такой момент, почему в каких-то случаях cryptsetup отрабатывает нормально, а при каком-то положении звёзд не работает?

Это пробовали?
update-initramfs -u -k all

Благодарю. Попробовал. Понаблюдаю, пока не понятно :coolsmiley:

Покажите пожалста содержимое /etc/crypttab и /etc/fstab

Пожалста:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/ubuntu--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sde1 during installation
UUID=e3f8b3b8-2f98-4be2-84ac-d98cd9bf324b /boot           ext2    defaults        0       2
/dev/mapper/ubuntu--vg-swap_1 none            swap    sw              0       0

sde5_crypt UUID=47908aed-2049-47e6-adc0-cb0d4730c0fc none luks
Пользователь решил продолжить мысль 13 Мая 2013, 23:36:36:
update-initramfs -u -k allПопробовал, не помогло. При первом же включении: "cryptsetup: evms_activate is not avaliable", сделал reset, со второй попытки поле для ввода пароля появилось.
« Последнее редактирование: 13 Мая 2013, 23:36:36 от Darkwolf »

Оффлайн Darkwolf

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
  • Волчище серый хвостище!
    • Просмотр профиля
    • Пока тут мой блог :)
Вобщем разобрался кажется :) Оставляю решение, может кому ещё пригодится.
Для того чтобы избавится от проблемы, нужно подогнать initramfs под последнюю версию ядра, и сделать это не для всех ядер, а только для последнего. Ну к примеру так:
1. Выводим список ядер:
$ ls /boot/
abi-3.8.0-19-generic         initrd.img-3.8.0-22-generic
abi-3.8.0-20-generic         lost+found
abi-3.8.0-21-generic         memtest86+.bin
abi-3.8.0-22-generic         memtest86+_multiboot.bin
config-3.8.0-19-generic      System.map-3.8.0-19-generic
config-3.8.0-20-generic      System.map-3.8.0-20-generic
config-3.8.0-21-generic      System.map-3.8.0-21-generic
config-3.8.0-22-generic      System.map-3.8.0-22-generic
grub                         vmlinuz-3.8.0-19-generic
initrd.img-3.8.0-19-generic  vmlinuz-3.8.0-20-generic
initrd.img-3.8.0-20-generic  vmlinuz-3.8.0-21-generic
initrd.img-3.8.0-21-generic  vmlinuz-3.8.0-22-generic
initrd.img-3.8.0-22
2. Берём последнее (ну или какое там у вас рабочее) и обновляем initramfs под него:
update-initramfs -u -k 3.8.0-22-generic3. Грузимся с этим ядром.
Периодичность появления ошибки как раз-таки и обусловлена тем, что системный механизм обновления обновляет ядро, а initramfs приходится обновлять ручками. Если во время загрузки появилась эта ошибка, не паникуем, грузимся с предыдущим ядром, производим вышеуказанные действия, и радуемся 8)
« Последнее редактирование: 27 Мая 2013, 23:58:39 от Darkwolf »

 

Страница сгенерирована за 0.101 секунд. Запросов: 24.