Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Для пакета «xserver-common:i386» не найден кандидат на установку  (Прочитано 1047 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Hi

  • Автор темы
  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
Пытаюсь поставить 32-х битные радеоновские драйвера. Apt  их отказывается ставить, причем при выяснении причин, я наткнулся на довольно интересную зависимость: один из пакетов, на который облизывается apt  называется xserver-common:i386. Вот полный вывод терминала
(Нажмите, чтобы показать/скрыть)

Так чего ж странного, спросите вы. Да дело в том, что требуемого пакета xserver-common:i386 не существует. Нет, его правда нету. Вот страница с сайта пакетов Ubuntu, надпись "архитектура", гласит all. И, если запустить muon, ввести xserver-common, и поклацать по кнопкам сортировки по архитектуре, искомый пакет будет только в архитектуре Common.
Похоже баг? Есть идеи, как внушить апту, что нужный пакет у меня уже установлен (а тот xserver-common, который существует не вне времени-пространства, у меня, конечно же стоит)?
« Последнее редактирование: 17 Мая 2013, 12:42:13 от Hi »

Оффлайн ArcFi

  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
cat /etc/issue
grep -Ev '^#|^$' /etc/apt/sources.list{,.d/*.list}
apt-cache policy xserver-xorg-video-radeon xserver-xorg-core xserver-common
?

Оффлайн Hi

  • Автор темы
  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
(Нажмите, чтобы показать/скрыть)
UPD:переместил под спойлер, по-моему удобней..
« Последнее редактирование: 17 Мая 2013, 12:49:25 от Hi »

Оффлайн ArcFi

  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Занятно...
Система 12.04, репы 13.04.

Оффлайн Hi

  • Автор темы
  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
ArcFi, то я вставил "raring" в sources, там просто дюже новее пакеты  :)
UPD: нет, я пытался обновиться и через do-release-upgrade. Дважды. :) Она просто вывела огромный список пакетов для обновления, и я не стал их просматривать, как оказалось зря: мне этот дист-апгрейд удалил кучу пакетов, причем очень нужных. У меня поломалось, например KDE. Благо, что e17 стоял еще, он рабочим остался.
Это были те пакеты, которые apt-get  autoremove все порывался удалить, да я ему не давал, а список, насколько я помню был огромный. И, по загадочной причине, хотя пакеты скачались, но Ubuntu себя величает не-обновленой. Второй раз пытался -- я уже не помню, что произошло, нечто менее трагичное, но со столь же неудачным исходом.
Больше не хочу пробовать, если честно: там же по-моему кроме названия релиза больше ничего не измениться? На последнии репозитарии я вручную подключился)
« Последнее редактирование: 17 Мая 2013, 13:12:25 от Hi »

Оффлайн ArcFi

  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Обычно вот так систему и ломают.
Ну, да ладно.

Смотрим далее
arch

Оффлайн Hi

  • Автор темы
  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
constantine@constantine-N61Ja:~$ arch
x86_64

Оффлайн ArcFi

  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
А зачем на x86_64 ставить i386-иксы/дрова?
Оно точно будет работать?

Оффлайн Hi

  • Автор темы
  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
ArcFi, я без понятия, пытаюсь установить просто из-за зависимостей. Ну, если Вам интересно мое мнение, то, как я полагаю, 32-битные библиотеки просто будут параллельно стоять...
Ну, у других же ведь работает, ставят же 32-битные драйвера на 64-битную систему. Да более того -- несколькими неделями ранее, у меня у самого удалось их поставить сюда, никаких проблем не было -- они для запуска под wine'ом приложений нужны. Когда они успели испарится, понятия не имею :) Но я их совершенно точно ставил. В смысле я про драйвер.

Оффлайн ArcFi

  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Попахивает извращением, но если вы в этом уверены, то можно попытаться поставить требуемые пакеты руками через dpkg.

Оффлайн Hi

  • Автор темы
  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
ArcFi, спасибо, я через sudo dpkg --unpack поставил пока. Но, apt пишет, что у меня пакет "разбитый", это конечно не выход.

 

Страница сгенерирована за 0.046 секунд. Запросов: 26.