Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Постоянная «Проверка SSL-сертификата» в Pidgin  (Прочитано 7878 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vkapas

  • Автор темы
  • Любитель
  • *
  • Сообщений: 93
    • Просмотр профиля
Использую Pidgin для приёма заявок из онлайн-консультата с одного из своих сайтов. Использую онлайн-консультант от компании Redhelper, который настроен по этой, написанной самой компанией, инструкции: https://redhelper.zendesk.com/entries/21000797-%D0%9D%D0%B0%D1%81%D1%82%D1%80%D0%BE%D0%B9%D0%BA%D0%B0-Pidgin

Всё работает отлично, но есть проблема: после каждого подключения к интернету (или выхода джабберовского аккаунта в сеть, а иногда и просто так в течение дня) Pidgin запрашивает сертификат xmpp.redhelper.ru. Вот с таким вот текстом:

Цитировать
Сертификат для xmpp.redhelper.ru не может быть подтверждён.
Вместо этого сертификат утверждает, что он от "ejabberd". Это может означать, что вы подключены не к той услуге, к которой думаете.
Сертификат является самоподписанным и не может быть автоматически проверен.


Причём этот сертификат уже был принят при первом подключении и находится в списке сертификатов. В этом списке есть и другие джабберовоские сертификаты, например, vk.com и jabber.ru, которые я тоже постоянно использую, но Pidgin не запрашивает их при каждом подключении к сети.

ТП Redhelper в решении не помогла и ответила отпиской:
Цитировать
Это проблема конкретно Pidgin и только под Линукс. Если это мешает, стоит использовать другой клиент.

В чём может быть проблема, можно ли её решить?
« Последнее редактирование: 02 Марта 2014, 22:20:26 от vkapas »

Оффлайн ArcFi

  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
dpkg -l | grep ^ii.*pidgin?

Оффлайн vkapas

  • Автор темы
  • Любитель
  • *
  • Сообщений: 93
    • Просмотр профиля
$ dpkg -l | grep ^ii.*pidgin
ii  libgadu3                                          1:1.11.0+r1184-2~pidgin1.10.04                      Gadu-Gadu protocol library - runtime files
ii  libpurple-bin                                     1:2.10.6-0ubuntu1+pidgin1.10.04                     multi-protocol instant messaging library - e
ii  libpurple-dev                                     1:2.10.6-0ubuntu1+pidgin1.10.04                     multi-protocol instant messaging library - d
ii  libpurple0                                        1:2.10.6-0ubuntu1+pidgin1.10.04                     multi-protocol instant messaging library
ii  pidgin                                            1:2.10.6-0ubuntu1+pidgin1.10.04                     graphical multi-protocol instant messaging c
ii  pidgin-data                                       1:2.10.6-0ubuntu1+pidgin1.10.04                     multi-protocol instant messaging client - da
ii  pidgin-libnotify                                  0.14-1ubuntu14                                      display notification bubbles in pidgin
ii  pidgin-plugin-pack                                2.6.2-0ubuntu2                                      Collection of Pidgin plugins
ii  pidgin-skype                                      20100121+dfsg-1                                     Skype plugin for libpurple messengers
ii  pidgin-themes                                     0.2-1                                               Smiley themes collection for pidgin
« Последнее редактирование: 17 Мая 2013, 14:26:30 от vkapas »

Оффлайн ArcFi

  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
OK
Покажите скрин с настройками подключения к серверу.

Оффлайн vkapas

  • Автор темы
  • Любитель
  • *
  • Сообщений: 93
    • Просмотр профиля
Ничего необычного, всё как в инструкции:


В настройках Прокси — «Использовать настройки прокси GNOME» (не использую)
Голос и видео — галок никаких не стоит.

Оффлайн ArcFi

  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
ТП Redhelper в решении не помогла и ответила отпиской:
Цитировать
Это проблема конкретно Pidgin и только под Линукс. Если это мешает, стоит использовать другой клиент.
Строго говоря, это неправда.
Попробовал подключиться к их серверу в конторе на pidgin-2.10.7 под вендами — та же самая ошибка.

Пробовал дописывать в конфиг:
<setting name='ignore-ssl-errors' type='bool'>1</setting>
<setting name='ignore_ssl_errors' type='bool'>1</setting>
Но это не помогло.

(Нажмите, чтобы показать/скрыть)

Тут нашёл похожие тикеты:
https://developer.pidgin.im/ticket/14439
https://developer.pidgin.im/ticket/6664

Как вариант, можно попробовать empathy.
Там точно есть опция для игнорирования ошибок SSL-сертификатов.
« Последнее редактирование: 17 Мая 2013, 20:33:12 от ArcFi »

Оффлайн vkapas

  • Автор темы
  • Любитель
  • *
  • Сообщений: 93
    • Просмотр профиля
Спасибо за тест Пиджина на венде и ссылки.

А до меня, тем временем, дошла информация, что сертификат redhelper подписан некорректно. В общем-то, из-за этого Pidgin и ругается. Отправил инфу разрабам, посмотрим, что они скажут.

Пользователь решил продолжить мысль 17 Мая 2013, 21:04:32:
Цитировать
Как вариант, можно попробовать empathy.
Там точно есть опция для игнорирования ошибок SSL-сертификатов.
Спасибо за информацию. Empathy рассматриваю только как крайний вариант, т.к. специально искал такой онлайн-консультант, который можно присовокупить к Pidgin посредством Jabber. Но даже если ничего не получится, то проще будет, наверное, использовать веб-клиент, чем устанавливать ещё один мессенжер.
« Последнее редактирование: 17 Мая 2013, 21:04:32 от vkapas »

Оффлайн vkapas

  • Автор темы
  • Любитель
  • *
  • Сообщений: 93
    • Просмотр профиля
Внезапно, спустя полгода, разработчики ответили на мои мольбы тикеты и починили свой сертификат. Ура!

 

Страница сгенерирована за 0.065 секунд. Запросов: 24.