Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Слетел интерфейс пользователя xfce  (Прочитано 1751 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн InventoR

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Добрый день всем.
Может конечно уже обсуждалось, но так сходу найти не удалось.
Чудесным образом после перезагрузки слетел дефалтный интерфейс xfce в профиле пользователя и теперь многие пункты программ в меню показываются без иконок и рабочий стол без интерфейса, интерфейс в стиле старого гнома. Подробней во вложении.

Был создан второй профиль пользователя и там интерфейс превосходно работает.
В старом профиле чистились ссесии, создавалась новая но не помогает. Так как не сильно понимаю что за что отвечает в интерфейсе то прошу вашей помощи натолкнуть на путь истиный и исправить эту досадную проблему, так как натыкаюсь второй раз и перекатывать систему не сильно хочется. В прошлый раз виновником был аммарок, судя по всему при удалении унес за собой все нужные файлы для оформления. В этот раз обновлений не было, ничего такого не было в обще за последний месяц, а аптайм всего 10 дней.

Также вместе с этим перестали работать хоткеи настроенны для регулировки музыки и printscreen.

http://s1.ipicture.ru/uploads/20130519/215FEPsF.jpg


Руководство по добавлению изображений на форум
« Последнее редактирование: 19 Май 2013, 12:02:12 от Haron Prime »

zpa1488

  • Гость
Re: Слетел интерфейс пользователя xfce
« Ответ #1 : 19 Май 2013, 10:50:55 »
Удаление папки ~/.config/xfce4/ должно помочь. Если нет, то уж тогда удаление большей части скрытых папок в папке пользователя. Именно там находятся конфигурационные файлы. При перелогине после удаления их настройки слетят на дефолтные для системы и папки создадутся вновь. Только придется все заново настраивать. :-\

Оффлайн InventoR

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Слетел интерфейс пользователя xfce
« Ответ #2 : 20 Май 2013, 01:40:09 »
мил человек, спасибо, да, помогло, и тут же докопался, проблема решается после удаления файла: xfwm4.xml
в архиве два файла, тот что не работает и тот что создается после удаления и работает, если кто скажет причину такого поведения, буду очень благодарен.

Оффлайн v!tax

  • Старожил
  • *
  • Сообщений: 4157
  • Gentoo x64 bspwm
    • Просмотр профиля
Re: Слетел интерфейс пользователя xfce
« Ответ #3 : 20 Май 2013, 01:41:28 »
найди десять отличий?чем созданный неугодил?
господь ведет твою руку, сын мой....

zpa1488

  • Гость
Re: Слетел интерфейс пользователя xfce
« Ответ #4 : 20 Май 2013, 07:02:47 »
zpa1488@dns:~/Загрузки/xfce-perchannel-xml$ diff xfwm4.xml xfwm4.xml-old-notwork > changesвывод
А причина какая, хз)))

Оффлайн InventoR

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
    • Просмотр профиля
Re: Слетел интерфейс пользователя xfce
« Ответ #5 : 20 Май 2013, 11:41:12 »
Дамс, ночью то не увидил что в проблемном файле все type пустые.
а вот пересозданый, все отлично.

чем не угодил, ну это другой вопрос, тут скорее попытка понять что привело к появлению такой проблемы.

Оффлайн yodev

  • Любитель
  • *
  • Сообщений: 59
    • Просмотр профиля
Re: Слетел интерфейс пользователя xfce
« Ответ #6 : 21 Май 2013, 18:13:27 »
открываешь консоль
пишешь sudo adduser
пишешь ему имя пароль

выходишь из системы

заходишь под новым пользователем, твой рабочий стол в первоначальном состоянии.
« Последнее редактирование: 29 Май 2013, 05:36:20 от yodev »

Оффлайн m010103

  • Участник
  • *
  • Сообщений: 152
    • Просмотр профиля
Re: Слетел интерфейс пользователя xfce
« Ответ #7 : 18 Июнь 2013, 18:08:56 »
Нарвался и я на эти грабли. шапки окон нет, мыши (указателя) нет, если и появляется то ввиде жирного черного креста.
Создал я нового пользователя, там все отлично, дал ему все права в том числе и sudo, скопировал из конрня первой учетки в корень второй все файлы и папки посредством MC от sudo, зашел во вторую учетку, часть настроек таки не перешла, софт под вайном тоже не живой. Виртуал бох попросил снова пересоздать машины и т.д.
Вернулся впервую учетку и попробовал в терминале xfwm4 --replace все ожило и в первой учетке! :) после перезагрузки снова грабли, заголовков не, мыши нет и т.д.
как побороть? или не парится, а в автозапуске прописать  xfwm4 --replace ?
Спасибо.

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7169
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Слетел интерфейс пользователя xfce
« Ответ #8 : 18 Июнь 2013, 19:58:00 »
Эту тему читать пробовали?

 

Страница сгенерирована за 0.131 секунд. Запросов: 24.