Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Пропал звук в ubuntu 13.04  (Прочитано 2625 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн almaric

  • Автор темы
  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
Пропал звук в ubuntu 13.04
« : 05 Июня 2013, 20:26:00 »
Добрый день!

Помогите пожалуйсто решить вопрос со звуком!

Пропал звук в ubuntu 13.04:

Нашёл в инете решение проблемы в виде команды:

sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`вбиваю в терминал, в конце выдаёт вот это:
(Нажмите, чтобы показать/скрыть)
жму Д и выдаёт вот это:
(Нажмите, чтобы показать/скрыть)
Снова жму Д, в конце выдаёт вот это:
(Нажмите, чтобы показать/скрыть)
  >:(

Помогите люди умные и добрые!  ;)
ubuntu 14.04, ядро 3.13.0-24-generic

Оффлайн gizomo

  • Любитель
  • *
  • Сообщений: 63
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #1 : 05 Июня 2013, 20:40:20 »
У тебя звук через hdmi?

Попробуй так
sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt-get update
sudo apt-get install oem-audio-hda-daily-dkms

Оффлайн almaric

  • Автор темы
  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #2 : 05 Июня 2013, 20:41:29 »
gizomo, я не знаю через что. как это узнать?

Пользователь решил продолжить мысль 05 Июня 2013, 20:45:49:
gizomo, на команду:
sudo apt-get updateвыдало это:
Цитировать
Чтение списков пакетов… Готово
W: Duplicate sources.list entry http://archive.ubuntu.com/ubuntu/ raring/restricted i386 Packages (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_raring_restricted_binary-i386_Packages)
W: Duplicate sources.list entry http://archive.ubuntu.com/ubuntu/ raring-updates/restricted i386 Packages (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_raring-updates_restricted_binary-i386_Packages)
W: Вы можете запустить «apt-get update» для исправления этих ошибок
продолжаю командой:
sudo apt-get install oem-audio-hda-daily-dkmsвыдаёт вот это:
Цитировать
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия oem-audio-hda-daily-dkms.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить [Д/н]?
жму Д выдаёт вот это:
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 05 Июня 2013, 20:45:49 от almaric »
ubuntu 14.04, ядро 3.13.0-24-generic

Оффлайн v!tax

  • Старожил
  • *
  • Сообщений: 4154
  • Gentoo x64 bspwm
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #3 : 05 Июня 2013, 20:48:05 »
зачем вы копируете команды в терминал,не понимая что они делают?так у Вас не только звук работать перестанет.
после чего звук перестал работать?
господь ведет твою руку, сын мой....

Оффлайн almaric

  • Автор темы
  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #4 : 05 Июня 2013, 20:51:33 »
#anonymous>, короче комп перестал влючатся, решил почистить пыль, разобрал, почистил, собрал включил, всё заработало только перестали работать клавиатура и мышь, мне посоветовали вынуть батарейку и сбросить биос, ну вынул, поколупался ещё с неделю с этим компом короче в результате всё заработало и комп, и мышь с клавой, но звука нет. Может тогда это железо не знаю... Но почему тогда выдают всякие ошибки при попытках исправить и ту же алсу и всё что связано со звуком? если дело в железе, значит тут должно быть всё гуд, короче не знаю
ubuntu 14.04, ядро 3.13.0-24-generic

Оффлайн gizomo

  • Любитель
  • *
  • Сообщений: 63
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #5 : 05 Июня 2013, 20:51:58 »
Да, походу, тут трабла с самим пакетом. Вот человек уже пофиксить пробовал зависимости, в итоге полсистемы улетело (https://forum.ubuntu.ru/index.php?topic=222266.0).

Пользователь решил продолжить мысль 05 Июня 2013, 21:07:31:
Судя по ошибке, модуль hda не прикручивается к твоему ядру. И скорее всего проблема в ядре 3.9
Попробуй пока снести модуль hda.
sudo apt-get --purge remove oem-audio-hda-daily-dkmsА потом сделай апгрейд системы.
sudo apt-get dist-upgrade
« Последнее редактирование: 05 Июня 2013, 21:07:31 от gizomo »

Оффлайн almaric

  • Автор темы
  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #6 : 05 Июня 2013, 21:11:37 »
gizomo, на команду:
sudo apt-get --purge remove oem-audio-hda-daily-dkmsудалил, а на команду:
sudo apt-get dist-upgradeвыдало только это:
Цитировать
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений…Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

и дальше не идёт
ubuntu 14.04, ядро 3.13.0-24-generic

Оффлайн gizomo

  • Любитель
  • *
  • Сообщений: 63
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #7 : 05 Июня 2013, 21:12:07 »
Если не получится, то не вздумай сносить ядро 3.9. Оно утянет за собой и остальные ядра (глюк разрабов).
Лучше просто на старом ядре систему загрузи пока.

Оффлайн almaric

  • Автор темы
  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #8 : 05 Июня 2013, 21:44:45 »
gizomo, короче перешёл на ядро 3.8.0-24-generic то же самое что и выше:

Цитировать
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений…Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
ubuntu 14.04, ядро 3.13.0-24-generic

Оффлайн gizomo

  • Любитель
  • *
  • Сообщений: 63
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #9 : 05 Июня 2013, 21:57:20 »
Качай пакет https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+files/oem-audio-hda-daily-dkms_0.201306050203%7Eraring1_all.deb
Потом в консоли выполни:
sudo dpkg -i <здесь укажи путь к скаченному файлу>

Оффлайн almaric

  • Автор темы
  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #10 : 05 Июня 2013, 23:35:51 »
gizomo, короче на ядре 3.8.0-24-generic запустил этот пакет через центр приложений и установил и выдало вот что:
Цитировать
DKMS: install completed.
Building initial module for 3.9.0-030900-generic
Error!  The dkms.conf for this module includes a BUILD_EXCLUSIVE directive which
does not match this kernel/arch.  This indicates that it should not be built.
dpkg: error processing oem-audio-hda-daily-dkms (--install):
 subprocess installed post-installation script returned error exit status 9
Errors were encountered while processing:
 oem-audio-hda-daily-dkms
перешёл на ядро 3.9 получилось вот это:
Цитировать
snd-hda-codec-cmedia.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.8.0-24-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod...............

DKMS: uninstall completed.

------------------------------
Deleting module version: 0.201306050203~raring1
completely from the DKMS tree.
------------------------------
Done.
Unpacking replacement oem-audio-hda-daily-dkms ...
Setting up oem-audio-hda-daily-dkms (0.201306050203~raring1) ...
Loading new oem-audio-hda-daily-0.201306050203~raring1 DKMS files...
First Installation: checking all kernels...
Building only for 3.9.0-030900-generic
Building for architecture i686
Building initial module for 3.9.0-030900-generic
Error!  The dkms.conf for this module includes a BUILD_EXCLUSIVE directive which
does not match this kernel/arch.  This indicates that it should not be built.
dpkg: error processing oem-audio-hda-daily-dkms (--install):
 subprocess installed post-installation script returned error exit status 9
Errors were encountered while processing:
ubuntu 14.04, ядро 3.13.0-24-generic

Оффлайн gizomo

  • Любитель
  • *
  • Сообщений: 63
    • Просмотр профиля
Re: Пропал звук в ubuntu 13.04
« Ответ #11 : 06 Июня 2013, 06:27:25 »
Ну все понятно. Как я и говорил. Для ядра 3.9 еще не выпустили модуль hd audio. Но вот чего он на ядро 3.8 не хочет ставить.
В общем можешь попробовать обновить ядро 3.9 по этому руководству https://github.com/GM-Script-Writer-62850/Ubuntu-Mainline-Kernel-Updater#readme. Говорят решает многие проблемы после его первой установки, в том числе и со звуком.

Если не поможет, то нужно еще переконфигурировать систему звука
sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo alsa force-reload

Ну и в конце еще раз попробовать на новое ядро накатить последние патчи
sudo add-apt-repository ppa:ubuntu-audio-dev
sudo apt-get update
sudo apt-get dist-upgrade

 

Страница сгенерирована за 0.04 секунд. Запросов: 25.