Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Проблема с драйверами canon pixma ip 1900  (Прочитано 964 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rosichek

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
долго пытался установить драйвер на canon pixma ip 1900 спустя какое то время получилось и нормально работает только вот заходишь в центр приложений и он начинает на драйвер ругаться и не дает устанавливать приложения пока не сам его не удалит( ubuntu называет это восстановлением  >:( ) что то можно с этим сделать ?
--изображение удалено--
« Последнее редактирование: 15 Апрель 2016, 22:06:02 от Alex_ander »

Оффлайн suslikk

  • Старожил
  • *
  • Сообщений: 2468
    • Просмотр профиля
Re: Проблема с драйверами
« Ответ #1 : 06 Июль 2013, 12:28:40 »
Как драйвер ставили?

И так попробуйте
sudo apt-get update
sudo apt-get dist-upgrade
Нарисуй свой город на openstreetmap.org

Оффлайн rosichek

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Проблема с драйверами
« Ответ #2 : 06 Июль 2013, 13:15:44 »

распаковал а потом ставил во так
sudo dpkg -i --force-all ./*.deb
Пользователь решил продолжить мысль 06 Июль 2013, 13:18:19:
Как драйвер ставили?

И так попробуйте
sudo apt-get update
sudo apt-get dist-upgrade

все равно выдает

Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 cnijfilter-common:i386 : Зависит: libcupsys2:i386 (>= 1.2.1)
 cnijfilter-ip1900series:i386 : Зависит: libcupsys2:i386 (>= 1.2.1)
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.
« Последнее редактирование: 06 Июль 2013, 13:18:19 от rosichek »

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
Re: Проблема с драйверами
« Ответ #3 : 06 Июль 2013, 13:22:40 »
rosichek,
sudo apt-get install -f ?
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн rosichek

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Проблема с драйверами
« Ответ #4 : 06 Июль 2013, 13:25:55 »
rosichek,
sudo apt-get install -f ?
не понял вопроса

Оффлайн suslikk

  • Старожил
  • *
  • Сообщений: 2468
    • Просмотр профиля
Re: Проблема с драйверами
« Ответ #5 : 06 Июль 2013, 13:28:12 »
rosichek, выполни команду, которую написал Nikki1993
sudo apt-get install -f
Нарисуй свой город на openstreetmap.org

Оффлайн rosichek

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Проблема с драйверами
« Ответ #6 : 06 Июль 2013, 13:33:21 »
sudo apt-get install -fне помогает


Пользователь решил продолжить мысль 06 Июль 2013, 13:36:43:
sudo apt-get install -fпросто предлагает удалить драйвер
« Последнее редактирование: 06 Июль 2013, 13:36:43 от rosichek »

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
Re: Проблема с драйверами
« Ответ #7 : 06 Июль 2013, 13:39:34 »
rosichek,
покажи что пишет терминал.
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн rosichek

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Проблема с драйверами
« Ответ #8 : 06 Июль 2013, 13:42:58 »
rosichek,
покажи что пишет терминал.
--изображение удалено--

Пользователь решил продолжить мысль 06 Июль 2013, 13:57:12:
что значит не разрешенные зависимости ? это как то можно исправить ?
« Последнее редактирование: 15 Апрель 2016, 22:06:48 от Alex_ander »

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
Re: Проблема с драйверами
« Ответ #9 : 06 Июль 2013, 14:16:11 »
rosichek,
неразрешенные завивисмости от твоего драйвера. Не стоило его ставить с параметром force. Я бы лучше выполнил команду
sudo apt-get install -fсогласившись на удаление всех драйверов. Потом сделал
sudo apt-get clean && sudo apt-get autoremoveэто почистит систему от ненужный пакетов
sudo apt-get update && sudo apt-get dist-upgradeобновил систему, у тебя там висят не обновленные пакеты.
Затем перезапустил систему и попробовал бы просто воткнуть принтер в компьютер. У меня Ubuntu автоматически определила принтер. Если не получится, пиши сюда и давай ссылку на инструкцию по которой делал.
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн rosichek

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Проблема с драйверами
« Ответ #10 : 06 Июль 2013, 16:48:08 »
rosichek,
неразрешенные завивисмости от твоего драйвера. Не стоило его ставить с параметром force. Я бы лучше выполнил команду
sudo apt-get install -fсогласившись на удаление всех драйверов. Потом сделал
sudo apt-get clean && sudo apt-get autoremoveэто почистит систему от ненужный пакетов
sudo apt-get update && sudo apt-get dist-upgradeобновил систему, у тебя там висят не обновленные пакеты.
Затем перезапустил систему и попробовал бы просто воткнуть принтер в компьютер. У меня Ubuntu автоматически определила принтер. Если не получится, пиши сюда и давай ссылку на инструкцию по которой делал.
сделал как ты написал но при попытки подключить принтер выдало вот это
--изображение удалено--
с начало пробовал так http://softhelp.org.ua/?p=300 но этот способ уже не работает
тогда я просто скачал драйвера под linux и попробовал поставить через консоль но начало выдавать ошибку при установке, нашел решение тут https://forum.ubuntu.ru/index.php?topic=76080.0 там как раз парень пишет про параметр force, я попробовал помогло(в плане принтер заработал, ток все остальное сломалось) 

Пользователь решил продолжить мысль 06 Июль 2013, 16:49:00:
дело в том что моего принтера нет в стандартном наборе =(

Пользователь решил продолжить мысль 06 Июль 2013, 18:13:12:
Спасибо за помощь =)
нашел решение проблемы здесь http://linuxg.net/how-to-install-printer-driver-canon-pixma-ip-series-on-ubuntu/
теперь все работает =)
« Последнее редактирование: 15 Апрель 2016, 22:07:37 от Alex_ander »

 

Страница сгенерирована за 0.09 секунд. Запросов: 24.