Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Помогите установить  (Прочитано 1185 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MiF36rus

  • Автор темы
  • Участник
  • *
  • Сообщений: 122
    • Просмотр профиля
Помогите установить
« : 18 Июль 2013, 22:14:07 »
помогите установить по данной инструкции а то не могу разобраться

https://github.com/chrisbmr/Mesa-3D/blob/gallium-nine/src/gallium/state_trackers/nine/README

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7172
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Помогите установить
« Ответ #1 : 18 Июль 2013, 22:57:38 »
MiF36rus, а зачем? В репозиториях должно быть.

Оффлайн MiF36rus

  • Автор темы
  • Участник
  • *
  • Сообщений: 122
    • Просмотр профиля
Re: Помогите установить
« Ответ #2 : 18 Июль 2013, 23:01:47 »
а в каком репозитории?

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7172
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Помогите установить
« Ответ #3 : 18 Июль 2013, 23:12:17 »
MiF36rus, что именно ставите? Инструкция там вроде для MESA.

Оффлайн MiF36rus

  • Автор темы
  • Участник
  • *
  • Сообщений: 122
    • Просмотр профиля
Re: Помогите установить
« Ответ #4 : 18 Июль 2013, 23:16:27 »
для меса вышел новый компонент обеспечивающий полную поддержку Direct3d 9 без программной прослойки.пишут что фпс в некоторых играх вырос в 2 раза!чтобы все работало нужно вот это:

https://github.com/chrisbmr/Mesa-3D/tree/gallium-nine

и это

https://github.com/chrisbmr/wine/tree/d3dadapter9-wip

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7172
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Помогите установить
« Ответ #5 : 18 Июль 2013, 23:18:23 »
MiF36rus, а может подождать? А то потом удалить будет проблемно, apt-get про них ничего знать не будет. Посмотрите на репозитории Wine, вроде в вики где-то есть.

Оффлайн MiF36rus

  • Автор темы
  • Участник
  • *
  • Сообщений: 122
    • Просмотр профиля
Re: Помогите установить
« Ответ #6 : 18 Июль 2013, 23:21:16 »
это уже не тестовая версия.она уже прошла полную проверку с MESA и WINE и по идее должна уже быть в обновлении но ее там нету и самое главное я пользуюсь не чистым wine а play on linux поэту просто патч на wine меня не спасет придется все равно все ставить самому.

Оффлайн Hi

  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
Re: Помогите установить
« Ответ #7 : 19 Июль 2013, 00:10:46 »
для меса вышел новый компонент обеспечивающий полную поддержку Direct3d 9 без программной прослойки.пишут что фпс в некоторых играх вырос в 2 раза!чтобы все работало нужно вот это:

https://github.com/chrisbmr/Mesa-3D/tree/gallium-nine

и это

https://github.com/chrisbmr/wine/tree/d3dadapter9-wip
Если вы про это, то надо wine компилять, а не драйвера)

Оффлайн MiF36rus

  • Автор темы
  • Участник
  • *
  • Сообщений: 122
    • Просмотр профиля
Re: Помогите установить
« Ответ #8 : 19 Июль 2013, 02:28:51 »
да я именно про это

Пользователь решил продолжить мысль 19 Июль 2013, 02:29:10:
Что конкретно нужно делать?

Оффлайн Hi

  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
Re: Помогите установить
« Ответ #9 : 19 Июль 2013, 03:35:21 »
Создаете папку для исходников wine, заходите туда через терминал и выполняете команду git clone https://github.com/chrisbmr/wine.git
Как все скачается, запускаете ./configure, и в течении ближайших суток кропотливо собираете зависимости (ох, не завидую я Вам, если система х64, тогда можете смело увеличивать срок на починку зависимостей в пару раз).
Если вы дотерпели до сакрального момента, когда наконец dependencies кончатся, пишите make, и, надейтесь, что компиляция пройдет без проблем.
И наконец sudo make install (или checkinstall)
Пара источников, которые могут пригодиться:
http://www.winehq.org/docs/wineusr-guide/installing-wine-source
http://wiki.winehq.org/WineOn64bit

Пользователь решил продолжить мысль 19 Июль 2013, 03:45:59:
Да, с галлиум почти так же: git clone https://github.com/chrisbmr/Mesa-3D.git
Только я глянул, там нет скрипта configure. Вам сначала надо будет ввести ./autogen.sh, а он уже родит configure.

Пользователь решил продолжить мысль 19 Июль 2013, 08:56:20:
А на инструкции, которую вы топике темы публиковали написано почти тоже, только с опциями. Просто копируете в терминал
(Нажмите, чтобы показать/скрыть)
это запустит autogen галлиума с необходимыми опциями. Я, кстати не пойму, где вы там застопорились: они в основном пишут список команд, которые вы должны просто скопировать в терминал, возможно с минимальными изменениями(на этот случай там же пишется краткое описание, что в данный момент происходит).
« Последнее редактирование: 19 Июль 2013, 09:00:26 от Hi »

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7172
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Помогите установить
« Ответ #10 : 19 Июль 2013, 16:17:08 »
Hi, зачем пара суток? Шести часов хватит для начала. Вот если по-человечески устанавливать (создать DEB пакет не через checkinstall), тогда нужно пару суток. :)

Оффлайн Hi

  • Любитель
  • *
  • Сообщений: 92
    • Просмотр профиля
Re: Помогите установить
« Ответ #11 : 19 Июль 2013, 20:25:23 »
Peregrine, я просто вспоминаю свою сборку Wine: я уже не помню всех подробностей, но приблизительно выглядело так -- я установил, как я полагал, все зависимости. Запускаю снова ./configure, он выдает кучу ошибок, при чем на то, что у меня установлено. Ладно, лезу в config.log, втыкаю, что ему надо. Выясняется, что потерялись .so файлы, сиречь симлинки на библиотеки. Насколько я понимаю, их создают обычно пакеты с префиксом -dev, но, отчего-то у меня они отсутствуют. Симлинки, т.е., а пакеты то, как раз, стоят. Начинаются долгие блуждания по логу, просмотр, какие опции он использует для радостного получения очередной ошибки, и, ручное создание ссылок.
Помню, в какой-то момент даже ошибку в скрипте обнаружил, сейчас точно не скажу, но, по-моему он вызывал функцию для проверки наличия очередной библиотеки, которая на самом деле находилась в другой. Пришлось исправлять скрипт.
Я, наверное, уже зная все эти грабли за 6-ть часов сейчас управился бы, а вот автор, который, как я понимаю, еще опыта не имеет -- вряд ли.

 

Страница сгенерирована за 0.119 секунд. Запросов: 24.