Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Linphone не работает ZRTP  (Прочитано 2236 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Corw1n

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Linphone не работает ZRTP
« : 20 Сентябрь 2013, 17:58:38 »
Собственно "не работает" не совсем правильная формулировка, потому что его тупо не выбрать в настройках. Там где он должен быть его просто нет. Options-prefernces-network settings-media encryption type - можно выбрать только SRTP/None
здесь вот обсуждается проблема, но я не понял что советуют сделать. в какой-то там файл надо что-то прописать и что-то скачать поставить, и то это какой-то костыль. судя по этому:
Found in versions linphone/3.5.2-8, linphone/3.5.2-10
Fixed in version linphone/3.5.2-11
начиная с 11 версии этого бага нет, но у меня в software manager только 3.5.2-10. На оф сайте есть исходники 3.6.1. Но вроде как она считается анстейбл (а может уже и нет), но компилировать это слишком жестко пока для меня - забил на это дело после очередной ошибки после ввода ./configure.

Оффлайн start733

  • Участник
  • *
  • Сообщений: 247
    • Просмотр профиля
Re: Linphone не работает ZRTP
« Ответ #1 : 20 Сентябрь 2013, 19:06:37 »
ставь jitsi.
Шифрование вроде работает.

Оффлайн Corw1n

  • Автор темы
  • Новичок
  • *
  • Сообщений: 34
    • Просмотр профиля
Re: Linphone не работает ZRTP
« Ответ #2 : 20 Сентябрь 2013, 21:07:58 »
ставь jitsi.
Шифрование вроде работает.
Не катит. Через какое-то время от начала звонка начинается сильное искажение звука в джитси. И в целом она работает куда медленее, чем Linphone и качество звука лучше. В джитси вот, к примеру, хоть и есть в опциях функция подавления шумов, но нифига она не работает. Звук заметно хуже, чем в скайпе том же. 

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2587
    • Просмотр профиля
Re: Linphone не работает ZRTP
« Ответ #3 : 28 Сентябрь 2013, 16:04:21 »
Corw1n,
Не написано какой у вас дистрибутив, но я включил собственную телепатию. Предпологаю, что у вас Ubuntu 12.04 и Linphone вы ставили с этого PPA https://launchpad.net/~felix.lechner/+archive/linphone-ppa?field.series_filter=precise Но для 12.04 есть и последняя версия доступная в PPA вот же она https://launchpad.net/~linphone/+archive/release?field.series_filter=precise
Лучше всего будет удалить все пакеты из старого PPA удалить старый PPA можно даже и его ключи, и потом установить новый PPA  ppa:linphone/release удобным для вас способом.

А вообще SIP клиентов нормальных считай нет, но Linphone по моему мнению вообще непригоден для использования, но может быть вам больше повезёт. У меня сейчас стоит последние версии SFLPhone (gnome версия) и Twinkle. SFLPhone в целом нравиться, но есть баги из за которых он не работает с некоторыми (некоторым) SIP провайдерами. Twinkle работает со всеми, но имеет ужасный дизайн, GUI на qt3, и нет ни какой поддержки video.

Оффлайн ode2

  • Активист
  • *
  • Сообщений: 268
    • Просмотр профиля
Re: Linphone не работает ZRTP
« Ответ #4 : 13 Январь 2014, 18:46:01 »
Собственно "не работает" не совсем правильная формулировка, потому что его тупо не выбрать в настройках. Там где он должен быть его просто нет. Options-prefernces-network settings-media encryption type - можно выбрать только SRTP/None
здесь вот обсуждается проблема, но я не понял что советуют сделать. в какой-то там файл надо что-то прописать и что-то скачать поставить, и то это какой-то костыль. судя по этому:
Found in versions linphone/3.5.2-8, linphone/3.5.2-10
Fixed in version linphone/3.5.2-11
начиная с 11 версии этого бага нет, но у меня в software manager только 3.5.2-10. На оф сайте есть исходники 3.6.1. Но вроде как она считается анстейбл (а может уже и нет), но компилировать это слишком жестко пока для меня - забил на это дело после очередной ошибки после ввода ./configure.
Corw1n,
Собственно "не работает" не совсем правильная формулировка, потому что его тупо не выбрать в настройках. Там где он должен быть его просто нет. Options-prefernces-network settings-media encryption type - можно выбрать только SRTP/None
здесь вот обсуждается проблема, но я не понял что советуют сделать. в какой-то там файл надо что-то прописать и что-то скачать поставить, и то это какой-то костыль. судя по этому:
Found in versions linphone/3.5.2-8, linphone/3.5.2-10
Fixed in version linphone/3.5.2-11
начиная с 11 версии этого бага нет, но у меня в software manager только 3.5.2-10. На оф сайте есть исходники 3.6.1. Но вроде как она считается анстейбл (а может уже и нет), но компилировать это слишком жестко пока для меня - забил на это дело после очередной ошибки после ввода ./configure.
Какие подвижки по этой теме? У меня тоже не выбрать ZRTP.

Оффлайн rayanAyar

  • Старожил
  • *
  • Сообщений: 1027
  • Да пребудет с вами совпавшая контрольная сумма
    • Просмотр профиля
Re: Linphone не работает ZRTP
« Ответ #5 : 13 Январь 2014, 22:15:11 »
Версия из PPA?

Оффлайн ode2

  • Активист
  • *
  • Сообщений: 268
    • Просмотр профиля
Re: Linphone не работает ZRTP
« Ответ #6 : 14 Январь 2014, 22:01:14 »
Из обычных репозитариев. Версия программы Linphone 3.5.2 Какие мысли об этой проблеме?

Оффлайн rayanAyar

  • Старожил
  • *
  • Сообщений: 1027
  • Да пребудет с вами совпавшая контрольная сумма
    • Просмотр профиля
Re: Linphone не работает ZRTP
« Ответ #7 : 15 Январь 2014, 05:24:39 »
Пробуйте из PPA

Оффлайн ode2

  • Активист
  • *
  • Сообщений: 268
    • Просмотр профиля
Re: Linphone не работает ZRTP
« Ответ #8 : 20 Январь 2014, 09:12:28 »
из ППА ставил, ставится на мою 13.10 последняя версия программы именно при установке в свойствах защиты соединения ZRTP - программа падает при снятии трубки другим абонентом. Пакет ZRTP в системе есть . Какие мысли по этой проблематике ??

Оффлайн rayanAyar

  • Старожил
  • *
  • Сообщений: 1027
  • Да пребудет с вами совпавшая контрольная сумма
    • Просмотр профиля
Re: Linphone не работает ZRTP
« Ответ #9 : 20 Январь 2014, 19:16:42 »
В официальном PPA нет версии для Saucy. В 13.10 с линфоном всё плохо - там получается конфликт библиотек. Я собрал у себя в PPA:
https://launchpad.net/~rayanayar/+archive/linphone

Но для Saucy там мегакостыль (см. предупреждение там же). Если есть желание (и нет Kopete в системе - можете попробовать).

 

Страница сгенерирована за 0.057 секунд. Запросов: 24.