Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Rhythmbox 3.0 на Ubuntu 12.04  (Прочитано 1449 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Givizub

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1415
  • Ubuntu 20.04 [KDE 5.2]
    • Просмотр профиля
Rhythmbox 3.0 на Ubuntu 12.04
« : 20 Октябрь 2013, 14:34:36 »
Пытался собрать Rhythmbox 3.0 из исходников, вот этой инструкции: http://boutnew.ru/tehnika-i-tehnologii/sobiraem-rhythmbox-3-0-iz-ishodnikov.html

Установил дополнительные пакеты, старый плеер удалил, скачал исходники. Когда делаю ./configure пишет:
Цитата:  ./configure
checking for RHYTHMBOX... no
configure: error: Package requirements (        gobject-introspection-1.0 >= 0.10.0         gtk+-3.0 >= 3.6.0                 x11                    gdk-pixbuf-2.0 >= 2.18.0     glib-2.0 >= 2.32.0              gio-2.0 >= 2.32.0        gio-unix-2.0 >= 2.32.0              libsoup-2.4 >= 2.26.0        libsoup-gnome-2.4 >= 2.26.0           libpeas-1.0 >= 0.7.3        libpeas-gtk-1.0 >= 0.7.3           libxml-2.0 >= 2.7.8        tdb >= 1.2.6                    json-glib-1.0) were not met:

Requested 'gtk+-3.0 >= 3.6.0' but version of GTK+ is 3.4.2

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables RHYTHMBOX_CFLAGS
and RHYTHMBOX_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Как я понял, нужны новые версии каких-то библиотек, а сам процесс сборки описан для 13.04 (ибо там они новые).

Возможно ли все таки установить на 12.04?
Как мне удалить дополнительные пакеты для сборки build-dep rhythmbox (они занимают 300Мб!)
R.I.P. - Unity

Оффлайн Nikki1993

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 3261
  • Owner of Dell XPS 13 Developer Edition :D
    • Просмотр профиля
Re: Rhythmbox 3.0 на Ubuntu 12.04
« Ответ #1 : 20 Октябрь 2013, 14:45:32 »
Drone93,
в Ubuntu 12.04 используется GTX 2.x в Ubuntu 13.04 > используется GTX 3.0, Rhythmbox 3.0 использует новый GTX 3.0 так что либо ставьте новую Ubuntu, либо как есть.
First i was like :0 Then i was like :D But now i am like(╯°□°)╯︵ ┻━┻
http://www.abload.de/img/banner_505uxa.png

Оффлайн Givizub

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1415
  • Ubuntu 20.04 [KDE 5.2]
    • Просмотр профиля
Re: Rhythmbox 3.0 на Ubuntu 12.04
« Ответ #2 : 20 Октябрь 2013, 15:43:02 »
Спасибо.
А как тогда пакеты удалить после команды
sudo apt-get install build-dep rhythmbox
Они мне память загадили!
R.I.P. - Unity

Оффлайн neon1ks

  • Старожил
  • *
  • Сообщений: 1183
    • Просмотр профиля
    • Блог молодого разработчика
Re: Rhythmbox 3.0 на Ubuntu 12.04
« Ответ #3 : 20 Октябрь 2013, 19:23:26 »
В ubuntu 12.04 используется GTK+ 3.4.2, а требуется для сборки GTK+ 3.6 или выше. Не один раз сталкивался с подобной ситуацией (((

Вспомнил, недавно читал, что в ubuntu 14.04 хотят оставить GTK+ 3.8, но в то время уже выйдет GTK+ 3.12 - и гадают возникнут ли проблемы с библиотекой или нет.

Как мне удалить дополнительные пакеты для сборки build-dep rhythmbox (они занимают 300Мб!)

Можно вручную) В центре приложений ubuntu - есть история установки пакетов - идешь туда, и все по очереди удаляешь - если есть желание)

Оффлайн Givizub

  • Автор темы
  • Старожил
  • *
  • Сообщений: 1415
  • Ubuntu 20.04 [KDE 5.2]
    • Просмотр профиля
Re: Rhythmbox 3.0 на Ubuntu 12.04
« Ответ #4 : 21 Октябрь 2013, 21:03:49 »
В ubuntu 12.04 используется GTK+ 3.4.2, а требуется для сборки GTK+ 3.6 или выше. Не один раз сталкивался с подобной ситуацией (((

Вспомнил, недавно читал, что в ubuntu 14.04 хотят оставить GTK+ 3.8, но в то время уже выйдет GTK+ 3.12 - и гадают возникнут ли проблемы с библиотекой или нет.

Можно вручную) В центре приложений ubuntu - есть история установки пакетов - идешь туда, и все по очереди удаляешь - если есть желание)

Спасибо. Чуть больше половины удалил. Больше терпения не хватило. :)
R.I.P. - Unity

 

Страница сгенерирована за 0.095 секунд. Запросов: 25.