Форум русскоязычного сообщества Ubuntu


Автор Тема: Lenovo E43 не запускается wi-fi  (Прочитано 5212 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MAF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Lenovo E43 не запускается wi-fi
« : 24 Октябрь 2013, 12:19:07 »
Доброго времени суток!
На Lenovo E43 под kubuntu 12.04 не работает wi-fi. Поставил проприеритарные драйвера, ноутбук увидел свой wi-fi модуль и позволяет его вкл/выкл кнопками Fn+F5 и из knetworkmanager. При этом сам модуль похоже не работает: диод не горит, точки доступа не видны. Пробовал разные драйвера - результат нулевой. По опыту работы на ноуте в винде проблема может быть в настройках энергосбережения, вот только не знаю в каких. А может просто не хватает нужного драйвера. В общем, нужна помощь...

lspci -k:
(Нажмите, чтобы показать/скрыть)

rfkill list:
(Нажмите, чтобы показать/скрыть)

iwconfig:

(Нажмите, чтобы показать/скрыть)

ifconfig:
(Нажмите, чтобы показать/скрыть)

dmesg | grep -e wl -e 802 -e eth6:

(Нажмите, чтобы показать/скрыть)

Pilot6

  • Гость
Re: Lenovo E43 не запускается wi-fi
« Ответ #1 : 24 Октябрь 2013, 12:19:50 »
MAF,
Отредактируйте пост так, чтобы можно было читать.

Оффлайн MAF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Lenovo E43 не запускается wi-fi
« Ответ #2 : 24 Октябрь 2013, 12:35:08 »
У меня все отображается корректно. Что вы имеете в виду?

Pilot6

  • Гость
Re: Lenovo E43 не запускается wi-fi
« Ответ #3 : 24 Октябрь 2013, 12:36:04 »
MAF,
Я имею ввиду, что под спойлером текст в одну строчку. Поэтому вывод посмотреть толком невозможно.

Оффлайн MAF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Lenovo E43 не запускается wi-fi
« Ответ #4 : 24 Октябрь 2013, 12:39:08 »
Странно, у меня вывод отображается правильно. Вот ссылка на архив с текстовыми файлами в которые перенаправлен вывод http://gfile.ru/a25it . Вложения на форум че-то не грузятся у меня.

Пользователь решил продолжить мысль 24 Октябрь 2013, 12:42:00:
В сообщении архив с листингом команд.

EDITED: загрузилось вложение.
« Последнее редактирование: 24 Октябрь 2013, 12:42:36 от MAF »

Pilot6

  • Гость
Re: Lenovo E43 не запускается wi-fi
« Ответ #5 : 24 Октябрь 2013, 12:44:21 »
MAF,
Понятно

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install firmware-b43-lpphy-installer
sudo modprobe b43

При этом надо быть подключенным к интернету по кабелю.
« Последнее редактирование: 24 Октябрь 2013, 12:50:44 от Pilot6 »

Оффлайн MAF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Lenovo E43 не запускается wi-fi
« Ответ #6 : 24 Октябрь 2013, 14:20:38 »
Пробовал, не помогает. Используемый драйвер b43-pci-bridge вместо wl. Вместо eth6 появился wlan1.

rfkill list при этом:

0: ideapad_wlan: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: yes



Светодиод на корпусе не горит, на кнопку реакции нет, устройство в knetworkmanager "Unavailable".

dmesg:

[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-55-generic-pae root=UUID=5bdb3b2e-c70c-475a-ae21-337f09802b1a ro quiet splash vt.handoff=7
[    1.013572] pci 0000:00:1c.5: BAR 15: assigned [mem 0x80100000-0x802fffff 64bit pref]
[    1.013731] pci 0000:00:1c.5:   bridge window [mem 0x80100000-0x802fffff 64bit pref]
[    1.013909] pci_bus 0000:07: resource 2 [mem 0x80100000-0x802fffff 64bit pref]
[    4.424491] ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x0F, vendor 0x4243)
[   30.457891] cfg80211: Calling CRDA to update world regulatory domain
[   30.463235] cfg80211: World regulatory domain updated:
[   30.463238] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   30.463241] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
.....................................
[   30.463252] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   31.992388] cfg80211: Updating information on frequency 2412 MHz for a 20 MHz width channel with regulatory rule:
[   31.992392] cfg80211: 2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
.........................
[   31.992459] cfg80211: Updating information on frequency 2484 MHz for a 20 MHz width channel with regulatory rule:
[   31.992462] cfg80211: 2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   32.115854] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   32.140726] udevd[481]: renamed network interface wlan0 to wlan1
[   32.143676] ADDRCONF(NETDEV_UP): wlan1: link is not ready
[   77.153168] ADDRCONF(NETDEV_UP): wlan1: link is not ready



Pilot6

  • Гость
Re: Lenovo E43 не запускается wi-fi
« Ответ #7 : 24 Октябрь 2013, 14:22:28 »
MAF,
sudo rfkill unblock all

Ну и поискать железную переключалку на ноуте или комбинацию типа Fn+F2 или Fn+F12.

Пользователь решил продолжить мысль 24 Октябрь 2013, 14:24:21:
ifconfig что говорит?
« Последнее редактирование: 24 Октябрь 2013, 14:24:21 от Pilot6 »

Оффлайн MAF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Lenovo E43 не запускается wi-fi
« Ответ #8 : 24 Октябрь 2013, 14:27:52 »
Я и показал rfkill list после unblock all. Некоторый phy0 аппаратно блокирован.

Включается выключается wi-fi с Fn+F5 и с помощью двухпозиционного выключателя в корпусе. На них реакции никакой. Подключил к ноуту usb-wi-fi адаптер, та же фигня, устройство видится, но unavailable. При этом разблокировано. И да, в knetworkmanager галка Enable wireless не активна.

В dmesg та же фигня wlan2: link is not ready.

Пользователь решил продолжить мысль 24 Октябрь 2013, 14:31:00:
ifconfig отображает eth5 - ethernet интерфейс и lo.
iwconfig показывает wlan1 и wlan2. Мне не нравится строчка Power Managment: off у интерфейса wlan1.
« Последнее редактирование: 24 Октябрь 2013, 14:31:00 от MAF »

Pilot6

  • Гость
Re: Lenovo E43 не запускается wi-fi
« Ответ #9 : 24 Октябрь 2013, 14:31:09 »
Не понятно почему eth5 или 6 wlan 1 или 2. Должно быть eth0 и wlan0.

Оффлайн MAF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Lenovo E43 не запускается wi-fi
« Ответ #10 : 24 Октябрь 2013, 14:36:29 »
По dmesg:
udevd[482]: renamed network interface eth0 to eth5
udevd[482]: renamed network interface wlan0 to wlan1


Зачем udevd переименовывает интерфейсы не знаю. Инкрементируется номер интерфейса после выхода из Windows, однако не всегда.

Пользователь решил продолжить мысль 24 Октябрь 2013, 14:46:05:
В rfkill. Переключатель на корпусе отвечает за hard блокировку ideapad_wlan. Fn+F5 за soft block всех устройств. Некоторый phy0 hard blocked постоянно. knetworkmanager не дает работать с беспроводными интерфейсами, хотя отображает их.

Пользователь решил продолжить мысль 24 Октябрь 2013, 16:20:02:
Загрузился с флешки в чистую kubuntu 13.04.
Поставил драйвер b43.
Появился интерфейс wlan1.
wlan1 IEEE 802.11bg ESSID:off/any
  Mode:Managed Access Point: Not-Associated  Tx-Power=off
  Retry long limit 7  Rts thr: off  Fragment thr:off
  Power Managment: off

rfkill list также показывает ideapad_wlan и phy0. phy0 всегда hard blocked.

iwconfig wlan1 txpower on выполняется без сообщений об ошибках, но в iwconfig по-прежнему отображается Tx-Power=off. Похоже не подается питание на модуль wi-fi.
« Последнее редактирование: 24 Октябрь 2013, 16:20:02 от MAF »

Оффлайн MAF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Lenovo E43 не запускается wi-fi
« Ответ #11 : 29 Октябрь 2013, 10:04:36 »
С драйвером wl, wi-fi штатно работает, но только при условии, что предварительно он был включен леновской утилиткой из-под винды. В противном случае wi-fi модуль будет всегда hard blocked: on. При этом как ни странно вместо wlan0 у меня отображается интерфейс eth6. o_0

Никто не сталкивался с подобной проблемой?

Оффлайн MAF

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Lenovo E43 не запускается wi-fi
« Ответ #12 : 07 Ноябрь 2013, 10:27:42 »
Логическое продолжение. Тот же ноут, та же ось, корректно подключается к точкам доступа с помощью knetwork-manager'a.

Хочу подключаться без GUI. Точка доступа открытая без шифрования и паролей. Делаю так:

# /etc/init.d/network-manager stop
# killall wpa_supplicant
# iwconfig <iface> essid <network> enc off key off mode managed power off
# ifconfig <iface> <ip>/24 up

В итоге iwconfig и ifconfig показывают правильные настройки интерфейса для подключения к точке, но само подключение тупо не устанавливается. При этом iwlist scan показывает точки доступа. То есть какая-то фигня имеет место быть. Все как бы работает, но ничего не работает. Что делать?

 

Страница сгенерирована за 0.072 секунд. Запросов: 25.