Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не грузится система с отформатированного диска  (Прочитано 2515 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yolven

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Доброго времени суток!
На чистый девственный диск установил ubuntu 13.10, создав установщиком нужные разделы (root, /home и swap) После перезагрузки BIOS не видит жесткого диска. Создал раздел EFI, не помогло. Пихал GRUB в разные разделы по очереди, никакого результата.
При загрузке с LiveUSB все разделы видятся и монтируются, перелопатил разные маны по восстановлению GRUB, ничего не помогает.
В чём тут может быть проблема (кроме хромосом :))?
Ноут Asus X401A.
PS: Винда семерка устанавливается и ставится нормально.

Оффлайн Shalmaran

  • Активист
  • *
  • Сообщений: 840
  • Cow super power!
    • Просмотр профиля
    • kristyushatmb.livejournal.com
Ох... Что за режим загрузки на этом ASUS? UEFI или Legacy BIOS (просто BIOS)?
Banana Pi

Оффлайн Shalmaran

  • Активист
  • *
  • Сообщений: 840
  • Cow super power!
    • Просмотр профиля
    • kristyushatmb.livejournal.com
Тогда надо грамотно разбивать диск, загружаться при установке с UEFI CD-ROM или UEFI FLASH (не Legacy!), ну и после установки выбрать правильный раздел с загрузочным скриптом. Ну и загрузчик естественно grub-efi

Диск по правилам должен быть размечен в GPT.
Разделы:

/boot/efi/ - FAT32 (обязательно 32), инсталятор ubuntu выделяет 200 МиБ (нафиг так много - не ясно, но меньше - вообще не получится им установить)
Banana Pi

Оффлайн Yolven

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
В том то и дело, что bios не видит загрузчика. В efi-разделе есть папка EFI. В ней три папки: Boot, linuxmint и windows. Биос видит видит только загрузчик винды.
Загрузчик grub-efi, прописан в efi-разделе, на котором стоит флаг boot. Переустанавливать grub пробовал, не помогло. А вот переключиться с UEFI на legacy на Асусе нельзя..
Что ещё можно сделать в этой ситуации?

Оффлайн Fantiney

  • Участник
  • *
  • Сообщений: 137
    • Просмотр профиля
В том то и дело, что bios не видит загрузчика. В efi-разделе есть папка EFI. В ней три папки: Boot, linuxmint и windows. Биос видит видит только загрузчик винды.
Загрузчик grub-efi, прописан в efi-разделе, на котором стоит флаг boot. Переустанавливать grub пробовал, не помогло. А вот переключиться с UEFI на legacy на Асусе нельзя..
Что ещё можно сделать в этой ситуации?
А Вы уверены, что установлен именно grub-efi? Попробуйте заново, в автоматическом режиме разметить диск.
Возможно также, нужные ответы найдёте в этой теме.

Оффлайн Yolven

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
А Вы уверены, что установлен именно grub-efi? Попробуйте заново, в автоматическом режиме разметить диск.
Возможно также, нужные ответы найдёте в этой теме.
Да, grub-efi. Ставится по-умолчанию, но я его на всякий случай переустанавливал, не помогает.

Оффлайн dj--alex

  • Старожил
  • *
  • Сообщений: 3224
  • Понимаешь, я какбы беру в руки лопату и говорю...
    • Просмотр профиля
    • все мои творения и занятия
в Legacy режиме пока microsoft его еще не убрала со всех компьютеров
можно линукс без проблем поставить
Ubuntu 16.04.1 MATE x64, 18.1 x64 Mate, MX-Linux 16 Mate Mate Mate Mate. PC:?\FX4100@4ghz\8Gb\2TB HDD\1060gtx\90GB Ocz
https://forum.ubuntu.ru/index.php?topic=199897.0

Оффлайн andrew_21_12

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
друзья, у меня похоже аналогичная проблема - тоже не знаю, как решить. суть:

1) изначально было два раздела: с Win7 и файлами

2) подготовил разделы для Ubuntu по мануалу: https://help.ubuntu.ru/manual/%D1%80%D0%B0%D0%B7%D0%BC%D0%B5%D1%82%D0%BA%D0%B0_%D0%B4%D0%B8%D1%81%D0%BA%D0%B0

3) при установке Ubuntu установщик стал ругаться, что не определён корневой раздел. присвоил подготовленному root-разделу "/" - установка прошла успешно

4) перезагружаю ноутбук - запускается Win7, выбора ОС нет

5) гружусь с CD Ubuntu, ставлю в GParted флаг "boot" на root-раздел Ubuntu, перезагружаюсь - ноутбук отказывается запускаться с харда

6) возвращаю "boot" на Win7 - нормально запускается Win7

как сделать выбор ОС при старте системы? как вообще запустить установленную на жёсткий диск Ubuntu?
скриншоты после установки:




Оффлайн andrew_21_12

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
andrew_21_12,
https://help.ubuntu.ru/wiki/%D0%B2%D0%BE%D1%81%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_grub

спасибо, попробую вечером)

Пользователь решил продолжить мысль 12 Ноябрь 2013, 17:04:14:
Pilot6,
всё получилось, спасибо тебе огромное)
« Последнее редактирование: 12 Ноябрь 2013, 17:04:14 от andrew_21_12 »

Оффлайн Yolven

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Ничего не понимаю. Виндовский загрузчик видит, а Ubuntu - нет, хоть убей. Прям мистика какая-то...

 

Страница сгенерирована за 0.092 секунд. Запросов: 25.