Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Grub - нет автозагрузки  (Прочитано 1718 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vboxer

  • Автор темы
  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Grub - нет автозагрузки
« : 02 Ноябрь 2013, 19:44:22 »
Уезжая из деревни оставляю комп онлайн для доступа, настроен БИОС на случай выключения света, автовходы, автозапуски, а недавно произошла подстава. Свет выключали и комп не вернулся в сеть. Приехал домой и обнаружил, что загрузка кончается на выборе системе в "гробу". То есть если жмакнуть ентер, то загрузка идет дальше и все в порядке. Отредактировал гроб по мануалу сделал апдейт гроб - ноль эмоций. Таймер отсчета не отображается, выбор стоит как надо на первом пункте и тупо ждет ентера. Куда копать этот гроб?

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Grub - нет автозагрузки
« Ответ #1 : 02 Ноябрь 2013, 19:50:39 »
vboxer,
grep -Ev '^#|^$' /etc/default/grub?

Оффлайн vboxer

  • Автор темы
  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Grub - нет автозагрузки
« Ответ #2 : 02 Ноябрь 2013, 19:51:43 »
GRUB_DEFAULT="saved"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_SAVEDEFAULT="true"
как то так, как и было в рабочем виде.

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Grub - нет автозагрузки
« Ответ #3 : 02 Ноябрь 2013, 19:53:53 »
sudo grep -Ev '^#|^$' /boot/grub/grub.cfgПод спойлер.

Оффлайн vboxer

  • Автор темы
  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Grub - нет автозагрузки
« Ответ #4 : 02 Ноябрь 2013, 20:07:15 »
ну такую то портянку естественно :)
(Нажмите, чтобы показать/скрыть)

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Grub - нет автозагрузки
« Ответ #5 : 02 Ноябрь 2013, 20:25:57 »
sudo sed -i 's/^GRUB_DEFAULT=.*$/GRUB_DEFAULT="0"/g' /etc/default/grub
sudo update-grub

Оффлайн vboxer

  • Автор темы
  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Grub - нет автозагрузки
« Ответ #6 : 02 Ноябрь 2013, 20:34:15 »
Осталось все так же. таймера нет, старта нет.

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Grub - нет автозагрузки
« Ответ #7 : 02 Ноябрь 2013, 20:35:26 »
cat /boot/grub/grubenv?

Оффлайн vboxer

  • Автор темы
  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Grub - нет автозагрузки
« Ответ #8 : 02 Ноябрь 2013, 20:37:36 »
что то жутко непонятно:
(Нажмите, чтобы показать/скрыть)

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Grub - нет автозагрузки
« Ответ #9 : 02 Ноябрь 2013, 20:39:01 »
sudo sed -i 's/recordfail=1/#recordfail=1/g' /boot/grub/grubenv

Оффлайн vboxer

  • Автор темы
  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Grub - нет автозагрузки
« Ответ #10 : 02 Ноябрь 2013, 22:13:19 »
Сработало 1 раз, после второго ребута опять ждет ентера.

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15189
    • Просмотр профиля
    • aetera.net
Re: Grub - нет автозагрузки
« Ответ #11 : 02 Ноябрь 2013, 22:30:28 »
grep -Ev '^#|^$' /boot/grub/grubenv?

Оффлайн vboxer

  • Автор темы
  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Grub - нет автозагрузки
« Ответ #12 : 02 Ноябрь 2013, 23:46:20 »
saved_entry=gnulinux-simple-99dfc707-4541-496a-8176-e580af179c99
recordfail=1

Оффлайн Spect

  • Старожил
  • *
  • Сообщений: 1173
    • Просмотр профиля
Re: Grub - нет автозагрузки
« Ответ #13 : 03 Ноябрь 2013, 00:34:10 »
Попробую дать тупой совет..  boot_repair
Ubuntu 16.04 LTS [x86-64]/i3-2100T/2*4G/1T HDD/Intel HD 2000
Hatsan Escort Aimguard Combo 12/76, 7+1

Оффлайн vboxer

  • Автор темы
  • Активист
  • *
  • Сообщений: 656
  • Release: 14.10 Codename: utopic
    • Просмотр профиля
Re: Grub - нет автозагрузки
« Ответ #14 : 03 Ноябрь 2013, 09:35:30 »
Попробую дать тупой совет..  boot_repair
Оказался совсем не тупой совет. Загрузка восстановилась, понять бы что за... это было :(

 

Страница сгенерирована за 0.161 секунд. Запросов: 25.