Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: ATI+ATI ксоргконфиг криво генерит? 13.04  (Прочитано 759 раз)

0 Пользователей и 1 Гость просматривают эту тему.

ElectroPeople

  • Автор темы
  • Гость
Проблема в следующем - 2 ноута, НР и Айсер, решил всё кардинально переставить.
Вобщем бьюсь второй день. с ноутами и бунтой.
До этого ж ВСЁ ОТЛИЧНО РАБОТАЛО!
Началось с Айсера, после установки проприетарных дров, после переключения на дискретку, ноут начал тупить и зависать при загрузке, тут однозначно причина в драйверах где то.
Ладно, это поборол хз какими очень неправильными методами.
Ноут стал при том ещё очень глючить после переключения в БИОС на только встроенное видео ( в ККЦ - уже стояло интегрированное), после переключения в БИОС - дрова совсем начинают глючить - это сразу даже по поведению плазмы видно.
Вобщем мучался-мучался, переставился с десяток раз - на Айсер чудом вроде норм работает, правда, апосле установки кучи софта и ребута - плазма с дровами опять поплыли. Повторный ребут - вроде ОК стало.
Но чуствую - дело хреновое, в самый неподходящий момент пойдут глюки, надо причину искать.
На НР - никак!
Ставлю ОС, дрова, sudo aticonfig --initial -f - вроде норма.
Переключаюсь на дискретку и приехали - ноут то виснет при загрузки, и кривеют дрова напрочь.
То ли ксорг конфиг внезапно стал криво генериться, я глянул на НР - там вообще почему то по несколко секций, типа Монитор 1, Девайс 1, 0 и т.д.
Как будто у меня несколько моников.  :-[
Я заманался уже, у меня на обоих нотиках драйвера только отсюда стоят sudo apt-add-repository ppa:xorg-edgers/ppa только они отлично работают и без проблем.
Я на НР уже все возможные перепробовал драйвера, и Убунтовые и сам кучу пересобирал и везде одно и то же стало.
Сплошной глюкодром.
Вобщем на Айсере ж каким то чудом он хоть боле менее норм сгенерился, я уже просто, взял и зашвырнул его на НР, я не знаю как ещё решить проще.
Ребутнулся и на интеграшке стало вроде норм.
/etc/X11/xorg.conf
(Нажмите, чтобы показать/скрыть)

~$ aticonfig --lsa
* 0. 00:01.0 AMD Radeon HD 7640G
  1. 01:00.0 AMD Radeon HD 7600M Series
На Айсере такие же почти видяхи, только чуть поновее.

Вобщем странно как то очень это всё, у меня как бы, ведь системы отлично работали до переустановки.
Пакетная база в принципе - особо не меняется очень. (лок. репо из кеша).
Ранее когда то с этой же пакетной базой и ставился и переставлялся и никогда не было проблем.
И тут на ровном месте.
Дело однозначно стало в драйверах, а вот как этот момент поправить и найти истинного виновника? (что там внезапно с дровами которые всё время на ура работали - стало не так?)

ElectroPeople

  • Автор темы
  • Гость
Re: ATI+ATI ксоргконфиг криво генерит? 13.04
« Ответ #1 : 07 Ноябрь 2013, 13:54:00 »
Вобщем странно как то всё. Проблема да, именно в драйверах на видио и репозитории ppa:xorg-edgers/ppaПроблема то решена , однако суть так и не выяснена.
Может кто выскажет пусть даже самое бредовое предположение, интересно до истины докопаться.
Мне непоняте тот момент, что с этим репо, системы очень долгое время работали отлично и при попытке переустановки - пошла сплошная кривизна.
Как это обьяснить, стоит система - работает отлично, переустанавливаю с нуля, полностью анаогичная пакетная база, дрова и всё остальное и уже никак, всё в кривь и вкось.

Оффлайн Gisburne

  • Новичок
  • *
  • Сообщений: 7
  • Use The Force
    • Просмотр профиля
Re: ATI+ATI ксоргконфиг криво генерит? 13.04
« Ответ #2 : 14 Ноябрь 2013, 11:54:03 »
Аналогичная проблема с теми-же дровами и тем-же репо. Копаюсь, но пока безрезультатно.
Кстати, как решил проблему?
Jedem Das Seine!

ElectroPeople

  • Автор темы
  • Гость
Re: ATI+ATI ксоргконфиг криво генерит? 13.04
« Ответ #3 : 19 Ноябрь 2013, 04:18:18 »
Цитировать
как решил проблему?
Методом проб и ошибок бесконечных переустановок и вылавливании виновника , "тыка" короче )).Да просто решил. Суть правда проблемы так до конца полностью и не ясна... но факт остаётся фактом = кривые дрова - раз, плюс - кривущий репо - два....
Я причём какой то закономерности в нормальной, либо кривой работе так и не заметил и не выцепил окончательно.То есть, можно например удачно и с этим кривым репо и накатить систему , и обновить и софтом натыкать и будет она ровненько абсолютно и без лагов работать. Как и было у меня ранее.
А может и такя хрень как щас пойти - та же пакетная база, всё одно и то же, а в результате - лбом об стену. Хоть 100500 раз подряд переставляйся. Ток накатишь дрова и пошло поехало....\
Я как вариант, пошёл чуть иначе, как борол глюк - отказ от этого самого глючного репо - раз.
Во вторых, там же драйвер, в репо, по сути amd-catalyst-13.10-beta2-linux-x86.x86_64 - собрать самому.
Это на Айсере, так как там видеокарты довольно таки новые и всё нормально работает только с этим бета-драйвером.
Собственно почему и начал юзать этот репо.
Как вариант, сначала обновить установленную систему, потом ставить видеодрайвер. В ходе "разбора полётов" - почему то так, возникает намного меньше шансов поймать всевозможные лаги и глюки.

Ну и на НР с ~$ aticonfig --lsa* 0. 00:01.0 AMD Radeon HD 7640G  1. 01:00.0 AMD Radeon HD 7600M Series как бы позволяет пользовать стабильный 13.4 без особых  проблем. Меня в нём просто вымораживает кривой сплешскрин при выключении.
Аналогично - вынос репо, и сбор и установка стабильного - вроде норм.
А с вышеозвученной бетой, тут даже с собранной самому - как повезёт опять таки.
Но опять же, более положительный и менее глючный результат - установка дров после полного обновления системы.

Беда в общем с этими АМД драйверами как всегда.
В Kubuntu 13.10 - то же ни на йоту не лучше, как бы не наоборот. (.
« Последнее редактирование: 19 Ноябрь 2013, 04:43:41 от acidpeople »

Оффлайн Gisburne

  • Новичок
  • *
  • Сообщений: 7
  • Use The Force
    • Просмотр профиля
Re: ATI+ATI ксоргконфиг криво генерит? 13.04
« Ответ #4 : 19 Ноябрь 2013, 12:09:08 »
ОК! Спасибо за информацию. Думал в этом же направлении.

Да, в Kubuntu 13.10 с этим хуже  ;D именно под ней и сижу.
Jedem Das Seine!

ElectroPeople

  • Автор темы
  • Гость
Re: ATI+ATI ксоргконфиг криво генерит? 13.04
« Ответ #5 : 20 Ноябрь 2013, 06:53:09 »
Я никогда например не использую видеодрайвера те что предлагаются в Убунте из каропки.
Только или собранные лично с сайта АТИ - и это как правило всегда, либо репо с ЛП - крайне редко, скорее как уже какой то безвыходный вариант, но, могут пойти такие вот незадачи с репами....
А вот в Кубунте 13.10, сколько я её ещё с беты ни ковырял - прищлось пользовать именно те видеодрайвера что предлагаются в Убунте.
У меня только с ними было относительно, боле-менее всё благополучно. И как то всё, вроде хоть как то работало и яркость регулировалась... Она на НР стояла с вышеозвученными видеокартами.
Правда, с АТИ сайта у меня один только этот amd-catalyst-13.10-beta2-linux-x86.x86_64 видеодрайвер работал, но, с ним, если пронесут все глюки после его установки, то с яркостью - засада. Она выставляется автоматом на чуть больше средней примерно и никакими плясками мне не удалось её изменить.
Потому и сидел на Убунтовском видеодрайвере на 13.10.
Пока не принял наконец решение к откату, не выпилил её и не вернул наконец безглючную и норм. работающую 13.04 на ноут.
В 13.10 же по сути всё то же что и в 13.04, за одним исключением, что и КДЕ и всё остальное в 13.10 - насквозь глючное, в отличие от 13.04 - где и КДЕ и всё остальное на ура работает.
Вобщем забыл я давно о Kubuntu 13.10, чего и вам желаю, и, если уж ковыряться - то с 13.04. А то кажется мне что будете вы ковырять Kubuntu 13.10 как раз вплоть до следующего релиза.

Оффлайн Gisburne

  • Новичок
  • *
  • Сообщений: 7
  • Use The Force
    • Просмотр профиля
Re: ATI+ATI ксоргконфиг криво генерит? 13.04
« Ответ #6 : 21 Ноябрь 2013, 11:58:57 »
ОК! Думаю в эти выходные откачусь до 13.04 - 13.10 реально задрала нестабильностью.
Jedem Das Seine!

 

Страница сгенерирована за 0.237 секунд. Запросов: 25.