Форум русскоязычного сообщества Ubuntu


Автор Тема: Немогу поставить Eclipse 3.3 на Ubuntu 7.10.....  (Прочитано 1948 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kurtis

  • Автор темы
  • Новичок
  • *
  • Сообщений: 32
    • Просмотр профиля
Совсем замучился я с этим Эклипсом...
Из репозитория вытянул версию 3.2, потом попытался поставить через обновление плагин avr-eclipse, он ругается что у меня не стоит CDT версии 4, ставлю CDT версии 4, начинает ругаться 
Цитировать
Eclipse C/C++ Development Tools (4.0.3.200802251018) requires plug-in "org.eclipse.core.filesystem (1.1.0)", or compatible.
пытаюсь сделать общий апдейт, оно сначало долго тянет пакеты, потом начинает ругатся
Цитировать
Eclipse RCP Patch 1 for 3.3.1 (3.3.1.v20071002_331) requires feature "org.eclipse.rcp (3.3.1.R33x_r20070802-8y8eE8sEV3Fz0z0GlHJrXvTAUS)".
Я убираю пункты на который оно ругается, в итоге оно начинает скачивать пакеты, но при установке выдает кучу ошибок
Цитировать
Unable to complete action for feature "Eclipse Platform" due to errors.
  Unable to complete action for feature "Eclipse RCP" due to errors.
    Unable to create file "/usr/lib/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar1205625192707.tmp". [/usr/lib/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar1205625192707.tmp (Permission denied)]
    Unable to create file "/usr/lib/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar1205625192707.tmp". [/usr/lib/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar1205625192707.tmp (Permission denied)]
  Unable to complete action for feature "Eclipse RCP" due to errors.
    Unable to create file "/usr/lib/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar1205625192707.tmp". [/usr/lib/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar1205625192707.tmp (Permission denied)]
    Unable to create file "/usr/lib/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar1205625192707.tmp". [/usr/lib/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar1205625192707.tmp (Permission denied)]
  Unable to create file "/usr/lib/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar1205625192707.tmp". [/usr/lib/eclipse/plugins/com.ibm.icu_3.6.1.v20070906.jar1205625192707.tmp (Permission denied)]

что делать, непонятно....

Оффлайн Yurror

  • Старожил
  • *
  • Сообщений: 1966
    • Просмотр профиля
Re: Немогу поставить Eclipse 3.3 на Ubuntu 7.10.....
« Ответ #1 : 16 Март 2008, 08:07:53 »
Ы... (Permission denied) открой словарик и переведи.
а потом воспользуйся sudo

Оффлайн Alexey-S

  • Активист
  • *
  • Сообщений: 263
    • Просмотр профиля
Re: Немогу поставить Eclipse 3.3 на Ubuntu 7.10.....
« Ответ #2 : 16 Март 2008, 22:39:50 »
Сначала надо разобраться, что хочется поставить.
"Из репозитария вытянул 3.2" - у тебя Eclipse 3.2
Теперь тянешь Eclipse C/C++ Development Tools 4.0.3
Он ругается, что нужен Eclipse 3.3.

Самый простой выход из этой ситуации - зайти на сайт www.eclipse.org и скачать полную среду разработки для C/C++.
Это один из тяжелых вариантов по скачиванию из интернента, зато работоспособный.

Оффлайн Yurror

  • Старожил
  • *
  • Сообщений: 1966
    • Просмотр профиля
Re: Немогу поставить Eclipse 3.3 на Ubuntu 7.10.....
« Ответ #3 : 17 Март 2008, 05:50:14 »
Упаси боже с сайта эклипса тянуть. пусть ставит из репозитария. И нефиг обновляться встроенными средствами эклипса. Или же перед обновлениями надо запускать эклипс с рутовыми правами.

Оффлайн zeleniy

  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Re: Немогу поставить Eclipse 3.3 на Ubuntu 7.10.....
« Ответ #4 : 24 Июль 2008, 10:53:07 »
А не подскажите, как это тянуть из репозитория... и средствами eclipse это делается или нет ? Если нет, то ведь наверное об автоматическом обновлении можно забыть, да ?

Оффлайн Holy Cheater

  • Любитель
  • *
  • Сообщений: 52
  • His Holiness
    • Просмотр профиля
Re: Немогу поставить Eclipse 3.3 на Ubuntu 7.10.....
« Ответ #5 : 24 Июль 2008, 11:43:12 »
Я так и не понял, каким образом eclipse обновить через их встроенную апдейтилку. Не стал париться, скачал с eclipse.org собранный eclipse cdt 3.4, и пользуюсь себе спокойно :)

 

Страница сгенерирована за 0.053 секунд. Запросов: 24.