Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Перестал работать Wi-Fi на Ubuntu 12.04 LTS (Dell Inspiron 3521-8249)  (Прочитано 10984 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ubuntu17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Был куплен новый ноутбук Dell Inspiron 3521-8249. Первые дни Wi-Fi работал нормально, но после установки всех обновлений ноутбук перестал видеть все беспроводные сети, причем появлялось сообщение "Текущая сеть имеет локальный домен (.local), который не рекомендуется и не совместим с сервисом поиска сетевых ресурсов Avahi. Служба была отключена.". Пробовал отключать Avahi, убирал из файла /etc/nsswitch.conf запись [NOTFOUND=return] и устанавливал AVAHI_DAEMON_DETECT_LOCAL=0, но ничего не помогло. В данный момент даже ошибка не выводится. Беспроводных сетей по-прежнему не видно. Как включить Wi-Fi?
Сетевой адаптер qualcomm Atheros QCA9565 AR9565 Wireless Network. Может к нему нужно установить драйвера? Только где их взять?
Сейчас rfkill выдает:
0: dell-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: yes
1: dell-bluetooth: Bluetooth
Soft blocked: yes
Hard blocked: yes
Может надо изменить на "no"? Но как это сделать? Вчера было везде "no", но Wi-Fi так же не работал.
« Последнее редактирование: 09 Ноябрь 2013, 14:19:12 от Ubuntu17 »

Pilot6

  • Гость
Ubuntu17,
Avahi отношения никакого не имеет к проблеме.

Попробуйте

sudo rfkill unblock all

Ну и дайте вывод посмотреть

lspci -knn | egrep 'Eth|Net' -A2

Оффлайн Ubuntu17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
После "sudo rfkill unblock all" ничего не разблокировалось. Вездe по-прежнему yes.

~$ lspci -knn | egrep 'Eth|Net' -A2
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
   Subsystem: Dell Device [1028:0597]
   Kernel driver in use: r8169
--
02:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)
   Subsystem: Dell Device [1028:020c]

Pilot6

  • Гость
Ubuntu17,
А что говорит

sudo modprobe ath9k
uname -a

Похоже в последнем ядре что-то с драйвером поломали. У меня тоже проблемы начались. Не такие радикальные, но все же. Загрузитесь с предыдущим ядром, а это удалите. Придет фикс со временем.

Оффлайн Ubuntu17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Pilot6,
Ввожу "sudo modprobe ath9k" Ничего не происходит. Ввожу "uname -a" и выдает вот что:
Linux Inspiron-3521 3.2.0-56-generic #86-Ubuntu SMP Wed Oct 23 09:20:45 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Только как "загрузиться с предыдущим ядром"? Я в Linux новичок совсем.

Pilot6

  • Гость
Ubuntu17,
Или наоборот поставьте более свежее ядро.

sudo apt-get install linux-generic-lts-raring linux-headers-generic-lts-raring

и перезагрузитесь.

Оффлайн Ubuntu17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Pilot6,
Вот что получилось после попытки поставить более свежее ядро:
E: Не удалось получить доступ к файлу блокировки /var/lib/dpkg/lock - open (11: Ресурс временно недоступен)
E: Не удалось выполнить блокировку управляющего каталога (/var/lib/dpkg/); он уже используется другим процессом?

Да и еще забыл сказать, что после вчерашних обновлений был установлен проприетарный драйвер кюалкомм, который я решил удалить в надежде, что Wi-Fi заработает, но не заработал. Сейчас этого драйвера нет в списке. Может его вернуть, но как?
« Последнее редактирование: 09 Ноябрь 2013, 15:06:18 от Ubuntu17 »

Pilot6

  • Гость
Ubuntu17,
У вас не ставится, так как в запущен synaptic или в этот момент что-то еще устанавливается.
Закройте все и снова выполните команду. Если не можете разобраться, то перезагрузитесь, а потом запустите снова.
Поставьте новое ядро. Если проблема останется, то посмотрим.

Оффлайн Ubuntu17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Pilot6,
После обновления ядра Wi-Fi по-прежнему не работает, но какие-то сдвиги есть. Появилась надпись "Беспроводные сети Поддержка отключена аппаратно". Снова появляется ошибка Avahi "Текущая сеть имеет локальный домен (.local), который..."

Теперь sudo rfkill list выдает вот что:
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: yes

Еще после обновления пропал Bluetooth куда-то. Но это мелочи. Главное работу Wi-Fi восстановить.
« Последнее редактирование: 09 Ноябрь 2013, 16:46:27 от Ubuntu17 »

Pilot6

  • Гость
Ubuntu17,
Про avahi забудьте. Вы наверное на Билайне. Это у всех так. Это сообщение ничего не значит.
А кнопка не отключена или в биосе?

Дайте вывод теперь

lspci -knn | grep Net -A2

Оффлайн Ubuntu17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Pilot6,
Нет, не на Билайне. На Yota. Кнопки на корпусе нет. В биосе пока не знаю как проверить.

Вывод lspci -knn | grep Net -A2 такой:
02:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)
   Subsystem: Dell Device [1028:020c]
   Kernel driver in use: ath9k

Pilot6

  • Гость
Во всяком случае драйвер теперь стоит. И раз он про .local соображает, то значит и к сети подключился.

Оффлайн Ubuntu17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
При нажатии комбинации клавиш Fn+F2 список беспроводных сетей появляется на несколько секунд, затем исчезает. При этом rfkill теперь показывает вот что:
0: phy0: Wireless LAN
   Soft blocked: yes
   Hard blocked: no
4: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no

Проблема решена! Спасибо Pilot6 за советы. Оказывается для того чтобы включились беспроводные сети нужно было еще вытащить адаптер Yota из USB порта.
« Последнее редактирование: 09 Ноябрь 2013, 22:37:32 от Ubuntu17 »

Оффлайн Genixoid

  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Ubuntu17,
Или наоборот поставьте более свежее ядро.

sudo apt-get install linux-generic-lts-raring linux-headers-generic-lts-raring

и перезагрузитесь.

WiFi в результате даже завелся, а вот 3G модем по прежнему не хочет определяться (до обновления на стоковой версии ubuntu от dell все работало). Принял решение переустановить 13.04 с нуля

Оффлайн skrainskiy

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Pilot6,
спасибо,
 мне эта тема помогла разобраться в аналогичной проблеме с новеньким ноутом Dell.
Автору темы тоже спасибо за грамотные вопросы и коменты.
 :)

 

Страница сгенерирована за 0.066 секунд. Запросов: 24.