Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Произошла ошибка при обновлении пакетов...  (Прочитано 1867 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ezdrael

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Собственно при обновлении пакетов произошла ошибка.

"Произошла ошибка, пожалуйста, загрузите менеджер пакетов с меню или выполните команду app-get в терминале, чтобы увидеть причину ошибки.
Сообщение об ошибке: "Неизвестная ошибка:'<type' exceptions.SystemError'>'(E:The packege mywm needs to bee reinstalled, but cant find an archive for it.). Обычно подразумевается, что установке пакеты имеют неудовлетворении зависимости"

Вот и все описание проблемы. : (
« Последнее редактирование: 12 Ноябрь 2013, 00:53:09 от Ezdrael »

Оффлайн Haron Prime

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 11317
  • Нетолерантный социопат
    • Просмотр профиля
Re: Сталася помилка при завантаженні...
« Ответ #1 : 12 Ноябрь 2013, 00:31:32 »
Цитировать
Правила форума
1. Основные положения

1.1.
На форуме допускается публикация сообщений только на русском языке.
sudo ls -a | grep brain > /dev/head

Оффлайн san-alex

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 7732
  • Ex-CNC programmer
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #2 : 12 Ноябрь 2013, 02:01:38 »
Ну, так выполни команду
sudo apt-get install -fв терминале и запость вывод сюда.

Оффлайн Ezdrael

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #3 : 12 Ноябрь 2013, 17:14:52 »
sudo apt-get install -f выдало следующую ошибку

"Пакет mywm должен быть переустановлен, но я не могу найти его архив"
« Последнее редактирование: 12 Ноябрь 2013, 17:16:26 от Ezdrael »

Оффлайн eugenez

  • Старожил
  • *
  • Сообщений: 1355
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #4 : 12 Ноябрь 2013, 17:50:08 »
удалить mywm и продолжить sudo apt-get install -f
Arch+KDE | Manjaro+Cinnamon | Debian+cli | Kubuntu | Endian | OPNSense | Proxmox VE

Оффлайн Ezdrael

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #5 : 12 Ноябрь 2013, 18:00:53 »
Проблема в том что не могу удалить. А как через терминал удалить?

Оффлайн eugenez

  • Старожил
  • *
  • Сообщений: 1355
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #6 : 12 Ноябрь 2013, 18:04:11 »
sudo dpkg --purge имяпакета
Arch+KDE | Manjaro+Cinnamon | Debian+cli | Kubuntu | Endian | OPNSense | Proxmox VE

Оффлайн Ezdrael

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #7 : 12 Ноябрь 2013, 18:06:31 »
max@Ambros:~$ sudo dpkg --purge virtualbox
[sudo] password for max:
dpkg: dependency problems prevent removal of virtualbox:
 virtualbox-qt depends on virtualbox (= 4.2.10-dfsg-0ubuntu2.1).
 virtualbox-dkms depends on virtualbox (>= 4.2.10-dfsg-0ubuntu2.1).

dpkg: error processing virtualbox (--purge):
 dependency problems - not removing
Errors were encountered while processing:
 virtualbox
max@Ambros:~$ sudo dpkg --purge virtual box
dpkg: попередження: ignoring request to remove virtual which isn't installed
dpkg: попередження: ignoring request to remove box which isn't installed
max@Ambros:~$

Оффлайн eugenez

  • Старожил
  • *
  • Сообщений: 1355
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #8 : 12 Ноябрь 2013, 18:11:19 »
значит мягкий вариант: sudo apt-get remove имяпакета, должны подтянуться зависимости.
Arch+KDE | Manjaro+Cinnamon | Debian+cli | Kubuntu | Endian | OPNSense | Proxmox VE

Оффлайн Ezdrael

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #9 : 12 Ноябрь 2013, 18:16:13 »
max@Ambros:~$ sudo apt-get remove .VirtualBox
[sudo] password for max:
Зчитування переліків пакунків... Виконано
Побудова дерева залежностей                       
Зчитування інформації про стан... Виконано
E: Пакунок mywm повинен бути перевстановленим, але я не можу знайти його архів.
max@Ambros:~$

Пользователь решил продолжить мысль 12 Ноябрь 2013, 18:20:25:
Понимаете я хочу обновится а у меня ошибка какаято стоит. Немогу обновления закачать. И ищо разшерение екрана само поменялось(
« Последнее редактирование: 12 Ноябрь 2013, 18:20:25 от Ezdrael »

Оффлайн eugenez

  • Старожил
  • *
  • Сообщений: 1355
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #10 : 12 Ноябрь 2013, 18:59:24 »
Ну так вы уберите пакет, мешающий обновлению, обновитесь, и уже потом восстановите этот пакет.

Как-то перестал понимать, виртуалбокс вам мешает или mywm.
Arch+KDE | Manjaro+Cinnamon | Debian+cli | Kubuntu | Endian | OPNSense | Proxmox VE

Оффлайн san-alex

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 7732
  • Ex-CNC programmer
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #11 : 12 Ноябрь 2013, 21:23:08 »
sudo dpkg --configure -aчто говорит?
И таки да, ты определись, какой пакет ты удалить хочешь.

Оффлайн Ezdrael

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #12 : 12 Ноябрь 2013, 22:48:55 »
sudo dpkg --configure -aчто говорит?
И таки да, ты определись, какой пакет ты удалить хочешь.
Ничего не пишет.

Ну так вы уберите пакет, мешающий обновлению, обновитесь, и уже потом восстановите этот пакет.

Как-то перестал понимать, виртуалбокс вам мешает или mywm.
В ошибке пишет что mywm.

Пользователь решил продолжить мысль 12 Ноябрь 2013, 23:02:15:
Пробувал удалить mywm. Вот что написало.max@Ambros:~$ sudo apt-get remove mywm
[sudo] password for max:
Зчитування переліків пакунків... Виконано
Побудова дерева залежностей                       
Зчитування інформації про стан... Виконано
E: Пакунок mywm повинен бути перевстановленим, але я не можу знайти його архів.
max@Ambros:~$
« Последнее редактирование: 12 Ноябрь 2013, 23:02:15 от Ezdrael »

Оффлайн san-alex

  • Заслуженный пользователь
  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 7732
  • Ex-CNC programmer
    • Просмотр профиля
Re: Произошла ошибка при обновлении пакетов...
« Ответ #13 : 12 Ноябрь 2013, 23:09:34 »
Тогда
sudo gedit /var/lib/dpkg/statusи удаляешь из файла блок связанный с mywm. Только сделай бэкап файла предварительно, и осторожно там...
после этого обновляешься.

 

Страница сгенерирована за 0.103 секунд. Запросов: 25.