Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: В локалке почти не работает http наружу. Йота-роутер Gemtek  (Прочитано 1672 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexis_spb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Братцы, помогайте, пожалуйста. Беда такая.

Имеем:

Есть офис с небольшой локальной сетью. 5 рабочих станций на Ubuntu 10.04 и 12.04 и один сервер на 12.04, на котором крутятся 2 виртуалки - одна кеширующий сервер обновлений убунты, другая - Redmine.
В интернет выходим через йотовский роутер Gemtek V01. На роутере включен DHCP, он выдаёт по мак-адресам фиксированные ip серверу и витруалкам. Настроен проброс портов снаружи.

Проблема:

На всех компах сеть есть, пинги и внутрь и наружу проходят, внутренние веб-ресурсы работают всегда без проблем. А вот наружу через http нормально могут работать 1-2 машины, причём не одни и те же, а когда как. На "рабочих" машинах всё норм, а на "нерабочих"  если набрать любой адрес сайта в любом браузере просто ничего не загружается, либо очень медленно и изредка прорывается, при этом чаще всего работают сайты через https и через vpn.

С такой конфигурацией сети работает с весны - всё было всегда нормально. Проблема возникла совершенно внезапно. Никаких настроек не меняли, нового софта не устанавливали. Вообще ничего не делали подозрительного.

Проблема возникла больше недели назад. Решили, что заглючил роутер. Взяли новый роутер, накатали те же настройи, всё нормализовалось. Все обрадовались, но рано...
После 3-х дней нормального полёта история повторилась. Причём началось всё так же внезапно.

Какие действия производили:

Подтыкали непосредственно к роутеру по две Ubuntu-машины, чтобы исключить глюки свичей и т.п. и каждый раз одна работала, а другая - нет. Нашлась на одном винда как вторая система - включили её и обнаружили, что она работает всегда в любых комбинациях.
Переговоры с поддержкой йоты и попытки выяснить всё ли у них в порядке ни к чему не привели, клянутся и божатся, что у них всё нормально, к нашей соте подключена туча абонентов и никто не жалуется. Посоветовали попробовать с чистой системой.
Загрузившись с live cd все смогли одновременно работать и загружать любые сайты. Что наводит на мысль, что что-то не так с нашими системами.  :(


Как-то не хочется всё везде переустанавливать (много чего у всех поустановлено), а также сильно одолевает желание разобраться что за хрень нам жизнь портит, чтобы не повторилось такое после переустановки.

Складывается впечатление, что 80-й порт снаружи кем-то забивается.
К сожалению я не гуру сисадминства и не знаю как поймать этого зверя за хвост.  >:(

Добрые люди, подскажите горемычным убунтоводам куда копать и какие заклинания использовать. Будем бесконечно благодарны.
« Последнее редактирование: 18 Ноябрь 2013, 17:42:22 от alexis_spb »

Оффлайн SvMidi

  • Активист
  • *
  • Сообщений: 815
    • Просмотр профиля
Re: В локалке почти не работает http наружу. Help!
« Ответ #1 : 17 Ноябрь 2013, 20:19:31 »
Мне кажется что дело в роутере, особенно после "Взяли новый роутер, накатали те же настройки, всё нормализовалось.". С другими протоколами как дела обстоят?
Я знаю только то, что ничего не знаю, остальные не знают и этого.

Оффлайн alexis_spb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: В локалке почти не работает http наружу. Help!
« Ответ #2 : 17 Ноябрь 2013, 20:25:16 »
Мне кажется что дело в роутере, особенно после "Взяли новый роутер, накатали те же настройки, всё нормализовалось.". С другими протоколами как дела обстоят?
Мне тоже так казалось, пока то же самое не воспроизвелось с новым роутером и стало понятно, что чистые системы работают без проблем.
Остальные протоколы пашут норм. FTP-клинеты, skype, dropbox, почта - не жалуются.

Оффлайн _rod_

  • Участник
  • *
  • Сообщений: 180
  • Kubuntu 18.04
    • Просмотр профиля
Re: В локалке почти не работает http наружу. Help!
« Ответ #3 : 17 Ноябрь 2013, 20:28:12 »
Цитировать
Загрузившись с live cd все смогли одновременно работать и загружать любые сайты. Что наводит на мысль, что что-то не так с нашими системами.  :(
Нет, роутер ни при чем. Правильно на мысль наводит... с виндой вот тоже без проблем. Куда копать подсказать не могу.... логи компов посмотреть разве что...

Оффлайн SvMidi

  • Активист
  • *
  • Сообщений: 815
    • Просмотр профиля
Re: В локалке почти не работает http наружу. Help!
« Ответ #4 : 17 Ноябрь 2013, 21:35:06 »
Ещё мысль была про одинаковые IP в сети, но раз раздаёт dhcp и всё остальное работает, то вроде как не подходит. Может браузер проверить?
Я знаю только то, что ничего не знаю, остальные не знают и этого.

Оффлайн alexis_spb

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Черт побери! Выяснил, что проблема всё же связана не с системами на наших компах. Вчера повторно пробовал грузиться с live cd, но уже не работало.

Потом взял у соседей такой же роутер, подключил его - всё нормально на всех машинах. Накатал на него наши настройки, тоже всё нормально.
Поменял симку в нашем роутере на чужую - всё отлично. А с нашей симкой в чужом роутере - та же ерунда.

Собрался менять симку. Но перед этим решил прицепить к своему счёту ещё йотовский модемчик с целью интернет с него расшарить на сервере. Сразу после того как я его прикрутил в личном кабинете и кинул на счёт деньги случилось чудо - всё стало работать как ни в чём ни бывало.

Ходил в сервис-центр сдавать роутер, который взял для тестирования. Там сотрудник, выслушав мой скорбный рассказ, нехотя признался что в Йоте сейчас то ли внедряют, то ли допиливают систему приоритезации трафика.  8)

И тогда всё стало на свои места и я прозрел окончательно. Как раз это всё логично объясняет. Вместо понижения скорости в нашем случае там у них что-то переклинило и система стала вообще отрубать часть внутренних клиентов. А когда я прицепил новое устройство, лимит на аккаунт увеличился и глюк пропал.

Вот ведь пи....., так их разэдак, не могли сразу сказать что-ли?  >:( Так ведь и с ума можно свести мнительного клиента...

В общем проблема как-бы "решена", точнее локализована. Спасибо всем кто участвовал. Если у кого-то подобное произойдёт - берите новую сим-карту, это бесплатно у Йоты. На некоторое время точно помогает. Или привязывайте ещё одно устройство, скорость можно на него выставить маленькую, деньги сильно жрать не будет.

Оффлайн _rod_

  • Участник
  • *
  • Сообщений: 180
  • Kubuntu 18.04
    • Просмотр профиля
Re: В локалке почти не работает http наружу. Help!
« Ответ #6 : 18 Ноябрь 2013, 17:45:13 »
Вон оно че..... приоритезация...мда....

Оффлайн andrey_mw

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Сейчас столкнулся с похожей проблемой. 7 виндовс машин работают нормально, а одна с убунтой, так вот http трафик не проходит так же. Причём если ребутнуть роутер то пару минут всё норм. В роутере модем Билайна. Не похоже на приоритезацию.

 

Страница сгенерирована за 0.058 секунд. Запросов: 24.