Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Проблема с исполняемым файлом формата ELF  (Прочитано 336 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nazares

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
  • Ubuntu 13.04
    • Просмотр профиля
Ситуация такая, есть диск от учебника по английскому языку Round UP, проблема в том что некоректно отображается шрифт в Ubuntu но при этом корректно отображается в Elementary OS.
Подскажите пожалуйста в какую сторону копать. Скриншоты под катом.
Ubuntu
(Нажмите, чтобы показать/скрыть)
Elementary
(Нажмите, чтобы показать/скрыть)

PS: Исполняемый файл (ELF) CD_Linux запускает где-то внутри себя main.swf  по сути, я так понял, это просто оболочка для проигрывания флеша.

Пользователь решил продолжить мысль 26 Ноябрь 2013, 15:45:15:
Я так понял ELF пользуется услугами библиотеки /lib/ld-linux.so.2 которая в свою очередь является линком библиотеки /lib/i386-linux-gnu/ld-2.17.so
в elementary используется 2.15. можно их как нить даунгрейднуть? простая подмена не помогла, Ubuntu тупо перестала загружаться, пришлось вертать взад.
« Последнее редактирование: 26 Ноябрь 2013, 16:04:41 от nserge »

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 2264
    • Просмотр профиля
Re: Проблема с исполняемым файлом формата ELF
« Ответ #1 : 26 Ноябрь 2013, 20:25:15 »
Запустите в Ubuntu этот файл из терминала, м.б., он скажет, чего не хватает.
Требуемого шрифта, например, или локаль не та, не знаю.
Заодно вот насчёт ld-linux.so:
https://forum.ubuntu.ru/index.php?topic=177388.0
Пётр.

Оффлайн nazares

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
  • Ubuntu 13.04
    • Просмотр профиля
Re: Проблема с исполняемым файлом формата ELF
« Ответ #2 : 27 Ноябрь 2013, 00:32:33 »
Запустите в Ubuntu этот файл из терминала, м.б., он скажет, чего не хватает.
Требуемого шрифта, например, или локаль не та, не знаю.
Заодно вот насчёт ld-linux.so:
https://forum.ubuntu.ru/index.php?topic=177388.0
Похоже дело всетаки в версии glibc, Ubuntu 12.04 c дефолтным набором шрифтов ldd --version eglibc 2.15 все коректно.
ubuntu 13.04/13.10 ldd --version eglibc 2.17 - не коректно.

 

Страница сгенерирована за 0.081 секунд. Запросов: 25.