Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Ubuntu Server 13.10 на ноутбуке -- отключение спящего режима при закрытии крышки  (Прочитано 18960 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Roboteck

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
Всем привет!

При закрытии крышки на ноуте, на котором стоит ubuntu server 13.10, включается ждущий или спящий режим, как это отключить?

И еще когда крышка открыта, то минут через 5 экран гаснет, это тоже хочу отключить, хочу, чтобы всегда работал экран, когда он открыт.

Оффлайн ccstim

  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
ну а открыть "параметры системы"/"питание" и все это настроить разве есть проблема?

Оффлайн nikulyan

  • Активист
  • *
  • Сообщений: 858
  • Чем хуже дела у Мелкософта, тем лучше у Linux'а
    • Просмотр профиля
ну а открыть "параметры системы"/"питание" и все это настроить разве есть проблема?

у него ubuntu server
ТС, если ты сидишь у сервера больше 5 мин., то там явно тебе делать не чего.
Если ты что-то изучаешь, то подключись к ноуту с помощью putty, будет тебе ещё наука.
или ставь на вертуалку...
Но если тебе всё же нужно, то смотри тут - gedit /etc/default/acpi-support
« Последнее редактирование: 24 Январь 2014, 19:04:47 от nikulyan »

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Я на всех серверах отключаю бланкскрин.
Если сервант теряется по сети можно подключить только моник (если конечно нет iLo или стоечной KVM) и посмотреть ошибки в консоли. Бывает достаточно принять решении о полном зависоне системы и необходимости нажатии MagicKey ;)
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн ccstim

  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
у него ubuntu
и что, думаешь у него графики нет совсем?

тогда для крышки в /etc/systemd/logind.conf
дефолтную
#HandleLidSwitch=suspend
#HandleLidSwitch=hibernate
заменить на
HandleLidSwitch=ignore

Оффлайн nikulyan

  • Активист
  • *
  • Сообщений: 858
  • Чем хуже дела у Мелкософта, тем лучше у Linux'а
    • Просмотр профиля
и что, думаешь у него графики нет совсем?

Да, именно это я и хотел до тебя донести!

P.S. и не стоит коверкать посты

Оффлайн ccstim

  • Новичок
  • *
  • Сообщений: 39
  • Slackware 3.2
    • Просмотр профиля
Да, именно это я и хотел до тебя донести!

прям уж аж "донести!"? :)) категоричный ты парень :))

P.S. и не стоит коверкать посты
а это я не со зла :))

Оффлайн Андрей_В

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Всем привет. Стоит на ноуте ubuntu server 13.10
у меня выглядит так:
[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#Controllers=
#ResetControllers=cpu
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=yes
#LidSwitchIgnoreInhibited=yes
#IdleAction=ignore
#IdleActionSec=30min

при закрытии экрана пропадает связь с сервером. Подскажите как это исправить

Оффлайн RetRider

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Всем привет. Стоит на ноуте ubuntu server 13.10
у меня выглядит так:
[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#Controllers=
#ResetControllers=cpu
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=yes
#LidSwitchIgnoreInhibited=yes
#IdleAction=ignore
#IdleActionSec=30min

при закрытии экрана пропадает связь с сервером. Подскажите как это исправить

Поздно уже увидел, но может кому то еще пригодится.
Проблема в том, что все строки файла закоментированы символом #
То есть для строки #HandleLidSwitch=ignore надо убрать символ #

HandleLidSwitch=ignore

После чего sudo restart systemd-logind на всякий случай перезагрузить процесс

Думаю после этого все будет нормально.

 

Страница сгенерирована за 0.115 секунд. Запросов: 24.