Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Браузер не видит виртуальный хост  (Прочитано 11232 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dwarfadelic

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Браузер не видит виртуальный хост
« : 08 Декабрь 2013, 13:52:33 »
XUbuntu 13.10. Стоит lamp + Webmin. Создаешь вебмином виртуальный хост, пишешь его в файле hosts.

Цитировать
127.0.0.1 localhost
127.0.1.1 anton-MS-7392
127.0.0.1 phpmyadmin

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

А в браузере когда набираешь phpmyadmin попадаешь на дефолтный локалхост, а не на то, что лежит в папке.

Текст файла /etc/apache2/sites-available/phpmyadmin.conf
Цитировать
<VirtualHost *>
DocumentRoot "/home/anton/vhosts/phpmyadmin"
ServerName phpmyadmin
<Directory "/home/anton/vhosts/phpmyadmin">
allow from all
Options +Indexes
</Directory>
</VirtualHost>
« Последнее редактирование: 08 Декабрь 2013, 13:57:14 от dwarfadelic »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27319
    • Просмотр профиля
Re: Браузер не видит виртуальный хост
« Ответ #1 : 08 Декабрь 2013, 14:14:41 »
Как написали, так и работает. У вас

127.0.0.1 localhost
127.0.0.1 phpmyadmin

формат файла hosts напомнить?
Пишите в одну строку

127.0.1.1 anton-MS-7392 phpmyadmin

и уберите третью строчку вообще.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн dwarfadelic

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Браузер не видит виртуальный хост
« Ответ #2 : 08 Декабрь 2013, 14:22:03 »
Не помогает

Пользователь решил продолжить мысль 08 Декабрь 2013, 15:15:17:
При рестарте апача выдает

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
« Последнее редактирование: 08 Декабрь 2013, 15:15:17 от dwarfadelic »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27319
    • Просмотр профиля
Re: Браузер не видит виртуальный хост
« Ответ #3 : 08 Декабрь 2013, 15:21:04 »
dwarfadelic, не помогает что-где?
Это сообщение можно игнорировать.
показывайте
apache2ctl -S
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн dwarfadelic

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Браузер не видит виртуальный хост
« Ответ #4 : 08 Декабрь 2013, 15:28:36 »
$ apache2ctl -S
Цитировать
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
VirtualHost configuration:
*:80                   is a NameVirtualHost
         default server 127.0.1.1 (/etc/apache2/sites-enabled/000-default.conf:1)
         port 80 namevhost 127.0.1.1 (/etc/apache2/sites-enabled/000-default.conf:1)
         port 80 namevhost 127.0.1.1 (/etc/apache2/sites-enabled/000-default.conf:1)
*:*                    is a NameVirtualHost
         default server hostx (/etc/apache2/sites-enabled/hostx.conf:1)
         port * namevhost hostx (/etc/apache2/sites-enabled/hostx.conf:1)
         port * namevhost hostx (/etc/apache2/sites-enabled/hostx.conf:1)
         port * namevhost phpmyadmin (/etc/apache2/sites-enabled/phpmyadmin.conf:1)
         port * namevhost phpmyadmin (/etc/apache2/sites-enabled/phpmyadmin.conf:1)
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex rewrite-map: using_defaults
Mutex default: dir="/var/lock/apache2" mechanism=fcntl
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
PidFile: "/var/run/apache2/apache2.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="www-data" id=33 not_used
Group: name="www-data" id=33 not_used
User: name="www-data" id=33 not_used
Group: name="www-data" id=33 not_used

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27319
    • Просмотр профиля
Re: Браузер не видит виртуальный хост
« Ответ #5 : 08 Декабрь 2013, 16:20:19 »
Ну, сайт оно видит.
curl -sH "Host: phpmyadmin" http://127.0.0.1/
?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн dwarfadelic

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Браузер не видит виртуальный хост
« Ответ #6 : 08 Декабрь 2013, 18:49:25 »
$ curl -sH "Host: hostx" http://127.0.0.1/
<html><body><h1>It works!</h1>
<p>This is the default web page for this server.</p>
<p>The web server software is running but no content has been added, yet.</p>
</body></html>


Пользователь решил продолжить мысль 08 Декабрь 2013, 18:57:42:
Хотя
$ a2ensite hostx
Site hostx already enabled
« Последнее редактирование: 08 Декабрь 2013, 18:57:42 от dwarfadelic »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27319
    • Просмотр профиля
Re: Браузер не видит виртуальный хост
« Ответ #7 : 08 Декабрь 2013, 20:56:30 »
Я отказываюсь понимать, что вы делаете.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн merlex

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Браузер не видит виртуальный хост
« Ответ #8 : 03 Январь 2014, 17:45:46 »
Во-первых проверьте наличее симлинка на фаил конфига хоста в sites-enabled

а во вторых, ВНИМАНИЕ, для тех кто столкнулся с проблемой при миграции конфигов с более ранней версии. Расширение файлов конфигов должно быть .conf об этом нам говорит строка импорта конфигов в apache2.conf

# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

Сам столкнулся с этой проблемой, первой ссылкой в гугле была эта тема, поэтому пишу сюда, может кому поможет.

 

Страница сгенерирована за 0.147 секунд. Запросов: 24.