Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Ошибка: Нарушены зависимости  (Прочитано 615 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Henryh

  • Автор темы
  • Активист
  • *
  • Сообщений: 427
    • Просмотр профиля
Ошибка: Нарушены зависимости
« : 18 Декабрь 2013, 16:47:14 »
Всем привет.
Лабуда какая то происходит, пытался поставить какую-то программу (таймер кажется) она начала требовать программы по зависимостям. Я их подсунул, но она всё рано отказалась ставиться. Я плюнул и забил на неё - нет времени колупаться.
Сейчас не могу ни чего поставить, слетели зависимости, матерится на недоустановленные пакеты (которые я и пытался подсунуть).
apt-get -f install не спасает ситуацию, см скриншот:


Где то в интернетах вычитал что нужно убить пакеты в директории:/var/lib/dpkg/info/

я их командой: rm /var/lib/dpkg/info/ libpan*

Но всё равно ни чего не помогает, любые советы приветствуются.

upd: версия ос Ubuntu 12.04.3 x64 3.2.0-58-generic
« Последнее редактирование: 18 Декабрь 2013, 17:03:36 от keysi_ »

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7188
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Ошибка: Нарушены зависимости
« Ответ #1 : 18 Декабрь 2013, 16:58:49 »
keysi_, версию дистрибутива должны угадать телепаты?

Оффлайн Henryh

  • Автор темы
  • Активист
  • *
  • Сообщений: 427
    • Просмотр профиля
Re: Ошибка: Нарушены зависимости
« Ответ #2 : 18 Декабрь 2013, 17:00:58 »
Ну вот, peregrine, а я так надеялся что орлам это под силу :)

Ubuntu 12.04.3 x64 3.2.0-58-generic
« Последнее редактирование: 18 Декабрь 2013, 17:03:19 от keysi_ »

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7188
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Ошибка: Нарушены зависимости
« Ответ #3 : 18 Декабрь 2013, 17:08:34 »
keysi_,
sudo aptitude -f installЧто говорит?

Оффлайн Henryh

  • Автор темы
  • Активист
  • *
  • Сообщений: 427
    • Просмотр профиля
Re: Ошибка: Нарушены зависимости
« Ответ #4 : 18 Декабрь 2013, 17:15:13 »
peregrine, спасибо Aptitude предложил всё исправить и собственно исправил.

Всегда думал что apt-get и aptitude одинаково работают в таких случаях, но я был не прав - aptitude на высоте.

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7188
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Ошибка: Нарушены зависимости
« Ответ #5 : 18 Декабрь 2013, 17:17:49 »
keysi_, apt-get и aptitude это разные программы. У aptitude в среднем решатель проблем лучше работает, только иногда может предложить снести половину системы, так что аккуратнее с ним.

Оффлайн Henryh

  • Автор темы
  • Активист
  • *
  • Сообщений: 427
    • Просмотр профиля
Re: Ошибка: Нарушены зависимости
« Ответ #6 : 18 Декабрь 2013, 17:28:04 »
Спасибо за предостережение, это важно.

 

Страница сгенерирована за 0.069 секунд. Запросов: 24.