Форум русскоязычного сообщества Ubuntu


Автор Тема: Проблема с монтированием сетевой шары - mount error(112): Host is down  (Прочитано 7148 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kalek

  • Автор темы
  • Активист
  • *
  • Сообщений: 267
    • Просмотр профиля
Проблема следующая.
Есть машина с windows server 2003. При попытке подкоючить ее ресурсы (а именно диск F:) на компьютере с ubuntu 12.04:

sudo mount -t cifs //192.168.1.2/f$ /mnt/svrf -o username=name,domain=domain,password=pass
Вылезает ошибка

mount error(112): Host is down
При том, что другая папка с той же самой винды монтируется без проблем, нужный диск F: есть в списке общих ресурсов windows.
И, что самое интересное, при вводе абсолютно той же самой команды
mount -t cifs //192.168.1.2/f$ /mnt/svrf -o username=name,domain=domain,password=passна другой машине под debian wheezy все монтируется без всяких проблем.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
Огнестена?

smbclient -U user -W domain -L hostЧто кажет?
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн kalek

  • Автор темы
  • Активист
  • *
  • Сообщений: 267
    • Просмотр профиля
smbclient -U администратор -W domain -L server:

Enter администратор's password:
Domain=[DOMAIN] OS=[Windows Server 2003 R2 3790 Service Pack 2] Server=[Windows Server 2003 R2 5.2]

Sharename       Type      Comment
---------       ----      -------
print$          Disk      Драйверы принтеров
C$              Disk      Стандартный общий ресурс
Obmen           Disk     
f$              Disk     
IPC$            IPC       Удаленный IPC
ADMIN$          Disk      Удаленный Admin
D$              Disk      Стандартный общий ресурс
SYSVOL          Disk      Общий сервер входа
NETLOGON        Disk      Общий сервер входа

Ну и дальше список компьютеров в сети

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27626
    • Просмотр профиля
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн kalek

  • Автор темы
  • Активист
  • *
  • Сообщений: 267
    • Просмотр профиля
_netdev тоже не помог.
Помогла только перезагрузка Ubuntu. Причем не в первый раз. Уже было такое, что именно эта примонтированная шара отваливалась, (при том, что другие смонтированные сетевые ресурсы оставались как были) и потом обратно без перезагрузки ее не примонтируешь.
Отваливется она, судя по всему, во время копирования с этого диска f: на ubuntu данных порядка 15-20 ГБ. Но по какой причине оа отваливаеся - не понятно.
Можно конечно в cron прописать ежедневную перезагрузку, но это же не винда,чтобы проблемы решать reset'ом, должен быть какой-то нормальный способ.

Оффлайн fisher74

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 13750
    • Просмотр профиля
вот как раз _netdev должна максимально исключить проблемы с "отваливанием" сервиса.
Принимаю благодарности в WMR и WMZ на кошельки:
R158160676909 и Z313280060764

Оффлайн kalek

  • Автор темы
  • Активист
  • *
  • Сообщений: 267
    • Просмотр профиля
Дописал _netdev в fstab - посмотрим как будет себя вести

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27626
    • Просмотр профиля
При загрузке системы команда mount вызывается дважды.
Первый раз - после монтирования корневого раздела, с параметрами "mount -a -O _netdev".
Второй раз - после подключения сети, вызывается "mount -a"
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.067 секунд. Запросов: 24.