Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Mplayer перестал воспроизводить .MKV и .AVI с кодеком x264  (Прочитано 1254 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Вадимка

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
В декабре все фильмы воспроизводились. С января любые MKV и некоторые AVI с кодеком x264 не воспроизводятся. Остальные форматы работают как раньше. Грешу на обновления Ubuntu недавние.

Что попробовал: переустановил rescticted-extras, smplayer, mplayer2 - не помогло.

Что посоветуете?

P.S. Ubuntu 13.04, ATI Radeon HD5550

SMplayer пишет:
/usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xv -ao pulse -nokeepaspect -framedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 115343407 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/dooda/.config/smplayer/styles.ass -font Arial -subfont-autoscale 0 -subfont-text-scale 20 -subcp enca:ru:CP1251 -subpos 100 -volume 60 -nocache -osdlevel 0 -vf-add screenshot -noslices -channels 2 -af scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /path/Krovyu.I.Potom.Anaboliki.Bluray.x264.aac.rus.eng.by.L.mkv

MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Terminal type `unknown' is not defined.

Playing /media/dooda/data/Files/Video/Movies/Krovyu.I.Potom.Anaboliki.Bluray.x264.aac.rus.eng.by.L.mkv.

И все. Сейчас нашел один MKV с кодеком ffh264, который воспроизводится! :) Даже странно, выборочно как-то.
« Последнее редактирование: 11 Январь 2014, 18:59:52 от Вадимка »

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2600
    • Просмотр профиля
У меня тоже самое было. Я весь избился, и ставил и удалял и плееры и кодеки. Скорее всего mplayer окривел в репах.
Перезапустился в ранее установленную Kubuntu, там работает.
Начал выяснять в чем дело, оказалось что mplayer и smplayer установлены svn, а в новой кубунте не из svn реп.
Svn репы гуглением не нашел, поэтому взял реп из старой Kubuntu и вставил в новую, и все заработало.
Вообще то я весь source list из старой Kubuntu в новую запихал.
« Последнее редактирование: 11 Январь 2014, 18:57:42 от Aleksandru »
Intel Core i3-3240 3.40GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, KINGSTON SV300S37A240G, Kubuntu 20.04

Оффлайн Вадимка

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
Ага, спасибо за наводку, копаюсь...

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2600
    • Просмотр профиля
http://ppa.launchpad.net/motumedia/mplayer-daily/ubuntu precise main
http://ppa.launchpad.net/rvm/smplayer/ubuntu precise main
Попробуй из этих реп поставить.
Intel Core i3-3240 3.40GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, KINGSTON SV300S37A240G, Kubuntu 20.04

Оффлайн Вадимка

  • Автор темы
  • Любитель
  • *
  • Сообщений: 51
    • Просмотр профиля
Забавно, поставил GHex, посмотрел внутренности файлов, а там - нули. :) Видимо, qbittorent подарок сделал, больше некому. Aleksandru, спасибо за советы!

 

Страница сгенерирована за 0.159 секунд. Запросов: 25.