Форум русскоязычного сообщества Ubuntu


Автор Тема: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca  (Прочитано 5882 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн grubnn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Добрый день!
Приобрел нетбук ASUS x200ca с предустановленной Ubuntu 12.04. Раньше с линуксом не сталкивался, но система понравилась. Надо было срочно поработать с документами Word, времени разбираться с установкой Office на Ubuntu не было, снес линукс, поставил Windows 7. Не думал что могут возникнуть проблемы с последующей установкой Ubuntu, поэтому ЖД просто полностью отформатировал.
Почитал факи, оказалось что Office может жить на никсах, решил установить Ubuntu заново. Скачал дистрибутив ubuntu-12.04.3-desktop-amd64.iso с офф сайта. Заглянул в bios. У меня он был версии BIOS 205 (X200CAP), при том, что модель называется просто x200ca (без P на конце). Также на сайте была версия BIOS 208 (X200CA) – которую я скачал и установил. Обе версии от одного и того же числа, обновил на старшую по цифровому коду.
Записал образ unetbootin-windows-585.exe. При установке получил ошибку указанную в названии темы. Пробовал менять флешки, включать и выключать wifi, записывал образ UltraISO. Всего около 40 установок – все заканчивались ошибкой.
На этом форуме нашел совет по разбивке ЖД из Live программой Gparted. Разбил так: 4 гига свап, потом 16 гиг / и остальное /home. При установке система ругнулась на отсутствие root раздела, переформатировал 16 гигабайтный раздел из-под программы установки. Установка завершилась без ошибки. При перезагрузке черный экран с мигающим курсором, ubuntu не грузится, но и сообщений об ошибке загрузки не выдается.


Насколько я понял читая факи, проблема в UEFI bios, некой защите. Попробовал откатиться на BIOS 205 (X200CAP) – не прошивается, пишет bios не той модели. Как я понял, буква P в названии биоса может указывать на отсутствие защиты, либо возможность ее снятия, и может устанавливаться на ноуты с предустановленной ubuntu как у меня было (моя догадка, информации об этом не нашел). Но теперь этот биос прошить я не могу. Настроек по отключению UEFI нет.
Что делать, как вернуть пингвина?

Оффлайн Spect

  • Старожил
  • *
  • Сообщений: 1173
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #1 : 12 Январь 2014, 12:36:42 »
Создать в начале диска efi раздел в 100..200 м размером, остальное так же размечай. Инсталлятору этот раздельчик указать как "boot-efi". Установка загрузчика - указать на sda.
Общая тема https://forum.ubuntu.ru/index.php?topic=167665.0
Ubuntu 16.04 LTS [x86-64]/i3-2100T/2*4G/1T HDD/Intel HD 2000
Hatsan Escort Aimguard Combo 12/76, 7+1

Оффлайн grubnn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #2 : 12 Январь 2014, 13:08:52 »
Создать в начале диска efi раздел в 100..200 м размером, остальное так же размечай. Инсталлятору этот раздельчик указать как "boot-efi". Установка загрузчика - указать на sda.
Общая тема https://forum.ubuntu.ru/index.php?topic=167665.0

Так разделы создаются при установке автоматом. Не помогает(

Оффлайн Spect

  • Старожил
  • *
  • Сообщений: 1173
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #3 : 12 Январь 2014, 14:39:01 »
Биос не откатишь, без ефи не поставишь (на своем х301 поэксперементировал год назад, было).
Судя по сообщению - просто не ставится загрузчик. Предположительно, система-то установилась. Как указываешь куда ставишь загрузчик? Пробовал "все автоматом"? Есть ли какие-то настройки насчет ефи в биосе, не помню.
Как вариант, если ефи раздел есть, можно попробовать восстановить загрузчик (если система все же установилась) - см. http://help.ubuntu.ru/wiki/boot_repair
Ubuntu 16.04 LTS [x86-64]/i3-2100T/2*4G/1T HDD/Intel HD 2000
Hatsan Escort Aimguard Combo 12/76, 7+1

Оффлайн grubnn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #4 : 12 Январь 2014, 18:18:28 »
Все автоматом пробовал, уже десятки раз. Пробовал создавать раздел EFI, вначале, конце... Всего уже провел около 200 установок с разными настройками и параметрами - все безрезультатно. Я так понял что линукс на ноут поставить уже нельзя... И назад его уже не сдам - стер ЖД.

Восстанавливать пока не пробовал.

Оффлайн Spect

  • Старожил
  • *
  • Сообщений: 1173
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #5 : 12 Январь 2014, 18:55:12 »
Он даже сертифицирован под Ubuntu http://www.ubuntu.com/certification/hardware/201306-13793/
Рекомендовано с Ubuntu 12.04.2 LTS 64-bit. Кстати, а не 32-х разрядную ставил?
Изучаем http://jamesnsheri.com/how-to-install-ubuntu-on-asus-x200ca/ - ну там переход на http://ubuntuforums.org
Есть также описание насчет уефи http://ubuntuforums.org/showthread.php?t=2147295.

Так, "черный экран с мигающим курсором, ubuntu не грузится" - попробуй при загрузке с ливюсб, в первом меню, опцию "загрузиться с первого жесткого диска". При установленной без загрузчика системе - будет загружаться. Тогда вопрос только в том, чтобы переустановить загрузчик.
Ubuntu 16.04 LTS [x86-64]/i3-2100T/2*4G/1T HDD/Intel HD 2000
Hatsan Escort Aimguard Combo 12/76, 7+1

Оффлайн grubnn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #6 : 12 Январь 2014, 20:34:26 »
12.04.2 я не нашел, скачал с сайта http://www.ubuntu.com/download/desktop/ файл ubuntu-12.04.3-desktop-amd64.iso - это 64 бит, размер 700 мегабайт. На флешку заливал unetbootin-windows-585.exe и ultraiso 9.5.3.2901. Флешки пробовал на 4, 8 и 16 гигабайт. Ubuntu у меня была установлена при покупке, 12.4 - номер дальше не помню. Возможно это из-за того что я сменил биос с 205 на 208, у них разные индексы, обратно на 205 не прошивается. Штатная утилита прошивальщик WinFlash из под виндоус не работает, пишет что будет работать только на асус-))).
Повторить проход установки без ошибки не могу, делаю то же самое - пишет ту ошибку.
За ссылки спсибо, но не силен в английском, староват его изучать. Не знаю что делать дальше.

Без каких-либо шаманств, в полностью автоматическом режиме установилась и запустилась ubuntu-13.10-desktop-amd64.iso. Почему не работает 12 не понятно.
« Последнее редактирование: 12 Январь 2014, 21:03:22 от grubnn »

Оффлайн Spect

  • Старожил
  • *
  • Сообщений: 1173
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #7 : 12 Январь 2014, 22:08:00 »
Цитировать
обратно на 205 не прошивается
да, асус версию биоса понизить не даст, я поминал выше.
Странно, что не стало 12.04.. Может какая железка "сильно новая" или биос? В 13.10 ядро более позднее, чем в 12.04.3.
Поздравляю! Удачи :))
Ubuntu 16.04 LTS [x86-64]/i3-2100T/2*4G/1T HDD/Intel HD 2000
Hatsan Escort Aimguard Combo 12/76, 7+1

Оффлайн 1eo

  • Активист
  • *
  • Сообщений: 486
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #8 : 13 Январь 2014, 16:40:43 »
1. После прошивки нужно зайти в (U)EFI и выставить правильные параметры загрузки. Как они выглядят на Вашем ноутбуке мне знать не дано, но смысл их в том, чтобы в режиме EFI могла быть загружена OS, отличная от w8\w8.1.
2. В меню загрузки с флешки она должна отобразиться два раза: под именем (U)EFI + её название и просто по названию. Вам нужен первый пункт, с (U)EFI, разумеется.
3. Не осталось ли на винчестере скрытые разделы восстановления w8\w8.1? Возможно, они могут помешать (или Вы их захотите сохранить).

Оффлайн grubnn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #9 : 14 Январь 2014, 15:19:08 »
Рано я обрадовался. На 13.10 не определился bt, система страшно тормозит по сравнению со штатной 12.04. Хром открывается секунд 7. Продолжаю попытки установить 12 версию.

1. После прошивки нужно зайти в (U)EFI и выставить правильные параметры загрузки. Как они выглядят на Вашем ноутбуке мне знать не дано, но смысл их в том, чтобы в режиме EFI могла быть загружена OS, отличная от w8\w8.1.
2. В меню загрузки с флешки она должна отобразиться два раза: под именем (U)EFI + её название и просто по названию. Вам нужен первый пункт, с (U)EFI, разумеется.
3. Не осталось ли на винчестере скрытые разделы восстановления w8\w8.1? Возможно, они могут помешать (или Вы их захотите сохранить).
По п.1 - нет у меня никаких настроек UEFI, не безопасной загрузки, ни чего-либо еще.
п.2 - выбирал всякие методы, всего около 200 установок сделал.
п.3 - была предустановлена ubuntu с завода, так что разделов Win не было. При форматировании снес весь винчестер.

Если найти образ ubuntu с аналогичного заводского ноута, можно ее развернуть (восстановить) на моем ноутбуке?

Оффлайн 1eo

  • Активист
  • *
  • Сообщений: 486
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #10 : 14 Январь 2014, 18:37:45 »
Если вообще нет EFI, то почему он упоминается в заголовке темы?
1. Попробуйте загрузиться с флешки в live-режим и провести установку оттуда.
2. Попробуйте установить i386 (32-битный) дистрибутив, он не содержит пакета grub-efi-amd64
3. Наличие слова signed в grub-efi-amd64-signed наталкивает на мрачные мысли: одно из толкований - пакет подписан именно для этого ноутбука, а после перепрошивки ноутбук стал "не своим".
4. Попробуйте связаться с сервисом ASUS, о нём хорошие отзывы. В частности можно выяснить, является ли перепрошивка на старшую версию основанием для отказа в гарантии.

Оффлайн grubnn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #11 : 15 Январь 2014, 09:25:53 »
Если вообще нет EFI, то почему он упоминается в заголовке темы?

EFI есть, нет настроек EFI: По п.1 - нет у меня никаких настроек UEFI,

В лайв грузится нормально. Попробую поставить 32 битную версию.

Оффлайн Spect

  • Старожил
  • *
  • Сообщений: 1173
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #12 : 15 Январь 2014, 13:47:25 »
Цитировать
2. Попробуйте установить i386 (32-битный) дистрибутив, он не содержит пакета grub-efi-amd64
Без efi - на Асусы Х система становится, загрузчик - никак.
Эксперементировал год назад - сначала поставил "без ефи", система нормально встала переставил "с ефи" - встала, и вот потом выяснилось, что уже "без ефи" ставить ничего не дает - только с ним :) Перешил биос на следующий - все так же. Перешивка биоса на ниже версию - штатно не дает. На форуме советовали как крайний вариант - поставить или загрузиться в лив-режиме винь и перешить биос "вниз" утилитой виндовой - это, писали, позволит вернуть биос-старее, не проверял.
(Нажмите, чтобы показать/скрыть)
Ubuntu 16.04 LTS [x86-64]/i3-2100T/2*4G/1T HDD/Intel HD 2000
Hatsan Escort Aimguard Combo 12/76, 7+1

Оффлайн 1eo

  • Активист
  • *
  • Сообщений: 486
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #13 : 15 Январь 2014, 23:20:11 »
Если вообще нет EFI, то почему он упоминается в заголовке темы?
EFI есть, нет настроек EFI: По п.1 - нет у меня никаких настроек UEFI,
В лайв грузится нормально. Попробую поставить 32 битную версию.

Вспомнил древний способ открытия дополнительных настроек BIOS в матплатах Gigabyte: [Ctrl]+[F1].
Нет ли подобного в рассматриваемом EFI? Это может знать сервис ASUS. 

Оффлайн grubnn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: The grub-efi-amd64-signed package failed to install into /target/. ASUS x200ca
« Ответ #14 : 16 Январь 2014, 19:19:32 »
Победить UEFI при установке с флешки так и не смог. Взял внешний DVD - устанавливается и запускается без проблем.

Новая проблема. Захотел поставить Ubuntu рядом с Windows 7. Ставиться без проблем, запускается только Win, такое ощущение что система не знает про Ubuntu вообще.

Перепробовал массу вариантов с установкой загрузчиков Win и Grub в разные разделы, не помогает. В какую сторону копать?

 

Страница сгенерирована за 0.064 секунд. Запросов: 25.