Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Blender 2.69 CUDA  (Прочитано 2735 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн agriiii

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Blender 2.69 CUDA
« : 16 Январь 2014, 21:23:59 »
Хочу установить из исходников Blender 2.69 32bit с поддержкой CUDA. В наличии есть карта, с поддержкой CUDA - Nvidia GT610 и Ubuntu 12.04. Проблема в том, что по следуя инструкции по wiki - нужного файла в исходниках нет, в нете готовых пакетов этой версии с поддержкой CUDA - тоже нет, а нужен рендер именно через GPU с CUDA.

Как установить? Например пишут о надобности nvidia-cuda-toolkit, но в терминале пишет пакет с ошибками.

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7188
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Re: Blender 2.69 CUDA
« Ответ #1 : 16 Январь 2014, 21:34:32 »
agriiii, а чем из репозиториев не угодил? И что за ошибки при сборке, как собираете, какая ОС и т.д.

Оффлайн agriiii

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Blender 2.69 CUDA
« Ответ #2 : 16 Январь 2014, 22:50:44 »
Из репозитария - старая версия, нет рендера cycles, нет поддержки CUDA, нет даже выбора чем рендерить - CPU или GPU.

Сейчас пытался установить из реп - выдало ошибки про пакеты nvidia, конкретно - не знаю как посмотреть, но установило - работает, хотя выше проблемы есть. А вот с сайта скачав последнюю версию, но без CUDA - всё хорошо, но долго рендерит, что и хочу исправить.

OC - Elementary OS (Luna), на основе Ubuntu 12.04, 32 бита.

Если я правильно понял - сейчас какая-то лажа с видеодрайверами (ошибки пакетов nvidia)?

Пытался делать по мануалу http://wiki.blender.org/index.php/Dev:Doc/Building_Blender/Linux/Ubuntu/CMake

Проблема уже на первом шаге:

sudo apt-get update; sudo apt-get install git build-essential
Уже установлена самая новая версия git.
Уже установлена самая новая версия build-essential.
Следующие пакеты устанавливались автоматически и больше не требуются:
  gir1.2-gstreamer-0.10 libcairomm-1.0-1 libglibmm-2.4-1c2a libatkmm-1.6-1
  libsigc++-2.0-0c2a libpangomm-1.4-1
Для их удаления используйте «apt-get autoremove».
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 40 пакетов не обновлено.
не установлено до конца или удалено 4 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить [Д/н]? y
Настраивается пакет nvidia-current (319.37-0ubuntu1) ...
update-alternatives: ошибка: alternative link /usr/share/man/man1/nvidia-persistenced.1.gz is already managed by i386-linux-gnu_man_persistenced.gz (slave of i386-linux-gnu_gl_conf).
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 2
Отчёты apport не записаны, так достигнут MaxReports
                                                   dpkg: зависимости пакетов не позволяют настроить пакет nvidia-compute-profiler:
 nvidia-compute-profiler зависит от nvidia-current (>= 270) | nvidia-current-updates (>= 270) | nvidia-experimental-304 (>= 270) | nvidia-experimental-310 (>= 270), однако:
  Пакет nvidia-current пока не настроен.
  Пакет nvidia-current-updates не установлен.
  Пакет nvidia-experimental-304 не установлен.
  Пакет nvidia-experimental-310 не установлен.
dpkg: не удалось обработать параметр nvidia-compute-profiler (--configure):
 проблемы зависимостей -- оставляем не настроенным
Отчёты apport не записаны, так достигнут MaxReports
                                                   dpkg: зависимости пакетов не позволяют настроить пакет nvidia-opencl-dev:
 nvidia-opencl-dev зависит от nvidia-current | nvidia-current-updates | nvidia-experimental-304 | nvidia-experimental-310 | libopencl1, однако:
  Пакет nvidia-current пока не настроен.
  Пакет nvidia-current, предоставляющий nvidia-current, пока не настроен.
  Пакет nvidia-current-updates не установлен.
  Пакет nvidia-current, предоставляющий nvidia-current-updates, пока не настроен.
  Пакет nvidia-experimental-304 не установлен.
  Пакет nvidia-current, предоставляющий nvidia-experimental-304, пока не настроен.
  Пакет nvidia-experimental-310 не установлен.
  Пакет nvidia-current, предоставляющий nvidia-experimental-310, пока не настроен.
  Пакет libopencl1 не установлен.
  Пакет nvidia-304, предоставляющий libopencl1, не установлен.
dpkg: не удалось обработать параметр nvidia-opencl-dev (--configure):
 проблемы зависимостей -- оставляем не настроенным
Отчёты apport не записаны, так достигнут MaxReports
                                                   dpkg: зависимости пакетов не позволяют настроить пакет nvidia-cuda-toolkit:
 nvidia-cuda-toolkit зависит от nvidia-opencl-dev (= 4.0.17-3ubuntu0.1), однако:
  Пакет nvidia-opencl-dev пока не настроен.
dpkg: не удалось обработать параметр nvidia-cuda-toolkit (--configure):
 проблемы зависимостей -- оставляем не настроенным
Отчёты apport не записаны, так достигнут MaxReports
                                                   При обработке следующих пакетов произошли ошибки:
 nvidia-current
 nvidia-compute-profiler
 nvidia-opencl-dev
 nvidia-cuda-toolkit
E: Sub-process /usr/bin/dpkg returned an error code (1)

P.S. - установлены драйвера версии 331.38, понятия не имею почему хочет другую версию и копает разные экспериментальные пакеты.

Пользователь решил продолжить мысль 16 Январь 2014, 23:29:56:
Пока ждал ответа, сделал след. команды:

sudo apt-get remove --purge nvidia*

sudo apt-get install nvidia-current

sudo apt-get install nvidia-cuda-toolkit

В итоге имею следующее: в настройки nvidia х-сервера зайти не могу, не запускает. Если верить синаптику - версия откатилась до 319.37, что плохо с одной стороны, но.. в портативной версии blender, скачанной с их оф.сайта появился выбор, и есть CUDA!

Вопрос - как обновить драйвера, чтоб появились опять настройки видеокарты и не заблочить выбор рендера в blender? Может конфликтуют они?

Пользователь решил продолжить мысль 17 Январь 2014, 00:01:07:
Вероятно проблема была в кривой установке драйверов, удалив всё и установив заново, всё заработало.
« Последнее редактирование: 17 Январь 2014, 00:01:07 от agriiii »

 

Страница сгенерирована за 0.083 секунд. Запросов: 26.