Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Помощь с postfix  (Прочитано 2198 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн savenko

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Помощь с postfix
« : 21 Январь 2014, 19:08:58 »
Здравствуйте!
Помогите ,пожалуйста, разобраться.
1) В логах есть eximquotacheck: File '' isn't exists. Как это вылечить?
2) Так же в логах warning: do not list domain example.com in BOTH mydestination and virtual_alias_domains (Подставил свой домен для примера, но он точно есть в списке из файла /etc/mail/local-host-names)
Менял mydestination на localhost но тогда не одно письмо не проходит, но ошибка пропадает из логов. Сейчас установлено значение "mydestination = $myhostname, localhost.$mydomain, localhost"
3) Некотороые письма не проходят. Отписка "452 user@example.com mail receiving disabled"

Оффлайн Karl500

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2261
    • Просмотр профиля
Re: Помощь с postfix
« Ответ #1 : 21 Январь 2014, 21:27:34 »
1. Слово "eximquotacheck" как бы намекает, что это имеет какое-то отношение не к postfix, а к exim. У Вас никаких ошметков от exim не осталось?
2. Домен должен быть указан ИЛИ в списке $mydestination ИЛИ в списке виртуальных доменов. Вы используете виртуальный домен?
3. Пользователю запрещен прием писем. Почему - указано где-то в настройках.

Для более подробного ответа нужна полная информация о настройках postfix.

Оффлайн savenko

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Помощь с postfix
« Ответ #2 : 21 Январь 2014, 22:06:21 »
1. Слово "eximquotacheck" как бы намекает, что это имеет какое-то отношение не к postfix, а к exim. У Вас никаких ошметков от exim не осталось?
2. Домен должен быть указан ИЛИ в списке $mydestination ИЛИ в списке виртуальных доменов. Вы используете виртуальный домен?
3. Пользователю запрещен прием писем. Почему - указано где-то в настройках.

Для более подробного ответа нужна полная информация о настройках postfix.

Спасибо за помощь)))
1. есть  /etc/exim4.  Его лучше переменовать? или как-то автозапуск можно отключить? Добавил позже: Через команды "dpkg -l | grep exim" и "sudo aptitude purge ~c" удалил все лишнее от Exim, но ошибка осталась
2. Насколько я понял что такое виртуальные домены, то у меня несколько доменов прикреплены к серверу. example1.com и example2.com, но пользователи заведены отдельно для каждого домена, т.е. user@example1.com не должен получить почту user@example2.com
3. Только от одного ползователя не приходят письма. В приложении у него 2 PDF файла было. Простые письма проходят.

Настройки:

#
 See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/sslsmtpd.crt
smtpd_tls_key_file = /etc/postfix/sslsmtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = example.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = $myhostname, localhost.$mydomain, localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = /usr/bin/procmail
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
mydomain = localdomain
myorigin = $myhostname
local_recipient_maps = unix:passwd.byname $alias_maps
virtual_alias_domains = /etc/mail/local-host-names
virtual_alias_maps = hash:/etc/mail/virtusertable
smtp_generic_maps = hash:/etc/mail/generic
sender_dependent_default_transport_maps = regexp:/etc/mail/domainips
default_transport = smtp:
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_received_header = yes
smtpd_tls_loglevel = 1
smtpd_sender_restrictions = permit_sasl_authenticated, check_sender_access hash:/etc/mail/access
smtpd_client_restrictions = permit_sasl_authenticated, check_client_access hash:/etc/mail/access
smtpd_recipient_restrictions = permit_sasl_authenticated, check_sender_access hash:/etc/mail/access, check_client_access hash:/etc/mail/access, check_recipient_access hash:/etc/mail/access, permit_mynetworks, reject_unauth_destination, reject_unlisted_recipient, reject_unverified_recipient
« Последнее редактирование: 21 Январь 2014, 22:28:24 от savenko »

Оффлайн Karl500

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2261
    • Просмотр профиля
Re: Помощь с postfix
« Ответ #3 : 21 Январь 2014, 22:31:36 »
Если у Вас используются виртуальные домены (а это так, судя по строке virtual_alias_domains = /etc/mail/local-host-names), то из строки mydestination нужно убрать example.com

postmap /etc/mail/local-host-names

делали?

Ваш сервер весьма вероятно будет служить открытым релеем - чтобы заведомо этого избежать, переставьте в строке smtpd_recipient_restrictions значение reject_unauth_destination сразу после permit_sasl_authenticated (предварительно перенесите permit_mynetworks в начало строки).

По какому руководству настраивали? Как-то все коряво, честно говоря...

Оффлайн savenko

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Помощь с postfix
« Ответ #4 : 21 Январь 2014, 22:46:57 »
Если у Вас используются виртуальные домены (а это так, судя по строке virtual_alias_domains = /etc/mail/local-host-names), то из строки mydestination нужно убрать example.com

postmap /etc/mail/local-host-names

делали?

Ваш сервер весьма вероятно будет служить открытым релеем - чтобы заведомо этого избежать, переставьте в строке smtpd_recipient_restrictions значение reject_unauth_destination сразу после permit_sasl_authenticated (предварительно перенесите permit_mynetworks в начало строки).

По какому руководству настраивали? Как-то все коряво, честно говоря...

Великий и ужасный ispmanager )))
Убрал, вот что вылезло
<virtuser_507@examlple1.com> (expanded from <user@examlple.com>): User unknown in virtual alias table

P.S.
На команду sudo postmap /etc/mail/local-host-names ругается так как там просто хоcты указаны,  каждый на своей строчке example1.com, example2.com
Если запускаю "sudo postmap /etc/mail/virtusertable" то все хорошо проходит
« Последнее редактирование: 21 Январь 2014, 23:20:49 от savenko »

Оффлайн Karl500

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2261
    • Просмотр профиля
Re: Помощь с postfix
« Ответ #5 : 22 Январь 2014, 10:13:38 »
А почему Вы используете virtual_alias_domains, если говорите, что "пользователи заведены отдельно для каждого домена"? Используйте тогда virtual_mailbox_domains. Ну и посмотрите правильный формат этой таблицы:

Цитировать
virtual_mailbox_domains (default: $virtual_mailbox_maps)
Postfix is final destination for the specified list of domains; mail is delivered via the $virtual_transport mail delivery transport. By default this is the Postfix virtual(8) delivery agent. The SMTP server validates recipient addresses with $virtual_mailbox_maps and rejects mail for non-existent recipients. See also the virtual mailbox domain class in the ADDRESS_CLASS_README file.

This parameter expects the same syntax as the mydestination configuration parameter.

 

Страница сгенерирована за 0.128 секунд. Запросов: 24.