Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Установить VMWare Tools на ubuntu-13.10-desktop-amd64  (Прочитано 4023 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн iiiopot

  • Автор темы
  • Новичок
  • *
  • Сообщений: 27
  • Ничто не истина (с) Ecio Auditore
    • Просмотр профиля
В связи с тем что более не поддерживается 13.04 и старшие товарищи на это указали пальцем, пересодал тему.

Суть проблемы:
После обновления пропала общая папка из /mnt. Посоветовали переустановить VMTools. Процесс застревает на ошибке:
«Searching for a valid kernel header path...
The path "" is not valid.».
Я естественно понимаю, что валидный путь не может быть пустым, но какой нажно указать??

Был задан вопрос:
Цитировать
А сами источники ядра есть в системе из чего компилировать?

aptitude search linux-headers-`uname -r`

и мною дан на него ответ:

iiiopot@ubuntu:~$ aptitude search linux-headers-`uname -r`
The program 'aptitude' is currently not installed. You can install it by typing:
sudo apt-get install aptitude
iiiopot@ubuntu:~$ sudo apt-get install aptitude
...
Processing triggers for libc-bin ...
iiiopot@ubuntu:~$ aptitude search linux-headers-`uname -r`
i   linux-headers-3.11.0-15-generic - Linux kernel headers for version 3.11.0 on
p   linux-headers-3.11.0-15-generic - Linux kernel headers for version 3.11.0 on
iiiopot@ubuntu:~$

другое окно терминала

The path "/usr/include/linux/" is not a valid path to the 3.11.0-15-generic
kernel headers.
Would you like to change it? [yes]

Enter the path to the kernel header files for the 3.11.0-15-generic kernel? /usr/src/linux-headers-3.11.0-15-generic

The path "/usr/src/linux-headers-3.11.0-15-generic" is not a valid path to the
3.11.0-15-generic kernel headers.
Would you like to change it? [yes]

Тогда был предложен вариант:

Цитировать
/usr/src/linux-headers-3.11.0-15-generic/include/linux/ ?

Но к сожалению он мне не помог.

Цитировать
The path "/usr/src/linux-headers-3.11.0-15-generic/include/linux/" is not a
valid path to the 3.11.0-15-generic kernel headers.
Would you like to change it? [yes]

Enter the path to the kernel header files for the 3.11.0-15-generic kernel? /usr/src/linux-headers-3.11.0-15-generic/include/linux

The path "/usr/src/linux-headers-3.11.0-15-generic/include/linux" is not a
valid path to the 3.11.0-15-generic kernel headers.
Would you like to change it? [yes]


хотя сама диириктория есть:

(Нажмите, чтобы показать/скрыть)
естественно ссылки.


iiopot@ubuntu:~$ sudo apt-get install build-essential linux-headers-`uname -r` psmisc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version.
psmisc is already the newest version.
linux-headers-3.11.0-15-generic is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Ума не приложу, в чем проблема?!



Пользователь решил продолжить мысль 02 Февраль 2014, 18:16:29:
!! Кстати, а разница есть ubuntu-13.10-desktop-amd64 и ubuntu-13.10-desktop-i386? :o

Пользователь решил продолжить мысль 03 Февраль 2014, 11:07:16:
Нашел путь:
"/lib/modules/3.11.0-15-generic/build/include"

 :D :P

Пользователь решил продолжить мысль 03 Февраль 2014, 17:04:17:
Цитировать
Нашел путь:
"/lib/modules/3.11.0-15-generic/build/include"


Данный вариант прокатил для ubuntu-13.10-desktop-i386, к сожалению на ubuntu-13.10-desktop-amd64 не заработал !!!
Вопрос остался открытым  :-[

ТС не появлялся на Форуме более полугода по состоянию на 09/09/2019 (последняя явка: 02/01/2019). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 09 Сентябрь 2019, 15:57:51 от zg_nico »
NB Asus Intel® Core™ i7-4510U\7.2 GiB\Ubuntu 18.04.1 LTS\64-bit\GNOME 3.28.2\4.15.0-43-generic

Оффлайн inklink

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Установить VMWare Tools на ubuntu-13.10-desktop-amd64
« Ответ #1 : 07 Май 2015, 09:17:10 »
Так обрадовался найденному решению этой проблемы, что аж решил зарегиццо тут, дабы помочь страждущим. :D
Во-первых, если Вы уже установили VMware tools, но без тех самых kernel headers (например, в ответ на бесконечное The path "/usr/include/linux/" is not a valid path to the "какая-то версия"-generic
kernel headers.
Would you like to change it? [yes]
ответили no), удалите его демонически хохоча посредством sudo ./vmware-uninstall-tools.pl. А потом делаем в терминале следующее:
1) ставим это sudo apt-get install build-essential2) ставим вот это sudo apt-get install linux-headers-$(uname -r)3) и заново устанавливаем VMware tools.
Лично у меня всё получилось, но у меня ubuntu-14.04.2-desktop-i386 на VMware Workstation v9.0.1 и вообще, я не Иванов, а Рабинович, а как у Вас - не знаю.
Если что-то пошло не так, и путь всё равно требует, можно попробовать перед установкой помолиться ктулху сделать вот это: sudo ln -s /usr/src/linux-headers-$(uname -r)/include/generated/uapi/linux/version.h /usr/src/linux-headers-$(uname -r)/include/linux/version.h Авось, поможет  :)
Материалы сего поста взяты отсюда: http://stackoverflow.com/questions/18805697/installing-vmware-tools-not-recognizing-path-to-3-8-0-19-generic-kernel-files
Всем удачи!  ;)

Оффлайн SABeShnik

  • Любитель
  • *
  • Сообщений: 99
  • KDE 19.04
    • Просмотр профиля
Re: Установить VMWare Tools на ubuntu-13.10-desktop-amd64
« Ответ #2 : 07 Май 2015, 11:13:10 »
inklink,
Спасибо добрый человек
2x2Gb DDRIII, C2D8400, Seagate 2x2Tb 5900, Samsung 1Tb 7200,
Seagate 250 7200, X633, AeroCool 700W

 

Страница сгенерирована за 0.097 секунд. Запросов: 23.