Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: LAMP настройка локальных мультисайтов - права доступа & apache2 ошибки  (Прочитано 7567 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andreuss

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Здравствуйте,

После настройки LAMP появились проблемы с правами доступа к папке, а также и другая ошибка.

Необходимо настроить LAMP для локального тестирования разных сайтов (drupal, wordpress и т.д.)


ОС версии десктоп: Linux Mint 16 Cinnamon
Установлен: LAMP

Ошибки:

1. Во время рестарта apache2:
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message

2. Ошибка прав доступа к проверочному файлу php http://ledolmen.ca/public/phpinfo.php

Ошибка прав доступа в браузере:

Цитировать
Forbidden
You don't have permission to access /public/phpinfo.php on this server.

Apache/2.4.6 (Ubuntu) Server at ledolmen.ca Port 80


=======

Подробности:


Настройки стандартной директории var/www были изменены на /home/Локальный-пользователь/www/название-сайта.com/public

Внутри папки public помещён файл phpinfo.php с целью проверки php.

==

Данные прав доступа к папке:


    $ ls -la /home/go/www
    total 20
    drwxrwsrwx  3 go www-data  4096 Feb  2 23:23 .
    drwx------ 45 go go       12288 Feb  2 23:29 ..
    drwxrwsrwx  3 go www-data  4096 Feb  2 18:46 ledolmen.ca

----


Проделанные шаги для установки и настройки LAMP:



sudo apt-get install lamp-server^
После чего был еще установлен phpmyadmin

После установке был создан и настроен конфигурационный файл для локального сайта. Файл был создан по адресу:

   
Цитировать
/etc/apache2/sites-available

Файл был назван с учётом адреса локального сайта: ledolmen.ca.conf

Конфигурационные данные файла:



   
Цитировать
<VirtualHost *:80>

    ServerName ledolmen.ca
    ServerAlias Welcome to Le Dolmen | Le Dolmen
    ServerAdmin go@localhost
    DocumentRoot /home/go/www/ledolmen.ca/public

    <Directory /home/go/www/ledolmen.ca/public/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>



    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined


    </VirtualHost>

--

Настройка файла хостов с добавлением локального домена:

$ sudo gedit /etc/hosts

Данные в файле hosts:

   
   
Цитировать
127.0.0.1 localhost ledolmen.ca
    127.0.0.1 ml

В директории /etc/apache2 настроен файл httpd.conf со следующими параметрами:

 
Цитировать
  ServerName localhost

Активация локального сайта:



sudo a2ensite ledolmen.ca
Перезагрузка апачи:


sudo /etc/init.d/apache2 restart

===========================

После проделанных шагов происходят следующие ошибки:

1. Во время перезагрузки apache2 :
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message

2. Не возможность открыть тестовый php файл по адресу http://ledolmen.ca/public/phpinfo.php

Ошибка с правами доступа:

Цитировать
Forbidden
You don't have permission to access /public/phpinfo.php on this server.

Apache/2.4.6 (Ubuntu) Server at ledolmen.ca Port 80

--


Если кто знает, подскажите пожалуйста где ошибся. Может чего не доглядел.

Заранее благодарен.

Оффлайн grOk

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Попробуйте добавить
<Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>

Мой конфиг выглядит так (Ubuntu Server 12.04):
<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        ServerName wordpress
        ServerAlias wordpress www.wordpress
        DocumentRoot /home/пользователь/web/wordpress/public_html
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /home/пользователь/web/wordpress/public_html/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

hosts:
127.0.0.1 www.wordpress wordpress

Оффлайн andreuss

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
grOk,
благодарю за помощь!

Проследовал Вашим рекомендациям.
Но ничего не изменилось.

Странно, что отлично работает тестовый php файл в папке /var/www/phpinfo.php
То есть, через ссылку localhost/phpinfo.php отлично заходит.

Но вот через настроенную в домашней директории папку www ни в какую..

Так что всё еще присутствуют две ошибки:

Ошибки:

1. Во время рестарта apache2:
Цитировать
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message

2. Ошибка прав доступа к проверочному файлу php http://ledolmen.ca/public/phpinfo.php

Ошибка прав доступа в браузере:



   
Цитировать
Forbidden
    You don't have permission to access /public/phpinfo.php on this server.

    Apache/2.4.6 (Ubuntu) Server at ledolmen.ca Port 80

Оффлайн vadim-nsk

  • LoCo команда
  • Старожил
  • *
  • Сообщений: 1318
  • Жить надо так, как горит пламя!
    • Просмотр профиля
    • Linux в Новосибирске
Посмотрите, что получите в результате выполнения следующих команд:
hostname -f
ls -la /home/Локальный-пользователь/www/название-сайта.com/
ps aux | grep www-data


 

Страница сгенерирована за 0.08 секунд. Запросов: 25.