Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Странное поведение програмного RAID0  (Прочитано 1750 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ixes26

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Странное поведение програмного RAID0
« : 17 Февраль 2014, 21:23:06 »
Суть такова:
  Ubuntu 12.4.4 desktop
  Диски Sundisk-SSD (на нем система), WD Raid edition (WD2003FYYS)-2 шт (для рэйда)
  Мать Gigabyte GA-C1037UN-EU
Собрал при помощи mdadm soft-RAID0:
mdadm --create --verbose /dev/md0 --level=0 \
  --raid-devices=2 /dev/sdb1 /dev/sdc1

форматнул:
mkfs.ext4 /dev/md0
Опции монтирования fstab:
вариант-1
/dev/md0 /mnt/raid ext4 noatime,nodiratime,errors=remount-ro,commit=60    1 2
вариант-2
/dev/md0 /mnt/raid ext4 default    0 0
При загрузке, т.е. при монтировании рэйда начинают мигать светодиоды обращения к дискам рэйда с частотой 0.5-сек. Отмантирую рэйд - перестаёт мигать (при любых опциях монтирования fstab). Сам собранный рэйд работает нормально, скорость запись/чтение все ок (хотя если устранить проблему, может будет побыстее).
Команда iotop -o во время работы примонтированного рэйда, выдаёт активность  процесса -ext4lazyinit , что это за хрень и за что она отвечает я так и не нашел.
Команда cat /proc/mdstat выдаёт
Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [ra
id10]
md0 : active raid0 sdc1[1] sdb1[0]
      3907025920 blocks super 1.2 512k chunks

unused devices: <none>


Переживаю что это частое "мигание" не просто обращение к плате HDD, оно скореевсего и головки диска тревожит, что не есть хорошо.
Может быть это обращение к диску, запись на диск, запись в кеш, сброс кеша на диск (на соседнем windows-форуме нашел)? Может спицифика дисков raid-edition (по исправлению ошибок)? Может еще что. Если кто сталкивался, или если есть мысли по лечению этого фетиша прошу помочь.
« Последнее редактирование: 17 Февраль 2014, 21:35:47 от ixes26 »

Оффлайн Karl500

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2240
    • Просмотр профиля
Re: Странное поведение програмного RAID0
« Ответ #1 : 17 Февраль 2014, 21:30:49 »
Ну, вообще-то гуглится на раз. Вот, например: https://bbs.archlinux.org/viewtopic.php?pid=1285202
Если коротко и по-русски: ext4 создается не полностью при форматировании, частично процесс продолжается при первом монтировании. Если раздел велик, этот процесс "досоздания" ФС может занять продолжительное время. Совет: оставьте, например, на ночь и посмотрите наутро.

Оффлайн ixes26

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Странное поведение програмного RAID0
« Ответ #2 : 17 Февраль 2014, 21:38:02 »
Спасибо! попробую
если головка блины в ноль не сотрет к утру :)

Оффлайн ixes26

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Странное поведение програмного RAID0
« Ответ #3 : 18 Февраль 2014, 23:59:08 »
тощно-тощно!
Джидай спас падавана! :coolsmiley:
на утро диски осознали своё безобразие и все заработало!
Спасибо  Karl500  !!!

 

Страница сгенерирована за 0.055 секунд. Запросов: 24.