Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Всем кто не смог справиться с процессом kworker !  (Прочитано 15600 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pl7ofit

  • Автор темы
  • Активист
  • *
  • Сообщений: 299
  • U18.04,Ryzen 5 1600,GTX 1050,8GB-DDR4
    • Просмотр профиля
    • vk.com/pl7ofit
http://ubuntulyb.blogspot.ru/2011/11/kworker-ubuntu.html - это мне не помогло.

Я года два пытался понизить нагрузку на процессор и наконец-то есть решение!  >:(

1.Проверяем
sudo -s
echo "disable" > /sys/firmware/acpi/interrupts/gpe06

Kworker теперь нагружает процессор не более чем на 3% ? Тогда сделаем что бы так было всегда.

2.Добавляем в rc.local:
sudo gedit /etc/rc.local Такие строки до exit 0:
echo "disable" > /sys/firmware/acpi/interrupts/gpe06
chmod -w-w-w /sys/firmware/acpi/interrupts/gpe06

PROFIT!  :D

Пишите если помогло!

ЗЫ: любой желающий может скопипастить это решение, что бы новичков не отпугивал Linux
ЗЫЗЫ: Такую же проблему имеет и Windows, но её решение не известно до сих пор,на ней процесс называется interrupts.
« Последнее редактирование: 20 Февраль 2014, 19:43:58 от Pl7ofit »
Добавляйтесь! Steam nick: pl7ofit

Линус над нами.Визин в кармане.Под ногами андроиды.Вперед Линуксоиды!

Оффлайн delvin-fil

  • Новичок
  • *
  • Сообщений: 31
  • import __hello__
    • Просмотр профиля
Доброго утра(у меня 7:35)!
А почему именно в gpe06?
У меня
          CPU0       CPU1       CPU2       CPU3       
9:          0               1                 1             1            IO-APIC-fasteoi   acpi
То есть 1,2 и 3-е ядра им заняты.
здесь http://ubuntuforums.org/showthread.php?t=1630347 рекомендуют пинать 01-ое ядро.

А, и да, если отключаю conky, активность IO падает в 20-30 РАЗ!!!  8) Не шутка!
« Последнее редактирование: 27 Август 2015, 04:21:38 от delvin-fil »
Делай что должен и сбудется, чему суждено!

Оффлайн Retoxic

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
echo "disable" > /sys/firmware/acpi/interrupts/gpe
bash: echo: write error: Invalid argument

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1927
    • Просмотр профиля
Retoxic, потому что не указан конкретный адрес
найти 

grep enabled /sys/firmware/acpi/interrupts/gpe*
 --------------------------

/sys/firmware/acpi/interrupts/gpe13: 16474884 enabled
 
У вас будут другие цифры после «gpe».

и останов
echo "disable" > /sys/firmware/acpi/interrupts/gpeХХ


Оффлайн Morisson

  • Модератор раздела
  • Старожил
  • *
  • Сообщений: 3956
    • Просмотр профиля
вы чего, некропостеры :2funny:

Оффлайн ZevSua

  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
Афигеть костыли.. Через опу же все. Да и будет работать только на том конкретном проце что у старттопика.

Правильнее будет отключить аспи вообще в системе, это из-за него.
nano /etc/default/grub
в строке
GRUB_CMDLINE_LINUX_DEFAULT=
добавить acpi=off
Должно быть чтото вроде - GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 2416
    • Просмотр профиля
Цитировать
костыли.. Через опу же все.
Через, специально для этого существующее, технологическое отверстие.
Цитировать
Должно быть чтото вроде - GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"
В принципе - тоже самое, но отверстие находится намного дальше от цели.

Оффлайн ZevSua

  • Новичок
  • *
  • Сообщений: 27
    • Просмотр профиля
В принципе - тоже самое, но отверстие находится намного дальше от цели.
ТАк все дело в том, что все выше сказанное топикстартером - мне не помогло.. нихира.
У меня было 4 в enabled
/sys/firmware/acpi/interrupts/gpe61
/sys/firmware/acpi/interrupts/gpe62
/sys/firmware/acpi/interrupts/gpe66
/sys/firmware/acpi/interrupts/gpe6F

Все повырубал, и нифига. я хз

p.s. Хотя я думал проще либо в биос вырубить ACPI нафиг, либо просто ядро обновить на более новое.
« Последнее редактирование: 02 Январь 2019, 04:05:49 от ZevSua »

 

Страница сгенерирована за 0.066 секунд. Запросов: 24.