Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Типографские символы. Блокировка экрана при запущенном Virtualbox  (Прочитано 2083 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Startsev

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
У меня Ubuntu 14.04. Имею два вопроса:

  • Как включить типографские символы? В настройках клавиатуры и ввода не нашел данного пункта
  • Ситуация. Запущен VirtualBox. В нем Windows 7. Клавиатура перехвачена VirtualBox. Ноутбук блокируется. И я не могу ввести пароль и даже поменять раскладку (мышка видимо тоже перехватывается). Как поступать в данной ситуации?

Решение для 1 вопроса:

1) sudo apt-get install gnome-tweak-tool2) В настройках Tweak → Typing а там

3)В обычных настройках системы → Keyboard → Typing → Alternative Characters Key: Right Alt
Все.

Решение для 2 вопроса:
Нажатие клавиши Right Ctrl и клавиатура снова будет под Ubuntu

ТС не появлялся на Форуме более полугода по состоянию на 13/07/2019 (последняя явка: 09/08/2017). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 13 Июль 2019, 23:50:56 от zg_nico »

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн Startsev

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
setxkbmap -query?
Спасибо, попробую в следующий раз

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Вывод команды выложить сюда.
По Виртуалбоксу стандартная клавиша освобождения мыши — правый Контрол
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн Startsev

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
rules:      evdev
model:      pc105
layout:     ru,us
variant:    ,

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
А последняя строка? С options: ?
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн Startsev

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
А последняя строка? С options: ?
Нет ее в выводе

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
А что Вы такого сделали? Раскладка хоть переключается?
Типографские символы в общем случае можно включить такsudo setxkbdmap -option lv3:ralt_switch_multikey -option misc:typo
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн Startsev

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
А что Вы такого сделали? Раскладка хоть переключается?
Типографские символы в общем случае можно включить такsudo setxkbdmap -option lv3:ralt_switch_multikey -option misc:typo

Даже на голой системе это нормальный выхлоп для команды.
И ваша команда не помогла

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Попробуйте без sudo
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн Startsev

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Попробуйте без sudo
Готовился смеяться с вашего совета, но он сработал. Почему так?

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Это я "тормознул"… EUID для команд с sudo — это 0, т.е. root, что означает что параметры Вы поменяли не для себя, а другого пользователя, в данном случае root.
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн Startsev

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Это я "тормознул"… EUID для команд с sudo — это 0, т.е. root, что означает что параметры Вы поменяли не для себя, а другого пользователя, в данном случае root.

Эта команда работает, но до того момента, как переключишь раскладку. Затем все сбивается. Может ее в какой-то файл прописать надо?

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 6017
  • Windows10, i3wm on Debian9, Manjaro20.0
    • Просмотр профиля
Пока ещё не выяснил что там "намутили" в 14.04… Баг с раскладкой (в различных вариантах по отзывам форумчан тянется ещё с 13.10). Что у Васgsettings list-recursively org.gnome.libgnomekbd.keyboard
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн Startsev

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Пока ещё не выяснил что там "намутили" в 14.04… Баг с раскладкой (в различных вариантах по отзывам форумчан тянется ещё с 13.10). Что у Васgsettings list-recursively org.gnome.libgnomekbd.keyboard
org.gnome.libgnomekbd.keyboard layouts @as []
org.gnome.libgnomekbd.keyboard model ''
org.gnome.libgnomekbd.keyboard options @as []

 

Страница сгенерирована за 0.085 секунд. Запросов: 24.