Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: acestream на ubuntu 14.04  (Прочитано 34423 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vanili

  • Автор темы
  • Участник
  • *
  • Сообщений: 142
    • Просмотр профиля
acestream на ubuntu 14.04
« : 19 Апрель 2014, 20:55:32 »
Установил ubuntu 14.04, попытался установить acestream из репозитория для  Ubuntu 13.04 и 13.10.

в итоге
The following packages have unmet dependencies:
 acestream-engine : Depends: python2.7-apsw but it is not installable

на сколько я понял этого пакета вообще нет, но есть пакет python-apsw, установка которого проблему не решила.

Что делать? Есть возможность утсановить  acestream на Ubuntu 14.04?

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2679
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #1 : 19 Апрель 2014, 21:51:58 »
Есть возможность утсановить  acestream на Ubuntu 14.04?
Зачем?
Устанавливал, поигрался, удалил. Не юзабельно.
Обратится к разрабам наверное.
Intel Core i3-3240 3.40GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, KINGSTON SV300S37A240G, Kubuntu 20.04

Оффлайн vanili

  • Автор темы
  • Участник
  • *
  • Сообщений: 142
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #2 : 19 Апрель 2014, 21:54:46 »
не юзабельно - это про что? про 14.04 или acestream?

Вам удалось установить? Как?

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2679
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #3 : 19 Апрель 2014, 21:59:33 »
Про acestream, не юзабельно.
Я же написал к разрабам обратится, пусть deb пакет соберут под 14.04.

Intel Core i3-3240 3.40GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, KINGSTON SV300S37A240G, Kubuntu 20.04

Оффлайн vanili

  • Автор темы
  • Участник
  • *
  • Сообщений: 142
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #4 : 20 Апрель 2014, 00:28:28 »
уже написал...

Оффлайн rada-07

  • Участник
  • *
  • Сообщений: 173
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #5 : 20 Апрель 2014, 09:17:07 »
Цитировать
Вам удалось установить? Как?
Устанавливал в Ubuntu Gnome14.04beta2!Скачивал в google пакеты
(Нажмите, чтобы показать/скрыть)
и устанавливал по отдельности.Посмотри еще здесь
(Нажмите, чтобы показать/скрыть)
и во вложениях!
« Последнее редактирование: 20 Апрель 2014, 09:23:53 от rada-07 »

Оффлайн vanili

  • Автор темы
  • Участник
  • *
  • Сообщений: 142
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #6 : 20 Апрель 2014, 14:00:14 »
спасибо, попробую

Работает
« Последнее редактирование: 21 Апрель 2014, 17:09:12 от vanili »

Оффлайн rada-07

  • Участник
  • *
  • Сообщений: 173
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #7 : 21 Апрель 2014, 23:00:19 »
Да,я уже видел на форуме compizomania!(Второй способ установки очень интересный!)Будем надеяться,что Уважаемый Максим Пузырев обновит свою статью в Wiki по установке и настройке Acestream в Ubuntu14.04!
vanili! Если сохранилась подробная установка выложи здесь на форуме,может кому пригодится!
« Последнее редактирование: 22 Апрель 2014, 06:55:38 от rada-07 »

Оффлайн blackknight

  • Новичок
  • *
  • Сообщений: 28
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #8 : 01 Май 2014, 10:39:55 »
Цитировать
Установка AceStream TV в Ubuntu 14.04 (64-bit)

Так как репозиторий AceStream TV для Ubuntu 14.04 пока не создан, подключаем репозиторий Ubuntu 13.04:

echo 'deb http://repo.acestream.org/ubuntu/ raring main' | sudo tee /etc/apt/sources.list.d/acestream.list
Устанавливаем публичный ключ к репозиторию:

sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add -
Обновляем пакетную базу следующей командой:

sudo apt-get update
Далее необходимо загрузить архив с acestream-engine и всеми зависимостями по следующей ссылке и распаковать его Домашнюю папку:

https://drive.google.com/file/d/0Bw2xofe4Yj9veDMwUlFXN2w1akE/edit?usp=sharing



После как архив загружен и распакован, переходим в папку Ace-stream-U14.04 и устанавливаем его следующими командами:

cd Ace-stream-U14.04
sudo dpkg -i acestream-engine-fix-Ubuntu_14.04.deb

Возможно в терминале появится извещение о невозможности установки acestream-engine ввиду неустановленных пакетов: python-apsw и python-m2crypto выполните эту команду:

sudo apt-get install python-apsw python-m2crypto
Устанавливаем необходимые зависимости.

Для систем 64-bit:

cd /tmp && wget http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavutil-extra-51_0.8.10ubuntu0.12.04.1_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/libd/libdvbpsi/libdvbpsi7_0.2.2-1_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/libe/libebml/libebml3_1.2.2-2_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/libm/libmatroska/libmatroska5_1.3.0-1_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/x/x264/libx264-120_0.120.2151+gita3f4407-2_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/x/x264/libx264-123_0.123.2189+git35cf912-1_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavcodec-extra-53_0.8.10ubuntu0.12.04.1_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavformat-extra-53_0.8.10ubuntu0.12.04.1_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavdevice-extra-53_0.8.10ubuntu0.12.04.1_amd64.deb && sudo dpkg -i *.deb

Устанавливаем все необходимые компоненты acestream следующей командой:

sudo apt-get install acestream-full
И последнее. Необходимо заблокировать обновление acestream-engine. Проще всего это сделать через Synaptic. Находим пакет acestream-engine, выбираем его, в меню Пакет выбираем пункт Заблокировать версию

Цитировать
Для систем 32-bit:

Владимир Маслов 30 апреля 2014 г., 9:28

Я отредактировал архив и названия файлов таким образом, чтобы эта инструкция из шапки полностью подходила и к 32 бит системам, при той лишь разнице, что при установке зависимостей в окончаниях названий пакетов поменять amd64 на i386.

Т.е. будет выглядеть далее, после
sudo apt updateтак:

Далее необходимо загрузить архив с acestream-engine и всеми зависимостями по следующей ссылке и распаковать его в Домашнюю папку:

https://drive.google.com/file/d/0B4jvnqKcp7LmQWZWcUJkUDhxRTg/edit?usp=sharing


После как архив загружен и распакован, переходим в папку Ace-stream-U14.04 и устанавливаем его следующими командами:

cd Ace-stream-U14.04
sudo dpkg -i acestream-engine-fix-Ubuntu_14.04.deb

Возможно в терминале появится извещение о невозможности установки acestream-engine ввиду неустановленных пакетов: python-apsw и python-m2crypto выполните эту команду:

sudo apt-get install python-apsw python-m2crypto
(или: эти пакеты, после распаковки архива на первой стадии, будут в папке Ace-stream-U14.04 и их можно установить установщиком gdebi-gtk вручную. Если он у вас не установлен, то устанавливаем: sudo apt install gdebi)

Устанавливаем необходимые зависимости.

cd /tmp && wget http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavutil-extra-51_0.8.10ubuntu0.12.04.1_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/libd/libdvbpsi/libdvbpsi7_0.2.2-1_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/libe/libebml/libebml3_1.2.2-2_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/libm/libmatroska/libmatroska5_1.3.0-1_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/x/x264/libx264-120_0.120.2151+gita3f4407-2_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/x/x264/libx264-123_0.123.2189+git35cf912-1_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavcodec-extra-53_0.8.10ubuntu0.12.04.1_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavformat-extra-53_0.8.10ubuntu0.12.04.1_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavdevice-extra-53_0.8.10ubuntu0.12.04.1_i386.deb && sudo dpkg -i *.deb
или все вышеуказанные и другие необходимые зависимости устанавливаем из папки Ace-stream-U14.04 (результат распаковки Вами скачанного архива) установщиком .deb-пакетов gdebi-gtk.

Устанавливаем все необходимые компоненты acestream следующей командой:

sudo apt-get install acestream-fullили по отдельности
sudo apt install acestream-mozilla-pluginsudo apt install acestream-playersudo apt install acestream-player-data
или, эти .deb-пакеты из папки Ace-stream-U14.04 (результат распаковки Вами скачанного архива) установщиком .deb-пакетов gdebi-gtk.

И последнее. Необходимо заблокировать обновление acestream-engine. Проще всего это сделать через Synaptic. Находим пакет acestream-engine, выбираем его, в меню: - Пакет выбираем пункт: - Заблокировать версию.
(c) Compizomania

Работает в Google Chrome (Ubuntu 14.04 64bit). :)
« Последнее редактирование: 01 Май 2014, 10:49:01 от blackknight »

Оффлайн rada-07

  • Участник
  • *
  • Сообщений: 173
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #9 : 01 Май 2014, 20:38:31 »
Спасибо, blackknight!У меня в U14.04,DE Cinnamon(32bit), AceStream TV работает,если что обращайтесь!
« Последнее редактирование: 01 Май 2014, 20:51:04 от rada-07 »

Оффлайн Advokat74

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #10 : 05 Июль 2014, 11:27:06 »
sudo apt install acestream-full
[sudo] password for max:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 acestream-full : Зависит: acestream-player (>= 2.1.6-1raring2) но он не будет установлен
                  Зависит: acestream-mozilla-plugin (>= 2.1.6-1raring2) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
Каждый год мы с друзьями кодим баги. Canonical.

Оффлайн rada-07

  • Участник
  • *
  • Сообщений: 173
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #11 : 05 Июль 2014, 22:33:17 »
MaxMIxPro, Посмотри здесь, особенно комментарии,и о своей системе поподробнее!
« Последнее редактирование: 05 Июль 2014, 23:06:00 от rada-07 »

Оффлайн mokut

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #12 : 31 Июль 2014, 09:36:21 »
обращаюсь...руки у меня кривые то конечно.
всяко извращался...но 
Цитировать
Пакеты, имеющие неудовлетворённые зависимости:
 acestream-full : Зависит: acestream-player (>= 2.1.6-1raring2) но он не будет установлен
                  Зависит: acestream-mozilla-plugin (>= 2.1.6-1raring2) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
будьте уж так любезны,пошагово с начала и до конца ваш удачный вариант предоставьте
Цитировать
Kubuntu14.04 архитектура 32бит

Оффлайн rada-07

  • Участник
  • *
  • Сообщений: 173
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #13 : 01 Август 2014, 00:06:44 »
Ну,что же, давайте попробуем вместе! Благо, что в очередной раз снес систему ,перестановил, и все приходится устанавливать с ноля, в т.ч. и Ase Stream!
Итак, имею Aser Extensa 5220, U14.04 (32 bit), DE Cinnamon 2.3.0, ядро 3.14.2-031402-lowlatency,браузеры Firefox 31.0,Opera 12.16.
1) Заходим (Ctr+Alt+T) в терминал и  подключаем репозиторий Ubuntu 13.04, т.е после
(вместо rada у Вас свой user)
 rada@rada-Extensa-5220:~$
копируем(Ctr+Ins) и вставляем(Shift+Ins)
echo 'deb http://repo.acestream.org/ubuntu/ raring main' | sudo tee /etc/apt/sources.list.d/acestream.list
2) [sudo] password for rada: (вводим свой пароль-он не отображается!),нажимаем Enter,
3)Устанавливаем в терминале публичный ключ к репозиторию:
sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add -
жмем Enter, и по окончанию
4) Обновляем пакетную базу  командой: sudo apt-get update
5) Затем, не закрывая терминал, качаем по ссылке:
https://docs.google.com/file/d/0B4jvnqKcp7LmYjhRbnQ3ZFlycGs/edit
acestream-engine, т.е. пакет acestream.deb, заходим в Nautilus в Загрузки и устанавливаем пакет( я установил с помощью установщика Gdebi, хотя можно и Центром приложений).
6) Далее, самое главное, устраняем возможные зависимости, т.е, заходим в открытый терминал и выполняем команду:
cd /tmp && wget http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavutil-extra-51_0.8.10ubuntu0.12.04.1_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/libd/libdvbpsi/libdvbpsi7_0.2.2-1_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/libe/libebml/libebml3_1.2.2-2_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/libm/libmatroska/libmatroska5_1.3.0-1_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/x/x264/libx264-120_0.120.2151+gita3f4407-2_i386.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/x/x264/libx264-123_0.123.2189+git35cf912-1_i386.deb http://mirrors.kernel.org/ubuntu/pool/universe/liba/libav-extra/libavcodec-extra-53_0.8.10ubuntu0.12.04.1_i386.deb http://mirrors.kernel.org/ubuntu/pool/universe/liba/libav-extra/libavformat-extra-53_0.8.10ubuntu0.12.04.1_i386.deb http://mirrors.kernel.org/ubuntu/pool/universe/liba/libav-extra/libavdevice-extra-53_0.8.10ubuntu0.12.04.1_i386.deb && sudo dpkg -i *.deb
7) По окончании устанавливаем  остальные компоненты AceStream в терминале командой:
sudo apt-get install acestream-full
8) После этого терминал можно закрыть,но!!!
Обязательно заходим в Synaptic, в Поиске забиваем acestream-engine, выбираем его, вверху в меню Пакет ставим галку в  пункте Заблокировать версию, и закрываем  Synaptic!
Вот и все.
Заходим в http://torrent-tv.ru/index.php, тестируем и смотрим ТВ!
После каждой команды внимательно смотрите терминал,если все O.K, выполняйте следующую.
Удачи!
« Последнее редактирование: 01 Август 2014, 18:52:27 от rada-07 »

Оффлайн mokut

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: acestream на ubuntu 14.04
« Ответ #14 : 01 Август 2014, 07:13:03 »
доброго времени...
чтож всё то ...после установки зависимостей
Цитировать
--2014-08-01 09:07:43--  http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavcodec-extra-53_0.8.10ubuntu0.12.04.1_i386.deb
Повторное использование соединения с cz.archive.ubuntu.com:80.
HTTP-запрос отправлен. Ожидание ответа... 404 Not Found
2014-08-01 09:07:43 ОШИБКА 404: Not Found.

--2014-08-01 09:07:43--  http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavformat-extra-53_0.8.10ubuntu0.12.04.1_i386.deb
Повторное использование соединения с cz.archive.ubuntu.com:80.
HTTP-запрос отправлен. Ожидание ответа... 404 Not Found
2014-08-01 09:07:43 ОШИБКА 404: Not Found.

--2014-08-01 09:07:43--  http://cz.archive.ubuntu.com/ubuntu/pool/universe/liba/libav-extra/libavdevice-extra-53_0.8.10ubuntu0.12.04.1_i386.deb
Повторное использование соединения с cz.archive.ubuntu.com:80.
HTTP-запрос отправлен. Ожидание ответа... 404 Not Found
2014-08-01 09:07:43 ОШИБКА 404: Not Found.

и дальше соответственно
Цитировать
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 acestream-full : Зависит: acestream-player (>= 2.1.6-1raring2) но он не будет установлен
                  Зависит: acestream-mozilla-plugin (>= 2.1.6-1raring2) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
...замкнутый круг

 

Страница сгенерирована за 0.341 секунд. Запросов: 24.