Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Раскладка клавиатуры в RDP  (Прочитано 5606 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн UnnamedUser

  • Автор темы
  • Активист
  • *
  • Сообщений: 287
    • Просмотр профиля
Раскладка клавиатуры в RDP
« : 23 Апрель 2014, 16:44:29 »
Друзья. помогите.
Поставил на сервер RDP по этому мануалу
http://infostart.ru/public/196375/
В конце вроде написано как исправить косяк с клавиатурой.
- не помогло.

поковырялся еще в инете, нашел вот это
http://debuntu.ru/note/v-lxde-net-russkoy-raskladki

Не помогло.
Что может быть?

Оффлайн Виктор Перестукин

  • Старожил
  • *
  • Сообщений: 2153
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #1 : 23 Апрель 2014, 18:01:58 »
UnnamedUser,
Как себя проявляет "косяк"?
На lxpanel есть апплет, который сейчас называется "Обработчик раскладки клавиатуры", а раньше был известен под именем "Индикатор раскладки клавиатуры". Есть он у Вас? С его помощью (кликом) можно переключить раскладку?
Или "косяк" означает что-то другое?

Оффлайн UnnamedUser

  • Автор темы
  • Активист
  • *
  • Сообщений: 287
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #2 : 23 Апрель 2014, 18:08:50 »
Индикатор есть, называется "Индикатор раскладок клавиатуры"
После вышеописанных манипуляций. флажок русской раскладки появился, по клику переключается.
А чтобы переключалось например по ctrl_shift - не могу настроить.

Если это поможет делу, то я ставил LXDE на серверную Ubuntu 12.04 как описано в первой ссылке в первом посте
« Последнее редактирование: 23 Апрель 2014, 18:10:29 от UnnamedUser »

Оффлайн Виктор Перестукин

  • Старожил
  • *
  • Сообщений: 2153
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #3 : 23 Апрель 2014, 18:54:59 »
ОК! Уберите свои костыли и попробуйте править файл /etc/default/keyboard. Как, здесь написано:
http://www.lubuntu.ru/forum/viewtopic.php?f=15&t=499

Оффлайн UnnamedUser

  • Автор темы
  • Активист
  • *
  • Сообщений: 287
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #4 : 23 Апрель 2014, 19:16:58 »
а он у меня изначально в таком виде как по этой ссылке

Оффлайн Виктор Перестукин

  • Старожил
  • *
  • Сообщений: 2153
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #5 : 23 Апрель 2014, 20:05:45 »
В чём всё-таки проявляется косяк?
Косяк появился, когда пользователя подключили?

Оффлайн UnnamedUser

  • Автор темы
  • Активист
  • *
  • Сообщений: 287
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #6 : 23 Апрель 2014, 21:25:27 »
Косяк только при подключении по RDP.  И на виртуалке в VirtualBox и на боевой машине. На виртуалке снес LXDE  , поставил другой DE - нормально все работает.
Может быть LXDE неправильно понимает сигналы по RDP?


Пользователь решил продолжить мысль 23 Апрель 2014, 21:34:50:
Забыл упомянуть: когда уже собственно рабочий стол по RDP загружен. В консолей ввожу вот это ( это из первой ссылки код)
setxkbmap -option grp:switch,grp:alt_shift_toggle us,ru
Все работает. Хотелось бы чтобы автоматом работало. Я же не скажу всем чтобы перед работой надо загрузить терминал и написать вот эту строчку. При слове терминал уже всех трясти начинает
« Последнее редактирование: 23 Апрель 2014, 21:34:50 от UnnamedUser »

Оффлайн Виктор Перестукин

  • Старожил
  • *
  • Сообщений: 2153
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #7 : 24 Апрель 2014, 06:59:45 »
Если честно. то я в первый раз вижу сочетание RDP, поэтому от меня, наверное, никакого толку.
У Вас есть ещё файлы autostart?

А для чего grp:switch?

Оффлайн UnnamedUser

  • Автор темы
  • Активист
  • *
  • Сообщений: 287
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #8 : 24 Апрель 2014, 13:05:04 »
Если честно. то я в первый раз вижу сочетание RDP, поэтому от меня, наверное, никакого толку.
У Вас есть ещё файлы autostart?

А для чего grp:switch?
grp:switch для быстрого переключения языков. т.е. пока держишь, язык поменялся на другой, отпустил язык переключился на первоначальный. ставится на клавишу alt, который справа
да есть еще
karamin@craftsvr:~$ locate autostart
/etc/xdg/autostart
/etc/xdg/autostart/gnome-keyring-gpg.desktop
/etc/xdg/autostart/gnome-keyring-pkcs11.desktop
/etc/xdg/autostart/gnome-keyring-secrets.desktop
/etc/xdg/autostart/gnome-keyring-ssh.desktop
/etc/xdg/autostart/gsettings-data-convert.desktop
/etc/xdg/autostart/notification-daemon.desktop
/etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop
/etc/xdg/lxsession/LXDE/autostart
/etc/xdg/openbox/autostart
/usr/lib/openbox/openbox-autostart
/usr/lib/openbox/openbox-xdg-autostart
karamin@craftsvr:~$

но дело в том, что два языка то появляются, значит читается файл призагрузке.
если все костыли убрать то просто даже русского не будет, остается один английский.
Этот косяк проявляется только через RDP
Ставил на виртуалку VirtualBox - все работает когда просто в систему заходишь. Когда через RDP та же хрень.
На сервере нет ни мышки ни клавы ни монитора, поэтому проверить не могу, но у верен, что если зайти в систему напрямую, то все будет ок

Оффлайн Виктор Перестукин

  • Старожил
  • *
  • Сообщений: 2153
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #9 : 24 Апрель 2014, 17:28:47 »
Это я почему спрашивал. Вот здесь:
http://www.lubuntu.ru/forum/viewtopic.php?f=15&t=499&start=70#p12388
пользователь в два файла прописал и какой-то сработал. :D

А что у Вас показывает:
setxkbmap -query

Оффлайн UnnamedUser

  • Автор темы
  • Активист
  • *
  • Сообщений: 287
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #10 : 24 Апрель 2014, 18:25:32 »
А что у Вас показывает:
setxkbmap -query
вот так показывает
karamin@craftsvr:~$ setxkbmap -query
rules:      evdev
model:      pc104
layout:     us
причем так же показывает, когда прописываешь в autostart
setxkbmap -layout us,ruи при клике меняется раскладка а вывов -query тот же

если записывать в autostart
setxkbmap -option grp:alt_shift_toggle us,ruто вывод опять же не меняется, но по клику раскладка меняется

Пользователь решил продолжить мысль 24 Апрель 2014, 18:28:35:
Это я почему спрашивал. Вот здесь:
http://www.lubuntu.ru/forum/viewtopic.php?f=15&t=499&start=70#p12388
пользователь в два файла прописал и какой-то сработал. :D

попробовал поменять в файлах
/etc/xdg/autostart
/etc/xdg/openbox/autostart
ничего не меняется, ну тоесть статичный американский флажок, даже по клику не меняется,
вывод -query опять тот же.

в других файлах не менял, не может же быть там ничего, я думаю..
хотя надо проверить будет
« Последнее редактирование: 24 Апрель 2014, 18:28:35 от UnnamedUser »

Оффлайн Виктор Перестукин

  • Старожил
  • *
  • Сообщений: 2153
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #11 : 25 Апрель 2014, 06:42:55 »
Нашёл тему с аналогичной проблемой ("rdp"), но без решения:
http://www.lubuntu.ru/forum/viewtopic.php?t=809

Можно попробовать прописать параметры переключения раскладки в xorg.conf, точнее в одном из файлов каталога /usr/share/X11/xorg.conf.d/.

PS
А если прописать setxkbmap в локальный autostart?
« Последнее редактирование: 25 Апрель 2014, 06:52:21 от Виктор Перестукин »

Оффлайн UnnamedUser

  • Автор темы
  • Активист
  • *
  • Сообщений: 287
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #12 : 25 Апрель 2014, 10:27:37 »
PS
А если прописать setxkbmap в локальный autostart?
а какой из найденных считается локальным?

Оффлайн Виктор Перестукин

  • Старожил
  • *
  • Сообщений: 2153
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #13 : 25 Апрель 2014, 10:46:21 »
А в RDP у пользователя есть домашний каталог? Если есть, то там. Изначально его может и не быть.
Вот у меня здесь:
/home/user_name/.config/lxsession/Lubuntu/autostart

Оффлайн UnnamedUser

  • Автор темы
  • Активист
  • *
  • Сообщений: 287
    • Просмотр профиля
Re: Раскладка клавиатуры в RDP
« Ответ #14 : 25 Апрель 2014, 12:08:01 »
А в RDP у пользователя есть домашний каталог? Если есть, то там. Изначально его может и не быть.
Вот у меня здесь:
/home/user_name/.config/lxsession/Lubuntu/autostart
да, не было такого.
Сделал файлик, прописал в него
@sexkbmap -layout "us,ru" -option "grp:alt_shift_toggle us,ru"все так же: раскладку подхватывает, а переключение по клавишам нет.
может я че не тот какой нибудь параметр задаю. раскладку то он хавает, появляется русский язык.

на setxkbmap -queryотвечает, что только раскладка us
в общем как обычно

может скриптик какой нибудь написать, чтобы после загрузки прописывал команду?
« Последнее редактирование: 25 Апрель 2014, 12:10:33 от UnnamedUser »

 

Страница сгенерирована за 0.061 секунд. Запросов: 24.