Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Не могу увеличить время выполнения на скрипт  (Прочитано 2233 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн serhy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 46
    • Просмотр профиля
Всем привет!

Ubuntu server 12.04 + ISPconfig(MAIL-WEB-FTP-DNS-MySQL).
Вот уже долгое время не могу увеличить время выполнения в следующих параметрах
max_execution_time 30
max_input_time 60
connect_timeout 10

Пробовал править значения в файлах, но безрезультатно
/etc/php5/apache2/php.ini
/etc/php5/cgi/php.ini

Далее в самой панели ISPconfig добавлял директивы Apache:
php_value max_execution_time 360
php_value max_input_time 360

Работает только при режиме Mod-PHP.

Но нужен режим Fast-CGI. Нашел в гугле, что для режима Fast-CGI в панели ISPconfig нужно в поле Custom php.ini settings (Пользовательские настройки php.ini) добавлять следующее
max_execution_time 360
max_input_time 360

не помогло.

Подскажите пож в каком месте еще могут быть эти строчки? Или еще лучше как правильно будет прописать эти параметры в панели ISPconfig?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 27665
    • Просмотр профиля
Вообще-то если вы пишите в php.ini, строчки должны быть
max_execution_time=360
Ref: http://ru2.php.net/manual/en/configuration.file.php

Но... если вам нужно ТАК ДОЛГО что-то делать, не лучше ли запустить этот скрипт в консоли?
PHP CLI в принципе не имеет ограничения по времени работы скрипта.
Ref: http://ru2.php.net/manual/en/features.commandline.differences.php
« Последнее редактирование: 27 Апрель 2014, 20:19:33 от AnrDaemon »
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн serhy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 46
    • Просмотр профиля
Вообще-то если вы пишите в php.ini, строчки должны быть
max_execution_time=360

Спасибо AnrDaemon! Капец как же я жестко стормозил... прописал в поле Custom php.ini settings
max_execution_time=360
max_input_time=360
и все заработало, даже не верится, вроде пробовал так... может забыл apache ребутнуть...
« Последнее редактирование: 27 Апрель 2014, 22:25:03 от serhy »

 

Страница сгенерирована за 0.063 секунд. Запросов: 25.