Форум русскоязычного сообщества Ubuntu


Автор Тема: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty  (Прочитано 2063 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nick222

  • Автор темы
  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« : 28 Мая 2014, 13:28:26 »
Здравствуйте!

При обновлении Xubuntu с 13.10 до 14.04 был почему-то автоматически удалён Wine.

После обновления системы при попытке установить с LP-PPA-Ubuntu-wine пакет Wine ставится версия 1.7.*, которая, при этом, предлагает снести почти весь софт с компа :) .

Из "официального" PPA Xubuntu пакет wine встаёт только установкой руками и только 1.6.* либо 1.4.* (нет метапакета wine просто, нужно явно указывать версию).

Но даже такой вариант требует снести nvidia-libopencl1-337 (как описано в https://forum.ubuntu.ru/index.php?topic=244403.0 , хотя у меня видеокарта гораздо старее, чем у автора той темы).

Никто не посоветует - имеет смысл ставить руками wine 1.6 (потом сносить и ставить 1.7, как выйдет) или ждать появления совместимой версии с Ubuntu-wine (и будет ли она)?

Не хотелось бы отказываться от LP-PPA-Ubuntu-wine , но и сидеть без wine тоже надоело...

Спасибо :)
Xubuntu 23.04

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 3023
    • Просмотр профиля
Re: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« Ответ #1 : 28 Мая 2014, 20:37:22 »
Установите wine-1.7.xx с http://www.winehq.org
Я в Ubuntu-14.04 так и сделал.
Пётр.

Оффлайн Nick222

  • Автор темы
  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« Ответ #2 : 29 Мая 2014, 07:44:28 »
Я оттуда и пытаюсь ставить (посмотрите внимательно), - а неразрешённые зависимости не дают этого сделать...
Xubuntu 23.04

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 3023
    • Просмотр профиля
Re: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« Ответ #3 : 29 Мая 2014, 08:39:25 »
Я оттуда и пытаюсь ставить (посмотрите внимательно), - а неразрешённые зависимости не дают этого сделать...
Я как-то не уловил, что это и есть оттуда.
У меня wine-1.7.18 в xubuntu установился через "apt-get install wine1.7",
при этом ничего другого не потребовалось.
Предварительно я подключил репозитарий. Драйвер nvidia-331 уже был установлен.
Пётр.

Оффлайн Nick222

  • Автор темы
  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« Ответ #4 : 29 Мая 2014, 09:39:42 »
Поясняю:

а) Я удалил nvidia-libopencl1-331 (не знаю, зачем он нужен), который требовал снести aptitude, вместо него встал ocl-icd-libopencl1
 
б) Далее при попытке установить через aptitude пакет wine, получаю:

Цитировать
Следующие пакеты имеют неудовлетворённые зависимости:
 liblcms2-2 : Ломает: liblcms2-2:i386 (!= 2.5-1) но будет установлен 2.5-0ubuntu4.
 liblcms2-2:i386 : Ломает: liblcms2-2 (!= 2.5-0ubuntu4) но установлен 2.5-1.

И предлагается:

Цитировать
Следующие действия разрешат зависимости:
Оставить для следующих пакетов их текущие версии:
1)     liblcms2-2:i386 [Не установлен]               
2)     wine [Не установлен]                           
3)     wine1.6 [Не установлен]                       
4)     wine1.6-amd64 [Не установлен]                 
5)     wine1.6-i386:i386 [Не установлен]

в) Если ставить не wine, а wine1.7, то сообщения 1, 3-5 те же самые (только номер пакета 1.7), но появляются ещё дополнительные варианты:

Цитировать
Оставить следующие зависимости неразрешёнными:     
5)     wine-gecko2.24 рекомендует wine1.5-amd64         
6)     wine-gecko2.24:i386 рекомендует wine1.5-i386:i386
Xubuntu 23.04

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 3023
    • Просмотр профиля
Re: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« Ответ #5 : 29 Мая 2014, 13:31:41 »
Попробуйте удалить установленный libcms ш повторить установку wine1.7.
Пётр.

Оффлайн Nick222

  • Автор темы
  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« Ответ #6 : 29 Мая 2014, 15:12:55 »
Невозможно - aptitude предлагает снести полсистемы...

***

Я руками принудительно понизил версию liblcms2-2 до 2.5-0, после чего установил пакет метапакет wine из PPA с предложенного Вами сайта - он, в свою очередь, поставил wine 1.6 из основного репозитория Xubuntu Trusty.
« Последнее редактирование: 29 Мая 2014, 15:17:41 от Nick222 »
Xubuntu 23.04

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1445
  • Ubuntu 16.04 LTS
    • Просмотр профиля
Re: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« Ответ #7 : 29 Мая 2014, 16:48:16 »
Невозможно - aptitude предлагает снести полсистемы...
Вот ещё один плюс в использовании apt-get, а не aptitude.

Оффлайн Nick222

  • Автор темы
  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« Ответ #8 : 29 Мая 2014, 17:13:38 »
apt-get предлагает ещё более плохой вариант :)
Xubuntu 23.04

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 3023
    • Просмотр профиля
Re: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« Ответ #9 : 29 Мая 2014, 17:24:38 »
Можно принудительно удалить пакет с помощью dpkg, можно установить тот, который требуется wine1.7
и потом удалить уже имеющийся. Для начала дайте команду
apt-get -f install
Пётр.

Оффлайн Nick222

  • Автор темы
  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: Wine из LP-PPA-Ubuntu-wine и Xubuntu 14.04 Trusty
« Ответ #10 : 29 Мая 2014, 17:33:26 »
Но я вроде уже решил проблему установкой предыдущей версии пакета (см.выше).
Xubuntu 23.04

 

Страница сгенерирована за 0.034 секунд. Запросов: 23.